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Preface
The Multidomain MDM Data Director User Guide explains how you can create, consume, manage, and monitor 
master data in Informatica® Data Director.

Informatica Resources
Informatica provides you with a range of product resources through the Informatica Network and other online 
portals. Use the resources to get the most from your Informatica products and solutions and to learn from 
other Informatica users and subject matter experts.

Informatica Network
The Informatica Network is the gateway to many resources, including the Informatica Knowledge Base and 
Informatica Global Customer Support. To enter the Informatica Network, visit 
https://network.informatica.com.

As an Informatica Network member, you have the following options:

• Search the Knowledge Base for product resources.

• View product availability information.

• Create and review your support cases.

• Find your local Informatica User Group Network and collaborate with your peers.

Informatica Knowledge Base
Use the Informatica Knowledge Base to find product resources such as how-to articles, best practices, video 
tutorials, and answers to frequently asked questions.

To search the Knowledge Base, visit https://search.informatica.com. If you have questions, comments, or 
ideas about the Knowledge Base, contact the Informatica Knowledge Base team at 
KB_Feedback@informatica.com.

Informatica Documentation
Use the Informatica Documentation Portal to explore an extensive library of documentation for current and 
recent product releases. To explore the Documentation Portal, visit https://docs.informatica.com.

Informatica maintains documentation for many products on the Informatica Knowledge Base in addition to 
the Documentation Portal. If you cannot find documentation for your product or product version on the 
Documentation Portal, search the Knowledge Base at https://search.informatica.com.
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If you have questions, comments, or ideas about the product documentation, contact the Informatica 
Documentation team at infa_documentation@informatica.com.

Informatica Product Availability Matrices
Product Availability Matrices (PAMs) indicate the versions of the operating systems, databases, and types of 
data sources and targets that a product release supports. You can browse the Informatica PAMs at 
https://network.informatica.com/community/informatica-network/product-availability-matrices.

Informatica Velocity
Informatica Velocity is a collection of tips and best practices developed by Informatica Professional Services 
and based on real-world experiences from hundreds of data management projects. Informatica Velocity 
represents the collective knowledge of Informatica consultants who work with organizations around the 
world to plan, develop, deploy, and maintain successful data management solutions.

You can find Informatica Velocity resources at http://velocity.informatica.com. If you have questions, 
comments, or ideas about Informatica Velocity, contact Informatica Professional Services at 
ips@informatica.com.

Informatica Marketplace
The Informatica Marketplace is a forum where you can find solutions that extend and enhance your 
Informatica implementations. Leverage any of the hundreds of solutions from Informatica developers and 
partners on the Marketplace to improve your productivity and speed up time to implementation on your 
projects. You can find the Informatica Marketplace at https://marketplace.informatica.com.

Informatica Global Customer Support
You can contact a Global Support Center by telephone or through the Informatica Network.

To find your local Informatica Global Customer Support telephone number, visit the Informatica website at 
the following link: 
https://www.informatica.com/services-and-training/customer-success-services/contact-us.html.

To find online support resources on the Informatica Network, visit https://network.informatica.com and 
select the eSupport option.
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C h a p t e r  1

Introduction
This chapter includes the following topics:

• Data Director Overview, 12

• Key Concepts, 13

• Logging in to Data Director, 17

• User Interface, 18

Data Director Overview
Data Director is a data governance tool. Use Data Director to create, manage, and use the master data that is 
stored in an MDM Hub Store. Master data is the collection of records that represent the best version of the 
truth about the people, places, and things that are important to your organization.

A master data domain is an area of data critical to the organization that is managed at the enterprise level to 
support semantic consistency across the organization. Common master data domains include Customer, 
Supplier, Location, Channel, Partner, Product, Asset, and General Ledger Account. Multidomain master data is 
the mastering of critical data across multiple master data domains concurrently. Multidomain MDM 
encompasses related master data domains that are central to an organization's business and business 
processes. The observations that arise out of multidomain master data are of significant interest to business 
executives. For example, in a healthcare organization, the relationships among doctors and healthcare sites 
might reveal gaps in services.

Your MDM administrator configured the application you use within Data Director. The MDM administrator 
implemented the master data domains by building data structures with a name that is meaningful for your 
organization. For example, Patient is an implementation of the Customer master data domain. The data 
structure relates records within a tree structure, with a root record, nodes, and child records. The MDM 
administrator can use one or both of the following data structures: business entities and subject areas. Each 
type of data structure comes with its own set of views for Data Director. Ask the MDM administrator which 
one is used in your application, and follow the instructions in the matching part.

This guide is organized into two parts that tell you how to use the available views:

• Data Director with Business Entities

• Data Director with Subject Areas

Based on your user role privileges, you can use the application to perform the following activities:

• Add records

• Find and edit records
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• Verify that records contain the most reliable data from all source systems

• Identify duplicate records and resolve them by merging the records

• Investigate changes to the data in records

• Unmerge merged records

• Manage relationships between records

• Participate in review processes for new and changed records

Key Concepts
To work effectively in Data Director, you need a basic understanding of Informatica Master Data Management 
concepts.

Records
When you use Data Director, you are working with master records.

Master Records

A master record contains a root record and multiple child records. In Data Director, the structure and 
display of the master records depends on the structure defined in either business entities or subject 
areas.

Root Records

The root record contains the data that identifies the record. For example, the root record for John Smith 
contains data such as first name, last name, gender, and date of birth.

Child Records

A child record contains data that is associated with a root record. For example, a child record for John 
Smith might contain addresses while another child record contains phone numbers. Child records can 
have their own child records.

Active Records

Active records contain approved master data.

Pending Records

When you make a change to a record, the change might need to go through a review workflow before it 
can be approved as master data. While the record is pending approval, the record is called a pending 
record and you are restricted in the actions that you can perform on a pending record. When the change 
is approved, the record returns to the active record state.

Source Records

Source records contain the data that MDM used to create the master records that you see in Data 
Director. Source records are stored in source systems throughout your organization.
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Business Entities
Business entities are an implementation of master data domains in your application. For example, the 
Customer master data domain can be implemented in the following types of business entities: Person, 
Patient, or Policy Holder.

The business entity data structure maps to the base object tables in the Operational Reference Store 
database. The base object tables contain all the master records. For example, the root node of a business 
entity corresponds to the root base object table. A child node in the business entity corresponds to a child 
base object table. Business entities can have an unlimited depth, though the views that display the child 
records might not be able to show all levels in a meaningful way beyond a certain depth. 

Related Topics:
• “Records” on page 13

• “Adding a Record” on page 32

• “Adding a Person Scenario” on page 31

• “Editing Records” on page 50

Subject Areas
Like business entities, a subject area is an implementation of a master data domain. Subject areas are the 
original data structure used in Data Director.

The data structure supports three levels: parent, child, and grandchild. The parent level corresponds to the 
root base object table. The child and grandchild levels are child records.

Note: Some applications for Data Director rely on the subject area data structure and custom code, and 
therefore have not been migrated to business entities. If you have questions about your application, contact 
your MDM administrator.

Best Version of the Truth
When you view a record in Data Director, you view master data that is consolidated from source systems in 
your organization, including Data Director. The MDM Hub loads data from the contributing source systems. 
The load process uses a trust framework and rules to decide which cells from all the contributing source 
systems are most likely to contain accurate, up-to-date data. The consolidated record represents the best 
version of the truth (BVT) that is available across your organization.

Note: A BVT record is also known as master data, a golden profile, or a golden record.

For example, consider a car manufacturer that offers an incentive program to employees to buy cars. To 
construct BVT customer records, the data steward identifies the contributing source systems as the 
customer relationship management (CRM) system and the human resources (HR) system. The data steward 
trusts the employee address and telephone number from the HR system more than the same information in 
the CRM system, because employees are required to notify the human resources department of any changes 
to their contact information.

Data Director is a special type of contributing source system. Usually, data stewards set Data Director to the 
highest trust level of all contributing systems, which means that when a user edits data in Data Director, the 
edit is preferred over other source systems. You can also choose to override the automated BVT process and 
select a cell value you know is accurate.
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For example, the following table shows data coming from two source systems and from Data Director:

Source Last Name First Name Telephone Telephone Trust

HR System Brown Nancy 555-1235 80

CRM System Brown Nancy null 50

Data Director Brown Nancy 555-1234 90

Because Data Director has the highest trust score for telephone numbers, the updated telephone number is 
used. The data steward can add rules that cause the trust value to increase or decrease for a system. For 
example, if the telephone number is subsequently updated in the HR system, the system might prefer that 
telephone number because it was updated most recently.

Search and Compare
A best practice in data governance is to check for existing records before adding new records. When you 
begin adding a record, Data Director (IDD) searches for duplicate records.

You can preview the potential duplicate records as they appear and take one of the following actions:

• If more than one record is a potential match for the record you are adding, you can compare the records 
side by side. If you find that the records are duplicates, you can initiate a merge.

• If one record matches the record you are adding, you can open the record and begin working with it. In this 
case, the record that you started adding is discarded.

• If none of the records is a match, you can continue adding the new record.

The MDM administrator configures the fields to use in the search for potential duplicates. 

Merge
After you compare records, you can merge records that appear to be duplicated.

When you merge a record, the root records of the merged record are consolidated into a single root record. 
The child records from each of the root records become child records of the merged root record. 

Related Topics:
• “Resolving Duplicate Records” on page 56

Review Processes and Tasks
A review process is an automated business process. When a user adds, edits, merges, or unmerges records, 
the action can initiate a review process. A review process ensures that business managers or data stewards 
review and ultimately approve the data before it becomes master data. 

Your user role determines whether a change to the master data triggers a review. For example, if your user 
role permits you to add or edit data but not approve changes, then when you save an edit or merge records, 
the action triggers a review process.

A review process contains people activities. A people activity is a point in the review process when the 
process requires human participation. When an instance of a review process reaches a people activity, the 
review process sends a task notification. Business managers and data stewards receive task notifications in 
their task inboxes. 
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Related Topics:
• “Participating in Review Processes” on page 140

• “Example of a Review Process for Edits” on page 140

Hierarchies and Relationships
A record can have relationships to other records. When the Hierarchy Manager is enabled, you can view a 
graph that shows how a record is related to other records.

You use the Hierarchy view to investigate relationships. You can view hierarchical relationships, such as an 
employer-employee relationship, as well as relationships that are not hierarchical, such as peer relationships.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

Related Topics:
• “Investigating Hierarchies and Relationships” on page 125

Security and User Roles
An MDM administrator creates user roles, configures permissions to resources and privileges for the user 
roles, and assigns a user role to all user accounts. Based on your job requirements, your access to master 
data might be different than your colleagues.

Types of security for business entities records

The following types of security exist:

Access to records based on the type of business entity

A user role is granted permission to all types of business entities or some types of business entities. For 
example, you can see the types of business entities that you have permission to create in the New dialog 
box. You might have access to the business entities Customer and Product, but someone else might 
have access to the business entities Product and Supplier.

Actions you can perform on a record

Your user role grants you a set privileges to the records for each type of the business entities. For 
example, a business user might have permission to read and create Customer records, but a data 
steward might also be able to delete and merge Customer records. The privileges can be different for 
different types of business entities.

In Data Director, your user role privileges control the types of actions you can perform:

• Create. You can create and save new master records.

• Read. You can view master records.

• Update. You can edit and save records.

• Delete. You can delete master records.

• Merge. You can identity and merge duplicate master records.

• Unmerge. You can unmerge a previously merged master record.

Access to records when a field contains a specified value

Your user role privileges might be constrained by field filters, which control whether you have access to 
the master record based on a value in a field. If a record contains a value specified in a field filter, the 
user roles are allowed or denied access to the record based on the rules that are defined in the filter.
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Access to a parent record when a child node has no records

Your user role privileges might be constrained by node filters, which control whether you have access to 
a parent record when the node contains no child records.

Access to fields in a record

Some fields might be hidden from your user role. For example, a view of a Supplier business entity might 
show a DUNs number to people in the finance department, but not to people in the line of business.

Values you can input

Some fields might restrict the values that you can select or add based on your user role.

Values in reference entities

Some fields might restrict the values that you can select from a list of common values, such as country 
or gender, based on your user role.

Losing access to records

You might lose access to a record that you have accessed in the past.

A loss of access can occur under the following circumstances:

• You or someone else makes a change to a field value such that the record is now denied to your user role. 
For example, you add a European address to a person record and enable the GDPR check box. After you 
save the change, only the EU data stewards can access the person record.

• The MDM administrator creates new field filters or node filters on a business entity. One or more of the 
filters contain a rule that denies access to your user role.

• The MDM administrator changed the user role to which you were assigned.

• The MDM administrator modified the privileges for your assigned user role.

Logging in to Data Director
To log in, you need the URL for Data Director and your user credentials. If your organization has created more 
than one application for Data Director, you also need the name of the application. If you do not have this 
information, contact your MDM administrator.

Note: If you cannot log in to the application and you are already running another MDM application in the 
browser, open a new browser window to log in to the application. The issue occurs because the application 
server that runs the MDM Hub uses the same session ID for both applications. 

1. Open a supported browser, such as Chrome. 

2. Enter the URL for Data Director. The URL has the following format: 

http://<MDM Server host name>:<MDM Server port number>/e360/mdm/entity360view/
The Log In page opens. 

3. Enter your user name and password. 

4. Click Log In. 

5. If prompted, select an application. 

The application opens and displays the Home page. Your username appears in the application header. 

Tip: From the menu beside your username, you can change your password and change the language of 
the user interface.
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Configuring Microsoft Internet Explorer
If you launch Data Director in Microsoft Internet Explorer, to ensure that the data changes appear in the user 
interface, configure Microsoft Internet Explorer to reload the web pages. Otherwise, after a data change, you 
might see the cached data instead of the latest data.

1. Start Microsoft Internet Explorer. 

2. Click Tools > Internet options. 

3. On the General tab, configure the browsing history settings to check for newer versions of stored web 
pages every time you visit the web page. 

The settings ensure that the latest version of the Data Director pages appear.

User Interface
The Data Director user interface contains a navigation bar with tabs.

The following image shows the user interface with the Home page displayed:

1. Navigation bar
2. Page area
3. Search box
4. User options

The navigation bar contains tabs that link to pages within Data Director. A tab contains a page area with one 
or more panels. In some tabs, you can switch between different views within the page.

Note: Some tabs might not be visible in Data Director. For example, if the MDM administrator configures an 
application for Data Director with business entities, the MDM administrator might remove the Data tab.

Data Director has the following tabs:

New

Use the New tab to create records, and, if configured, import data.

Note: In the New window, if you see both the Business Entity option and Subject Area option, ask the 
MDM administrator which one to use. The Business Entity option opens an entity tab while the Subject 
Area option opens the Data tab.
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Home

Use the Home page as your MDM dashboard. Managers and data stewards can view a list of review 
tasks in the task inbox. You might see other components, such as social media feeds, external URLs, and 
reports that display master data. The MDM administrator configures the Home page.

Task Manager

Managers and data stewards use the Task Manager to review changes to business entity records. When 
you click a task in the Home page, the Task Manager opens and displays the record associated with the 
task.

Data

Use the Data tab to search for and view subject area records from different perspectives.

Note: If a Data Director application uses business entities and the Data tab is hidden, the records open in 
an entity tab that displays the name of the business entity type.

The Data tab has multiple views:

• To find a subject area record, run a search query from the Data tab. Use search tabs to manage and 
use search queries to find subject area records.

Note: If a Data Director application uses business entities and the Data tab is hidden, use the Search 
tab or Search box.

• To view and edit a subject area record, select a record and click Open. The record opens in the Data 
view.

• To view the source of the record and pending changes, use the XREF view.

• To view past changes to the record, use the History view.

• To view a subject area record and potential duplicate records, use the Match Merge Comparison 
view.

• If the subject area record contains effective dates, you can view scheduled changes in the Effective 
Periods view.

• If the Hierarchy Manager is enabled, you can view the subject area record and its related records in 
the Hierarchy view.

Search

When you run a search from the application header, the Search tab displays the results of the search. 
You can open business entity records from the search results.

Entity tabs

In the search results, select a business entity record and open the record in a temporary entity tab. The 
name on the tab identifies the opened record, usually by the name of the record, but the tab name is 
configurable. You can view or edit the master data for the record in an entity tab.

Note: If a Data Director application uses subject areas only, the entity tab is unavailable and the records 
open in the Data tab.

In an entity tab, you can open the following views:

• To view and edit business entity records, use the Business Entity view.

• To view the source of the business entity record, use the Cross-reference Records view.

• To view past changes to the business entity record, use the History view.

• To view a business entity record and potentially duplicate records, use the Matching Records view.
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• If the business entity record contains effective dates, you can view the scheduled changes in the 
Timeline view.

• If the Hierarchy Manager is enabled, you can view the business entity record and its related records in 
the Hierarchy view.

Note: If your MDM administrator created custom views, you might see different names for the views.

Other Tabs

The MDM administrator can configure other tabs.

Record Views
Based on how the MDM administrator configured your application for Data Director, you might have more 
than one way to access master data. When you access master data in Data Director, you use record views. 
You might have record views for business entities or record views for subject areas.

Usually the MDM administrator configures an application to use either business entities or subject areas. If 
you do not see the Data tab in the navigation bar, you have access to record views for business entities. If 
you see the Data tab, you have access to record views for subject areas.

If the application supports both business entities and subject areas, you have a hybrid application and both 
types of record views are available. In this case, you see the Data tab in the navigation bar. Also, when you 
use the New tab to create records, the Business Entity option and the Subject Area option appear.

Regardless of how you add a record, the MDM Hub Store saves the record that makes up the business entity 
or subject area in the same way. A parent record contains the identifying information. Child records contain 
other types of related information, such as addresses or telephone numbers.

The following table describes differences between records views for Data Director with business entities and 
record views for Data Director with subject areas:

Elements Data Director with Business Entities Data Director with Subject Areas

Access to record view Use the View list in an entity tab. Use the tabs in the Data tab.

Data in the record view Master data
Optionally, related data from external sources, 
such as social media.
Optionally, other panels, such as a Similar 
Records panel.

Master data

Core entities 
representation

Business entities Subject areasl

Nesting records Business entities can have an unlimited depth 
of descendant records.

A subject area can include descendant 
records up to the grandchild level.

Language in the user 
interface

You select the language to use. In the 
application header, select the menu beside 
your username and select Change Language.

You select the language to use. In the 
application header, select the menu 
beside your username and select Change 
Language.
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Elements Data Director with Business Entities Data Director with Subject Areas

Search Smart search, which performs a full-text 
search.
In the Search box in the application header, 
type your search term.
In the Search tab, type your search term in the 
Search box.

Search queries, which searches for terms 
by field.
Click Data, and then use an existing 
search query or create a new search 
query.

Supported in Data 
Director version

10.0 and later All supported versions

Data Director 
applications using the 
record views

Applications developed for Data Director 
version 10.0 and later.
In addition, MDM administrators can update 
older applications.

Applications developed for Data Director 
version 9.7.x and earlier.
Note: Some applications based on subject 
areas include customizations that cannot 
be easily converted to business entities.

Related Topics:
• “Data Director with Subject Areas” on page 77
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C h a p t e r  2

Getting Started
This chapter includes the following topics:

• Getting Started Overview, 22

• Home Page, 23

• Start Page, 25

• Sorting and Filtering Tasks, 26

• Refreshing Data in the Home Page, 27

• Configuring the Columns for the Task Inbox, 28

• Localizing Your User Interface, 28

Getting Started Overview
After you log in to Data Director, you see the Home page. The Home page is unique to your organization and 
to your user role.

Based on the Home page layout, you might be able to monitor data in reports, monitor social media feeds, run 
a search in an embedded search engine, and organize your task inbox.

Related Topics:
• “Adding Business Entity Records” on page 30

• “Editing Records” on page 50

• “Resolving Duplicate Records” on page 56

• “Establishing the Best Version of the Truth” on page 66

• “Investigating Data Changes” on page 70

• “Investigating Hierarchies and Relationships” on page 125

• “Participating in Review Processes” on page 140
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Home Page
Use the Home page as a data monitoring dashboard. A Home page can contain charts that display views of 
selected master data or display lists of available tasks in the task inbox. The Home page can also contain 
content from other external sources, such as Twitter or a search engine.

Note: The MDM administrator configures Home pages by user role. If you and a colleague have different user 
roles, your page might look different from your colleague's page.

Charts
If your organization uses a business intelligence tool or charting tool, you can use it to create charts that 
show master data. An IDD developer embeds the charts in the Home page.

Charts can be static or dynamic. Static charts display the results of predefined criteria. Dynamic charts 
include input fields, where a business user can select different criteria to use with the chart. Before you 
analyze the data in charts, recalculate the charts to ensure that the data reflects the current master data.

For example, the following image shows a duration chart that was created with Highcharts:

Social Media Feeds
A Home page can include social media feeds. Social media feeds can help you keep up with your 
organization's social media presence.

For example, the following image shows Twitter feed:
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Search Engine and External URLs
A Home page can include an embedded search engine or other external URLs. With embedded external URLs, 
you can access the internet without leaving Informatica Data Director. For example, you might search for the 
internet for more information about a business entity or monitor competitor offerings.

The following image shows an embedded Bing search engine:

Task Inbox
A task is a request to participate in a review process. For example, you might need to approve a new record 
or review changes to a record. You receive task notifications in the task inbox. By default, the task inbox 
displays the tasks based on the first quick filter. For example, if the first quick filter is My Open Tasks, the 
task inbox lists all your open tasks. 

The following image shows the task inbox with the My Closed Tasks filter selected: 

1. Quick filters
2. Column filter
3. Refresh icon
4. Table Settings icon
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The following table describes the elements in the task inbox:

Inbox 
Element

Description

Filters Filters the tasks based on the filter criteria. You can use the following types of filters alone or in 
combination: 
- Quick filters. Filters the tasks based on the predefined filter that you select.
- Column filters. Filters the tasks based on the task properties that are visible in the list. 

View All Displays the details of all the listed tasks in the Task Manager.

Refresh icon Updates the contents of the task inbox. 

Table Settings 
icon

Opens a dialog box where you can configure the columns for each quick filter listed in the task inbox.

Task Title A link that displays a short description of the review task. To review the record and take action on 
the task, click the task title. The task opens in the Task Manager and displays the associated record 
in the review panel. If your role permits it, you can edit the record from this view before taking action 
on the task. 

ID Instance ID of the review process that generated the task. 

Type Name of a people activity within the process. 

Priority Priority of the task. The task priority can be Low, Normal, or High. When generating tasks, the review 
process assigns the same priority to all tasks of the same type. 

Due Date Date the task is due. The review process calculates a default due date based on the task creation 
date plus a predefined time period. 
The due date of each task is prefixed with one of the following colored dots:
- Green. Indicates that the task is not overdue.
- Red. Indicates that the task is overdue.
- Amber. Indicates that the task will be overdue in the next 24 hours.

Status Status of the task can be Open or Closed. When the task status is Open, you can view the record 
associated with the task.

Owner Name of the signed-in user. 

Creator Name of the user who created the task.

Creation Date Date on which the user created the task.

Start Page
If the Data tab is enabled for your environment and a Home page is not configured for your role, use the Start 
page as a data monitoring dashboard. The Start page contains a list of review tasks in the task inbox.

The following image shows the Start page with the default task inbox:
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If the Task Manager is not enabled, when you click a task, the task opens in the Data tab. If the Task Manager 
is enabled, the task opens in the Task Manager.

Sorting and Filtering Tasks
You can sort and filter the list of tasks in the task inbox. For example, you might want to review edited 
records before you review merge proposals.

The task inbox contains quick filters and column filters. You can use these filters in combination to get 
specific results. For example, to see high priority tasks assigned to you, select the My Open Tasks quick filter 
and set the Priority column filter to High. In logical terms, filters are joined by the AND operator.

Note: You can set one column filter at a time. For example, you can narrow your list to Organizations and then 
further restrict the results to show only the Merge tasks for organizations.

1. In the navigation bar, click Home. 

The task inbox appears. 

2. To sort the list of tasks by a field, click the column heading with that field name. 
For example, to sort tasks by task type, click the Task Type column heading. 

Sorts the tasks based on the values in the selected column. An up arrow beside the column heading 
indicates that the values are sorted in ascending order. A down arrow indicates descending order. 

Note: By default, the task inbox sorts tasks case insensitively. If the number of tasks to sort is more than 
the value of the CompositePagerTotalRecords property, case-sensitive sorting is database dependent. 
For more information about the CompositePagerTotalRecords property, see the Multidomain MDM Data 
Director Implementation Guide.

3. To filter the list of tasks, set filter criteria in any order. 

• To filter tasks by the most commonly used criteria, select one of the following quick filters: 

Filter Description

My Open Tasks Shows your open tasks.

My Closed Tasks Shows the tasks that you closed.

All Tasks Shows all the closed, claimed, and unclaimed tasks that are assigned to your user 
group.

All Unclaimed Tasks Shows all the unclaimed tasks that are assigned to your user group. 

26       Chapter 2: Getting Started



Filter Description

All Closed Tasks Shows all the tasks that the users in your user group closed.

All Claimed Tasks Shows all the tasks that the users in your user group claimed.

• To filter tasks based on the values of column headings, enter appropriate values for the following 
column headings:

Column Description

Task Title Shows tasks that contain the specified text. Enter the text that you want to search for in the 
task titles. 

ID Shows the tasks based on the value that you enter.

Type Shows tasks with the selected task type. Select a task type from the list, such as Final 
Review or Merge.

Priority Shows tasks with the selected priority, such as High. Select a priority from the list.

Due Date Shows tasks that are overdue or due in a specific period. Select a due date option from the 
list.

Status Shows tasks with the selected status, such as Open or Closed. Select a status from the list.

Owner Shows tasks that are assigned to the user. Enter a user name. 

Creator Shows tasks that the specified user created.

Creation Date Shows tasks that are created during a specific period of time. Select a creation date option 
from the list, such as Last 7 days or Custom range.

4. To remove filters, click the Clear Filter icon. 

Refreshing Data in the Home Page
Before you perform an analysis of the data in the Home page, refresh the components to ensure that they 
display current data. You can refresh all components at the same time, or you can refresh some of the 
components individually.

Note: Third-party components might refresh themselves periodically. If so, the refresh rate depends on the 
API provided by the third-party component. For more information, contact the MDM administrator.

Perform one of the following tasks:

• To refresh all the components in the page, refresh your browser instance.

• To refresh only the task inbox, click the Refresh icon.

• To refresh a chart with current data, click Recalculate.
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Configuring the Columns for the Task Inbox
By default, the task inbox displays the columns that the administrator configured for all the quick filters. For 
each quick filter, you can add or remove the available columns.

1. In the navigation bar, click Home. 

The task inbox appears. 

2. Select a quick filter for which you want to configure the columns. 

3. Click Table Settings. 

The Table Settings dialog box appears.

4. To add a column heading, in the Available Fields section, select a field and click Add. 

5. To remove a column heading, in the Selected Fields section, select a field, and click Remove. 

6. Click OK. 

Localizing Your User Interface
You can display all elements of the Data Director user interface in another language. All elements of the user 
interface are localized in the selected language. The localized elements are menus, buttons, navigation links, 
labels, error messages, and metadata.

1. Login to Data Director, and if prompted, select your application. 

2. From the application header, click your user name, select Change Language, and select a language. 

The Data Director user interface displays the selected language.
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Part I: Data Director with Business 
Entities

This part contains the following chapters:

• Adding Business Entity Records, 30

• Finding Records, 35

• Editing Records, 50

• Resolving Duplicate Records, 56

• Establishing the Best Version of the Truth, 66

• Investigating Data Changes, 70

• Investigating Data Change Events for Effective Periods, 73
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C h a p t e r  3

Adding Business Entity Records
This chapter includes the following topics:

• Adding Records Overview, 30

• Adding a Person Scenario, 31

• Adding an Organization Scenario, 31

• Adding a Record, 32

• Adding a Record with Data from DaaS Provider, 34

Adding Records Overview
To add records based on a business entity, use the New tab with the Business Entity option and select a 
business entity.

Note: In the New window, if you see both the Business Entity option and Subject Area option, ask the MDM 
administrator which one to use. The Business Entity option opens an entity tab while the Subject Area option 
opens the Data tab.

The MDM administrator defines the business entities, including the data and structure. The administrator 
also designs the layout of the record view that opens when you create a record. Your application can have 
one or more record views.

You might see the following panels in your record view when you create a record:

Record Details panel

The main panel in the record view is the data entry form. Required fields have a red line.

Similar Records panel

If the record view contains the Similar Records panel, as you enter data in required fields, Data Director 
generates a list of similar records for your review. Review the similar records before finishing the form. If 
you find the record already exists, you can edit the existing record instead of adding a new record. If you 
are uncertain whether a similar record is the same record that you want to add, continue adding the new 
record. If you add a duplicate record, Data Director can find and consolidate matching records for you.

DaaS Providers panel

If the record view contains the DaaS Providers panel, you can specify some basic information, such as 
the display name, and send the information in a request to a DaaS provider. The DaaS provider searches 
its database and returns a list of matching records. You can preview the data for each record. You can 
compare two or more records and specify which of the records you want to use to create the record.
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Data Validation in the Business Entity View
When a user adds or changes data in the Business Entity view, Data Director checks the data against 
metadata and, optionally, validation rules. The metadata defines the expected format for the data, such as 
the data type or the number of characters permitted. The validation rules are cleanse rules or Informatica 
Data Quality rules.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

Validation processes run at the field level, section level, and entity level:

• Field level. When you add or edit data in a field in the Business Entity view, a client-side validation process 
verifies that the data satisfies the metadata. For example, when you enter a date in a Date field and then 
navigate away from the field, the process verifies that you entered the date in the expected date format.

• Section level. When you apply all changes in a section in the Business Entity view, a client-side validation 
process verifies that all data satisfies the metadata and that the required fields contain data.

• Entity level. When you save a record in the Business Entity view, a server-side validation process verifies 
that data satisfies the metadata, the cleanse validation rules, and the Informatica Data Quality rules.

If user input does not satisfy the metadata or the validation rules, you see messages about the problems with 
the data.

Adding a Person Scenario
You are an insurance agent for a large insurance company. You have a new customer, Anthony Lomax, on the 
phone. You want to add Mr. Lomax as a record.

To add Anthony Lomax, you perform the following steps:

1. In the navigation bar, click New. Select Person as the business entity type, and then click OK.

2. In the Last Name field, you type Lomax. In the First Name field, you type Anthony.

3. In the Similar Records panel, you see a potential duplicate, so you open the similar record.

4. You confirm with Mr. Lomax that he is not the same person as the existing Anthony Lomax, and then 
close the similar record.

5. You finish adding Mr. Lomax's information in the form.

Adding an Organization Scenario
You are with the marketing department of a company. You have a new customer, Time Warner which is an 
organization. You want to add Time Warner as an Organization business entity record.

To add Time Warner, you perform the following steps:

1. In the navigation bar, click New. Select Organization as the business entity type, and then click OK.

2. Fill In the required fields for the DaaS provider. In the Display Name field, type Time Warner. The Display 
Name field is a required field.

3. Select the DaaS provider and click Go.
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4. Review the search results that the DaaS provider returns. You compare two or more records in the 
search results.

5. Select the records that are a potential match and click Use this to create the record.

6. If you do not find any potential matches, you close the search results, add data in the data entry form 
and click Save to create the record.

Adding a Record
To add a record that uses the business entity model, start from the New tab in the navigation bar and select 
the type of business entity.

1. In the navigation bar, click New. In the New window, select a business entity type, and then click OK. 

An entity tab opens and displays the data entry form for the business entity. A red line on a field 
indicates a required field.

2. For each required field in the form, click the field, and type a value. 

Note: You can use the following conventions when adding text:

• Type the complete search string or the search string with the asterisk wildcard character (*) for the 
record that you want to find. You can use the wildcard character at the end of the search string or in 
between the search string. For example, if you want to search for John, you can specify Jo* or J*n.

• If the search is configured to suggest search strings, type a few characters of the search string, and 
select one of the suggested values as the search string.

Note: The values are suggested when you search within a single business entity type.

If the search string includes any of the following special characters, add a backslash as a prefix to the 
special character: + , - , & , || , ! , ( ) , { } , [ ] , ^ , " , ~ , ? , : , \ . If you do not add a backslash as a prefix to 
each special character, the search might return no results or incorrect results. For example, if you want 
to search for AT&T, the search string must be AT\&T.

The following image shows a sample data entry form for a Person business entity. The required fields 
are filled in.

1 Navigation menu

2 Required field indicator

3 Changed field indicator

3. If the Similar Records panel contains a list of similar records, review them. 

a. In the Similar Records panel, click the information icon beside the name of a record. 

32       Chapter 3: Adding Business Entity Records



b. Check the other data values to see if the record is the same as the one you are adding. 

• If it is the same record, click Use this record. When prompted for confirmation, click Yes, 
proceed. The work-in-progress record is discarded and the tab closes. The selected record 
opens in an entity tab. You can edit data as required.

• If it is not the same record, click Close.

• To review child records for the previewed record without discarding the work-in-progress entity, 
click View Business Entity. The previewed record opens in an entity tab.

c. Review other similar records in the same way. 

d. If a record does not exist, return to the tab containing the work-in-progress record. 

4. In the data entry form, add data in the optional fields. 

a. Fill in the fields. 

b. Optionally, add an image. Type a valid URL in the image field. 

Note: For best results, use an image that is a maximum of 200 x 200 pixels. For images, the MDM 
Hub stores the URL, not the file. If the location of the file changes, you must update the URL.

c. Click the Apply icon. 

5. If the data entry form includes sections for child records, add child records to the sections. 

a. In the navigation menu, click a section name, such as Address or Phone. 

The view scrolls to the selected section.

b. Click the Create Child Record icon. 

Fields appear where you can enter data.

c. You can switch between a table view and a form view of the fields. Click the Form icon or the Table 
icon. 

d. Fill in the fields. 

The following image shows a sample Phone section in the form view:

1 Table icon. Click to view the fields within a table.

2 Form icon. Click to view the fields within a form.

3 Create Child Record icon. Click to add a child record to the selected record.

e. Click the Apply icon. 

6. After you finish adding data, click Save. 

A message confirms that the record was created successfully. If your user role permits you to save data 
without a review, the application saves the record to the MDM Hub Store as an active record. Otherwise, 
the application saves the record as a pending record and initiates the review process associated with 
your role.
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Adding a Record with Data from DaaS Provider
When you have Data as a Service (DaaS) integrated with the MDM Hub and configured for a business entity, 
the DaaS Providers panel lists the DaaS providers. Use the data provided by a DaaS provider to add your 
record. To add a record, start from the New tab and select the type of business entity.

1. In the navigation bar, click New. In the New window, select a business entity type, and then click OK. 

2. Fill in the required fields for the DaaS provider. 
For example, in the Display Name field, type Time Warner.

3. Move your cursor out of the Display Name field. 

You can now select a DaaS provider.

4. In the DaaS Provider panel, request information about the record from a DaaS service provider. 

a. Select the DaaS provider you want to use, and then click Go. 

The DaaS provider returns the search results based on the display name of the organization.

b. Investigate if a record in the search result is the one you want to add. 

1. Select the record and click Preview.

2. If the data values do not match the record that you want to add, click Go back.

3. Review all records in the same way.

c. Optionally, if you want to compare two or more records, select the records, and then click Compare. 

The Compare page displays the data from the selected records.

5. Based on the result of the previous step, perform one of the following actions: 

• To add the data from the DaaS provider, select one or more entities from the search results or from 
the Compare page, and then click Use this. All entities are merged to form a single record. Continue 
with this record.

• If the DaaS provider does not return results that match the entity you want to create, return to the tab 
containing the work-in-progress record, fill in the details, and click Save.
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C h a p t e r  4

Finding Records
This chapter includes the following topics:

• Finding Records Overview, 35

• Using the Search Box to Find Records, 37

• Using Queries to Find Records, 41

• Managing Queries, 46

• Migrating and Sharing Saved Queries, 47

• Filtering Child Records, 48

Finding Records Overview
To find a record, you can either enter a search text in a search box or use a query form. The search results 
show the most important details of the records. You can see more details by opening the records. 

You can use the search box to search and filter records. However, to repeatedly perform the same search and 
filter operation, it is efficient to create and save a query. 

Use the search box to perform a full-text search. Use a search query, which is a search form, to specify a 
criteria for your search.

When you use queries, you can search within a specific business entity for which the query is created. 
Whereas, when you use the search box, depending on your environment, in addition to searching within a 
business entity, you might be able to search across all business entities. 

Note: The search options that you see depend on what was configured by the MDM administrator. You must 
have the required privileges for the business entities within which you want to search for records.

Search Page
When you perform a search from the Search box in the application header, the Search page appears in the 
Search tab. A search returns a list of records that satisfy the search criteria.

Use the Search page to review the search results. You can expand a record in a search result to view the 
summary of record details. To refine the search results, you can use filters.

You can group the records that appear in search results based on the business entity types. If you group 
records, you can look for records in the relevant business entity type groups.

The following image shows a sample Search page:
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1. Results total
2. Search Results panel
3. Actions menu
4. Search box
5. Filter panel

The Search page includes the following sections:

Results total

Displays the total number of results found based on the search string that you enter in the Search box.

Search Results panel

Displays the total number of results found and lists the records that are part of the search results. You 
can group the records listed in the search results by business entity type.

Actions menu

Displays actions that you can perform on the record. For example, you can open the record in a view, 
such as the Business Entity view, or you can create a task for the entity.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

Filter panel

Displays the filter criteria to filter the search results. Use filters to refine the search results based on the 
filter criteria that you select or enter a value for. You can hide the Filter panel if you do not need to filter 
the search results.

Filter criteria

Filter properties that you can select or enter a value for to refine search results.
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Queries Page
Use the Queries page to create and run queries. A query returns a list of records that satisfy the criteria that 
you specify.

To open the Queries page, click the Queries tab. If you have a default query, the default query opens. If not, 
the Saved Queries panel appears, and you can create a query or select a saved query.

After you run a query, the Search Results panel lists the records that satisfy the search criteria.

The following table describes the user interface elements of the Queries page:

User interface element Description

Query panel Lists the saved queries or the query that is open. The query that you create appears in the 
query panel.

Run Runs the query that is open.

Save Saves a query.

Back to Saved Queries Displays the saved queries in the Saved Queries panel.

Query Results panel Lists the records that satisfy the query criteria.

Using the Search Box to Find Records
You can use the search box to perform a full-text search. You might want to search for records that you want 
to view, edit, or delete.

Your Data Director application might be configured to use search with Solr or Elasticsearch. When your 
application is configured to use Elasticsearch, at a time, you can search for records within a single business 
entity. This is different from search with Solr, where you could either search across all the business entities 
or within a specific business entity.

Finding Records in an Elasticsearch Environment
Use the search box to find a record.

1. In the Search box, select a type of business entity from the list. 

Tip: The Search list contains the types of business entities that you have permission to view. If the list is 
empty, contact your MDM administrator to request permission.

2. In the Search box, perform one of the following tasks: 

• Type the complete search string or the search string with the asterisk wildcard character (*) for the 
record that you want to find. You can use the wildcard character at the end of the search string or in 
between the search string. For example, if you want to search for John, you can specify Jo* or J*n.

• If the search is configured to suggest search strings, type a few characters of the search string, and 
select one of the suggested values as the search string.

Note: The values are suggested when you search within a single business entity type.
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If the search results must contain the words in the search string, add the + operator before each search 
word.

3. Click the Search icon. 

The search results appear in the Search Results panel.

4. To refine the search results, you can apply filters. 

Finding Records in a Solr Environment
Use the search box to find a record.

1. Optionally, in the Search box, select a type of business entity from the list. 

By default, All is selected, and Data Director searches within all the business entity types. Also, you can 
select a specific business entity within which you want to search for records.

Tip: The Search list contains the types of business entities that you have permission to view. If the list is 
empty, contact your MDM administrator to request permission.

The following image shows the business entity type list:

2. In the Search box, perform one of the following tasks: 

• Type the complete search string or the search string with the asterisk wildcard character (*) for the 
record that you want to find. You can use the wildcard character at the end of the search string or in 
between the search string. For example, if you want to search for John, you can specify Jo* or J*n.

• If the search is configured to suggest search strings, type a few characters of the search string, and 
select one of the suggested values as the search string.

Note: The values are suggested when you search within a single business entity type.

If the search results must contain the words in the search string, add the + operator before each search 
word.

If the search string includes any of the following special characters, add a backslash as a prefix to the 
special character: + , - , & , || , ! , ( ) , { } , [ ] , ^ , " , ~ , ? , : , \ . If you do not add a backslash as a prefix to 
each special character, the search might return no results or incorrect results. For example, if you want 
to search for AT&T, the search string must be AT\&T.

If you want to search for a negative value, type the value in the search string without the minus 
character. For example, if you want to search for -5000, the search string must be 5000.

If you want to search a date, use a simple date format, such as <Month> <DD> <YYYY>, in any order and 
do not use a date format, such as <YYYY>-<MM>-<DD> or YYYY-MM-DDThh:mmTZD. For example, use 
November 20 2014 or 2014 Nov 20 as the search string.

The following image shows the Search box with the search string, John Smith:
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3. Click the Search icon. 

The following image shows the search results in the Search page:

Note: A search request does not return a rounded float value that the Entity 360 view displays when you 
search for the rounded value.

4. Optionally, you can group the records that appear in search results based on the business entity types. 

The search results are sorted and moved to the relevant business entity type groups.
The following image shows search results in the Person business entity type groups, and search results 
in the Secure Person business entity type group:

5. To find the record that you are searching for, expand the business entity type under which you expect to 
find the record. 

The business entity type expands to show all the records that appear in the search result and belong to 
the business entity type.
The following image shows the expanded results for the Person business entity type:
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Filtering Records
After you perform a search, you can refine the search results by using filters. For example, you can refine the 
search results for John Smith by filtering the results by the city name, Toronto.

1. Perform a search. 

The search results appear in the Search Results panel in the Search page.

2. In the Filter panel, select or enter a value for the filter criteria that you require. 

Note: For a date and time field, you can specify the date in the filter, but not the time. The filter uses the 
default time as 00:00:00 UTC. Some numeric filters might appear in the scientific notation, even though 
the search results display the values in the decimal notation. For example, the filter might display 
10544444.6 as 1.05444446E7.

3. Click Apply. 

The search results contain only the records that match the filters that you applied.

4. To clear all the filter criteria, click Clear All. 

Viewing and Opening a Record in an Elasticsearch Environment
You can open records from the Search Results panel in the Business Entity view, or any record view. Before 
you open a record, you can preview the record. The preview appears in the Record Preview window and can 
display up to ten levels of records, which includes both parent and child record levels.

1. From the Search Results panel, select the record that you want to open. 

Note: A description with the prefix [Pending] means that the record has pending changes that are not yet 
approved. You can open the record, but you cannot make further changes until the review and approval 
process ends.

2. To verify that you have the correct record, click the Show Preview icon. 

The Record Preview displays the record details.

3. To open the record, click the Open in a new window icon. 

The record opens in the Business Entity view. You can view and edit the record that is open.

4. If you want to open the record in any other view, from the View list, select a record view. 

Note: The record views that appear in the View list depend on the Data Director configuration and your 
user role privileges.

The following views might be available in the Data Director application:

View Description

Cross-
reference 
Records

View the records that contribute to the best version of the truth of a record. You can unmerge a 
record that was merged with another record.

Matching 
Records

View the records that match the record that you opened. You can identify and resolve duplicate 
records.

Hierarchy View a diagram that shows how a record is related to other records. You can add, edit, and 
delete related records and relationships for the selected records.

History View data changes over the lifespan of the record. You can identify the data events that 
changed the data.
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The record opens in the view that you select.

Viewing and Opening a Record in a Solr Environment
You can view the summary of record details in the Search Results panel in the Search page. To ensure that 
you open the record that you want, review the details for the record before you open it. You can open a record 
in the Business Entity view, the Data view, or the Hierarchy view.

1. From the Search Results panel, select the record that you want to open. 

Note: A description with the prefix [Pending] means that the record has pending changes that are not yet 
approved. You can open the record, but you cannot make further changes until the review and approval 
process ends.

2. To verify that you have the correct record, expand the entry to display a few details about the record. 

The following image shows the expanded entry for John James Smith:

3. Open the record. 

• To open the record in the Business Entity view, click the record name.

• Alternatively, click the Actions menu at the end of the row and select a record view.

Note: The record views that appear in the View list depend on the Data Director configuration and 
your user role privileges.

The following table describes some of the views that might be available from the Actions menu:

View Description

Data View and edit the record, which is based on the subject area model, in the Data view.

Business Entity View and edit the record, which is based on the business entity model, in context with other 
sources of information about the record.

Hierarchy View a diagram of the relationships for the record.

4. If prompted, specify the effective period that you want to investigate. 

The record opens.

Using Queries to Find Records
Use a search query, when you want to repeatedly perform the same search and filter operation. When you use 
search queries, you specify a criteria for your search. You might want to use queries to find records that you 
want to view, edit, or delete.

To create and manage queries, use the Queries page. You can create a query to search for records based on 
a specific business entity. To reuse the query that you create, save the query. If you use a query frequently, 
you can set it as the default query.
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When you create a query with a lookup field that is dependent on other lookup fields, these other lookup 
fields are automatically included in the query. For example, the City lookup field is dependent on the State 
and Country lookup fields. When you create a query to include only the City lookup field, the State and 
Country lookup fields are automatically included in the query.

Types of Queries
You can use a basic or an extended query.

If a basic query does not return the results you are looking for, use an extended query. An extended query can 
find records that are missed by the basic query.

Basic Queries
Basic queries use simple text comparisons to find records that contain the query values. You can use text 
and the wildcard character (*) to query values.

The wildcard characters are special search symbols that you can use in basic queries to specify a text 
pattern instead of specific characters. You can use the asterisk (*) wildcard character to increase your 
chances of finding the records that you want. The wildcard characters are useful when you do not know the 
exact text or want to search for similar text.

The following table lists example search strings and explains how they function: 

Example Query 
String

Query Behavior

John Smith Queries for records that contain John, Smith, or any variations of John or Smith as a field 
value.

"John Smith" Queries for records that contain John Smith or any variations of John Smith as a field value.

John* Queries for records that contain a value that starts with John. For example, Johnson or 
Johnny.

Jo*n Queries for records that start with Jo and end with n. For example, Johansson or Jordan.

* Returns all the records.

Note: Basic query is not case sensitive in Microsoft SQL Server environments.

Extended Queries
Extended queries use matching logic and match-enabled attributes to find records that contain the query 
values. You must enable a match rule set to use with extended queries.

Extended query results include fuzzy matches, which are more reliable. Fuzzy matches take into account 
spelling variations, and other differences to ensure that matching data that are not identical are not missed. 
For example, an extended query can match variations of the word "Street", such as "St." and "St".

Note: The extended queries use match rule sets. If an MDM administrator edits or deletes a match rule set 
from the Hub Console, the related queries are deleted from the Data Director application.

When you use extended queries, ensure that the following conditions are met:

• The business entity has match-enabled attributes.
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• The match rule set used by the query is configured by the MDM administrator to use the Enable Search by 
Rules option in the Hub Console.

Creating a Query
You can create a query to search for records within a specific business entity. You are the owner of the 
queries that you create.

1. In the navigation bar, click Queries. 

2. In the Saved Queries panel, click the Add icon. 

The New Query dialog box appears.

3. From the Business Entity list, select the business entity within which you want to perform the search. 

4. Select a query type. 

Query Type Description

Basic Uses simple text comparisons to find records that contain the query values.

Extended Uses matching logic and match-enabled attributes to find records that contain the query values.

5. If you selected the extended query type, from the Match Rule Set list, select a match rule set. 

Select the Default match rule set only when a suitable match rule set does not appear in the list. A match 
rule is generated based on the values that you specify.

The fields available for the selected match rule set appear.

6. Select the fields that you want to include as the search criteria for the query. 

The fields that you selected appear in the Selected Fields section.

7. In the Selected Fields section, drag to rearrange the sequence of the fields. 

The fields appear in the query form in the sequence that you set.

8. Specify the search results options. 

a. If you want the query to be case sensitive, enable the Case sensitive option. 

b. If you want the search results sorted, from the Sort By list, select a field name by which you want 
the search results sorted. 

c. Select the sort order of the query to be ascending or descending. 

9. Click OK. 

The query is created and opens on the Queries page.

10. To save the query for reuse, click Save. 

The Save Query dialog box appears.

11. Enter a query name and description. 

12. If you want to use the query as a default query, enable Set as my default. 

The default query is the query that appears when you open the Queries tab.

13. If you want to share the query with other users, enable Share with all. 

By default, you own the query that you create. Other users cannot edit the queries that you own.

14. Click Save. 

The query is saved and appears on the Saved Queries panel.

You can run the query that you created, or save the query and run it when needed.
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Running a Query
You can run a query to find records. To run a query that is not saved, enter the search criteria, and then run 
the query. To run a saved query, first, open the query.

1. In the Saved Queries panel, open the query that you want to run. 

a. If a default query is open, but you want to run a saved query, click the Back icon to navigate to the 
Saved Queries page. 

b. Expand the business entity to which the query belongs. 

c. Click the query name. 

The query form appears.

2. Enter the search criteria for the record that you want to find. 

3. Click Run. 

The query results appear in the Search Results panel.

Viewing Query Results
After you run a query, you can view the query results that appear in the Search Results panel.

You can open records from the Search Results panel. Before you open a record, you can preview the record. 
The preview appears in the Record Preview window.

The Record Preview and the Business Entity view can display the parent records and up to ten levels of child 
records. The top two child record levels are expanded. To view the child record levels that are deeper, expand 
the record levels.

You can customize the results to view only the fields that are significant to your purpose. Also, you can 
export the results to a CSV file.

Opening Records from Query Results
After you run a query to find records, you can open the records from the Search Results panel. 

1. From the Search Results panel, select the record that you want to open. 

2. Optionally, to verify that you have the correct record, preview the record. 

a. Click the Show Preview icon. 

The Record Preview displays the record details.

b. After you preview the record, click Close. 

3. To open the record, click the Open in a new window icon. 

The record opens in the Business Entity view. You can view and edit the record.

4. If you want to view other information about the record, from the View list, select a record view. 

Note: The record views that appear in the View list depend on the Data Director configuration and your 
user role privileges.
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The following views might be available:

View Description

Cross-
reference 
Records

Displays the records that contribute to the best version of the truth of a record. You can 
unmerge a record that was merged with another record.

Matching 
Records

Displays the records that match the record that you opened. You can identify and resolve 
duplicate records.

Hierarchy Displays a diagram that shows how a record is related to other records. You can add, edit, and 
delete related records and relationships for the selected records.

History Displays data changes over the lifespan of the record. You can identify the data events that 
changed the data.

The record opens in the selected view.

Customizing Query Results
You can customize the query results that appear in the Search Results panel to include only the fields that 
you want to view.

1. From the Search Results panel, click the Settings icon. 

The Customize Query Columns dialog box appears.

2. Select the fields that you want to display in the Search Results panel. 

3. Optionally, change the order in which you want the fields to appear in the search results. 

4. Click OK. 

The Customize Query Columns dialog box closes. The query results include only the fields that you 
selected.

Exporting Query Results
If you want to view the query results in a CSV file, export the query results to a CSV file.

u Export the query results to a CSV file. 

• To export all the fields, including the fields that do not appear on the Search Results panel, click 
Actions > Export All Fields.

• To export only the fields that appear on the Search Results panel, click Actions > Export Current 
Fields.

Note: Before you export the query results, you can customize the results that appear on the Search 
Results panel to include only the fields that you want to export.
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Managing Queries
After you save queries, you might want to modify a query or delete a query that you do not need.

To manage queries, you can perform the following tasks:

• Edit a saved query.

• Delete a saved query.

• Save an existing query as a new query.

Note: The extended queries use match rule sets. If an MDM administrator edits or deletes a match rule set 
from the Hub Console, the related queries are deleted from the Data Director application.

Editing a Saved Query
Use the Saved Queries panel to edit queries. You can edit any query that you own. You own the queries that 
you create or import into your environment.

1. In the Saved Queries panel, expand the business entity, and click the query. 

The query opens.

2. Click Actions > Edit Query. 

The Edit Query dialog box appears.

3. Edit the query as required. 

You can make the following changes to the query:

• Add fields.

• Remove fields.

• Enable the query to be case-sensitive.

• Select a field name by which the query result must be sorted.

• Set the sort order to ascending or descending.

4. Click OK. 

The query is updated. You can save or run the query.

5. Save or run the query. 

Deleting a Saved Query
For each business entity, you can delete the queries that you own.

1. In the Saved Queries panel, expand the business entity. 

2. Select the query, and then click Actions > Delete. 

The delete confirmation dialog box appears.

3. To delete the query, click Yes. 

The query is deleted.
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Saving an Existing Query as a New Query
Instead of starting from scratch, you can use an existing query to create more queries. You can either select 
or open an existing query, and then save the it as a new query.

1. In the Saved Queries panel, select the query that you want to save as a new query. 

2. Click Actions > Save As. 

The Save As dialog box appears.

3. Enter a unique name and description for the query. 

4. Optionally, enable any of the following query options: 

• Set as my default. The query becomes the default query.

• Share with all. The query is shared with other users.

5. Click Save. 

A copy of the query is saved with the new name, and the query opens.

6. Optionally, modify the new query. 

a. Click Actions > Edit. 

b. Edit the query as required. 

You can make the following changes to the query:

• Add fields.

• Remove fields.

• Enable the query to be case-sensitive.

• Select a field name by which the query result must be sorted.

• Set the sort order to ascending or descending.

c. Click OK. 

The query is saved with the changes.

Migrating and Sharing Saved Queries
When an MDM administrator migrates a Data Director configuration from one environment to another, the 
saved queries are not migrated. You need to export the queries from the source Data Director application and 
then import the queries into the target Data Director application.

You can migrate all the saved queries in the application or migrate individual saved queries. When you 
migrate queries, if the target application contains queries that have the same names as the queries in the 
source application, the queries are renamed. For example, if a query with the name PersonQuery already 
exists in the target environment, the query is renamed to PersonQuery 1.

Also, you can share the saved queries with other users, who can import the queries into their application. You 
are the owner of the queries that you import into your application.
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Migrating and Sharing all the Saved Queries
To migrate all the saved queries, export the queries from the source Data Director application and then 
import the queries into the target Data Director application. Also, you can share all the saved queries with 
other users, who can import the queries into their environment.

1. From the Saved Queries panel header, click the Export icon. 

A Queries.json file, which contains all the saved queries, is downloaded to the default download 
location.

2. Import the JSON file into the target application. 

a. Copy the downloaded JSON file to an accessible location in the target application environment. 

b. From the Saved Queries panel header, click the Import icon. 

c. Locate and import the queries JSON file. 

All the saved queries are migrated to the target environment.

Migrating and Sharing a Single Saved Query
To migrate a saved query, export the query from the source Data Director application and then import the 
query into the target Data Director application.

1. From the source application, export the query that you want to migrate. 

a. In the Saved Queries panel, expand the business entity to which the query to export belongs. 

b. Select the query, and click Actions > Export. 

A Queries.json file, which contains the saved query, is downloaded to the default download location.

2. Import the JSON file into the target application. 

a. Copy the JSON file to an accessible location in the target application environment. 

b. In the target application, from the Saved Queries panel header, click the Import icon. 

c. Locate and import the JSON file. 

The saved query is migrated to the target environment.

Filtering Child Records
In a Business Entity view, you can filter the child records based on field values. Filters are enabled when the 
number of records in a child record section exceeds four records. Even though the child records might be 
listed in multiple pages, the filters are applied to the entire set of child records.

When you navigate away from the Business Entity view, the filters are cleared. When you switch between the 
form and table views, the filters persist.

Note: In the form view, when you filter by date, the records are filtered by date but not by time.

1. Expand a child record section. 

2. Click the Filter icon. 
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The filter fields appear.

3. Enter the filter criteria, and press the Enter key. 

The filters are applied, and the records that satisfy all the filter criteria are displayed.
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C h a p t e r  5

Editing Records
This chapter includes the following topics:

• Editing Records Overview, 50

• Scenario for Editing a Record, 50

• Editing a Record, 51

• Adding and Editing Related Records, 52

• Deleting a Record, 55

Editing Records Overview
You might want to add or make changes to the information in a record. To make changes to a record, search 
for the record, and open the record in the Business Entity view.

If your user role permits it, you can edit the data or delete the record. When you save changes, based on your 
user role, a review process might be initiated. In this case, Data Director saves the requested changes in a 
pending record until the review process ends. If the review ends in an approval, Data Director applies the 
change from the pending record to the active records.

Scenario for Editing a Record
A customer named John Smith reports that he did not receive the product that you mailed to him. You want 
to check his address, correct errors, and redirect the product to the correct address.

You find the record for John Smith, which you select and open to view the address. You find that the address 
has an incorrect postal code. After you correct the address, you close and save the record. You ensure that 
you resend the product to the correct address.
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Editing a Record
If your user role includes the edit permission, you can edit a record in the active state.

Note: You cannot edit a record that is in the pending state because the record has changes that are pending 
approval. You must wait until the review and approval process ends.

1. From the Search Results panel of the Search page, open the record that you want to edit. 

The record opens in a record view.

2. If the view is not your preferred view for editing, you can select a different view from the View list. 

3. Click Edit. 

Tip: If the button is disabled, either you do not have permission to edit the record or the record has 
changes that are pending approval.

The following image shows the record for John James Smith in edit mode:

4. Edit the data in the root record as required. 

a. Click anywhere in the top section. 

The section becomes editable.

b. Edit the data. 

5. Edit the data in child records as required. 

a. Expand the child section. 

b. Click the Edit icon. 

The section becomes editable.

c. Edit the data. 

d. Click the Apply icon. 

6. Click Save. 

If your user role permits you to save data without a review, the application saves the record to the MDM 
Hub Store as active records. Otherwise, the application saves the record as a pending record and 
initiates the review process associated with your role.
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Adding and Editing Related Records
Business entity relationships describe the affiliation between two entities. The MDM Hub supports one-to-
many and many-to-many relationships between business entities, in addition to hierarchical relationships 
between records in the same business entity. You can add, view, edit, and manage relationships between a 
business entity and the records related to the business entity.

In the Related Records panel, you can see the business entities that you have permission to view. To create 
relationships between different types of business entities, your user role must include the edit permission for 
both types of business entities.

When a relationship exists between two entities, you can add related records to a business entity. For 
example, Organization employs Person is a relationship that exists between the Organization and Person 
business entities. You can add Person records or employees as related records to the Organization. The 
Related Records panel lists the business entities that are directly related to the business entity that is open in 
the Business Entity view.

Note: If you do not see the Related Records panel when you edit a business entity, contact the MDM 
administrator.

Scenario for Adding and Editing Related Records
A relationship is configured between the Organization and the Person business entity types, such that an 
organization employs persons. You have an organization, Informatica, to which you want to add the 
employees. John Smith is an employee of Informatica.

You search for the record for Informatica. You open the record. You search for the record for John Smith. You 
add John Smith as a related record to Informatica. After an appraisal, John Smith has a different job title and 
salary. You must update the relationship details to reflect the change. You open the record for Informatica 
and select the relationship between Informatica and John Smith. You update the relationship details.

Adding a Related Record
When a record has relationships configured, you can add related records to records. Search for and open the 
record in the Business Entity view. Search for the related record that you want to add as a related record and 
add the record in the Related Records panel.

Note: The Related Records panel must be present in the Business Entity view. To create relationships 
between different types of business entities, your user role must include the edit permission for both types of 
business entities.

1. From the Search Results panel in the Search page, select the record to which you want to add the 
related records. 

2. Open the record. 

The Related Records panel displays the records that are directly related to the record you open. There 
might be more than one Related Records panel.

3. In the Related Records panel, click New. 

The Relationships dialog box opens.

4. Select the relationship type. 

5. In the Search box, type the complete search string or the search string with the asterisk wildcard 
character (*) for the record that you want to find. 

6. Click Search. 
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The following image shows the search results and the filter panel: 

7. In the Filters panel, select a value for the filter criteria that you require. 

8. Click Apply Filter. 

The revised search results appear in the Search Results panel based on the filters you set.

The following image shows the filtered records:

9. Select the record that you want to add as related record and click Select. 

10. If the relationship has additional attributes, specify the additional attributes. 

For example, for a PersonOwnsAutomobile relationship, you might have to specify the mileage and price.

11. Click Apply. 

The record is added as related record and appear in the Related Records panel.
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The following image shows the related records in the Related Records panel: 

Viewing Related Records
You can view the related records in the Related Records panel. Each related record in the component is a link 
that you can open in the Business Entity view.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

1. From the Search Results panel in the Search page, select the record. 

2. Open the record. 

The related records are listed in the Related Records panel.

Deleting a Related Record
You can delete the relationship between a record and a related record. Search for the record and then delete 
the related record in the Related Records panel.

1. From the Search Results panel in the Search page, select the record that you want to edit. 

2. Open the record. 

The Related Records panel displays the records that are directly related to the record you open. There 
might be more than one Related Records panel.

3. Select the related record that you want to delete, and then click the Delete icon. 

A confirmation box appears.

4. Click Yes. 

Data Director deletes the relationship between the record and the related record and no longer displays 
the related record in the Related Records panel.

Editing the Relationship Details
You can edit the details of the relationship between a record and the related record. You can edit the 
additional attributes associated with the relationship. Search for the record and edit the relationship from the 
Related Records panel.

1. From the Search Results panel in the Search page, select the record that you want to edit. 

2. Open the record. 

The Related Records panel displays the records that are directly related to the record you open. There 
might be more than one Related Records panel.
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3. In the Related Records panel, select the related record that you want to edit, and then click the Edit icon. 

4. Edit the additional attributes, and then click Apply. 

For example, assume that job title and salary are two attributes associated with the 
OrganizationEmploysPerson relationship. After an appraisal, you might edit the job title and salary for 
that Person record to reflect the changes.

Deleting a Record
If your user role includes the delete permission, you can delete records in the active state. You cannot delete 
a record that is in the pending state because the record is part of a workflow and is pending approval.

1. From the Search Results panel in the Search page, select the record that you want to delete. 

2. Open the record. 

3. Click Actions > Delete. 

A confirmation box appears.

4. Click Yes. 

Data Director marks the record as deleted and no longer displays the record, but does not remove the 
record from the database.
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C h a p t e r  6

Resolving Duplicate Records
This chapter includes the following topics:

• Resolving Duplicate Records Overview, 56

• Scenario for Duplicate Records, 60

• Resolving Duplicate Records, 60

• Resolving Duplicate Child Records in a Single Record, 64

Resolving Duplicate Records Overview
Your organization might have data that originates in multiple systems, resulting in duplicate, hard to merge 
records. To resolve the duplicate records, you can use the Matching Records view in Data Director. You can 
identify the duplicates, and merge the best version of the data into a single master record.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

When you merge duplicate records, you can preview what the merged record would look like. If you are 
satisfied with the preview, you can merge the records.

You must have the required privileges to view and merge the records. You can see only the business entities 
for which you have the required privileges. To request additional role privileges, contact your MDM 
administrator.

Matching Records View
You can resolve duplicate records by using the basic Matching Records view or the advanced Matching 
Records view. Your application might have one or both the Matching Records views configured.

Basic Matching Records View

You can use the basic Matching Records view to merge only the duplicate parent records.
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The following image shows a sample basic Matching Records view:

Advanced Matching Records View

You can use the advanced Matching Records view to merge the duplicate parent and child records.

The following image shows a sample advanced Matching Records view that is displaying the parent-level 
records:

The following image shows a sample advanced Matching Records view that is displaying the child-level 
records:
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Matching Records and Match Rules
Data Director depends on match rules to determine the matching records. An MDM administrator configures 
match rules based on the data characteristics and the requirements for matching and merging records.

The match rules determine whether the matching records have identical values or similar values. Also, match 
rules determine the records that are automatically merged and the records that appear on the Matching 
Records view.

For example, consider a match rule that is based on addresses. Based on the match rule, John Smith and 
Jane Smith are identified as matching records, because they share the same address. Though their address 
is the same, they are unique people. Their records are not duplicates and must not be merged.

The records that appear on the Matching Records view have a match score associated with them. The match 
scores are based on the match rules. A high match score indicates that the record is a close match. A low 
match score indicates that the record is a distant match.

Note: When a match job runs, the matching records are identified. If a match job was not run recently, the 
Matching Records view might not contain all the possible matches. If you upgrade from an earlier version, 
the match scores are set to null for the existing matching records. The match scores are displayed only for 
the new matches. 

For more information about match rules, see the Multidomain MDM Configuration Guide.

Best Version Of the Truth and Trust Scores
Best version of the truth is the result of merging the most trustworthy field values from the duplicate records. 
Data Director uses trust scores to evaluate and determine the most trustworthy field values. When you 
prepare to merge duplicate records, you can finalize the best version of the truth.

You can finalize the best version of the truth by promoting or overriding the values in the Merge Preview 
column with values that you think are correct. For the values that you override to take effect, the MDM 
administrator must have configured trust for the Admin system. When you merge records, if child-level 
records with values that you override are also being merged, an additional cross-reference record, which is 
called an edit record might be created or updated. An edit record is created or updated when you override 
values in the Merge Preview column. The edit record contains only the field values that you override.

To identify an edit record, look for the following field values:

• Source system. The value is Admin.

• Source primary key. The value is generated by the MDM Hub and is the same as the Record ID or has the 
format SYS:<number>.

If trust is configured for your environment, the records that appear on the Matching Records view have trust 
scores associated with the fields for which trust is enabled. Trust scores are a measure of the relative 
trustworthiness associated with field values based on their source system, change history, and other 
business rules. Trust scores range from zero to 100. A field value with a higher trust score is more 
trustworthy than a field value with a lower trust score.

For more information about the best version of the truth and trust scores, see the Multidomain MDM 
Configuration Guide.
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Merging Duplicate Records
To resolve duplicates, you merge the records that you identify as duplicates. When you merge duplicate 
records, a single master record is created.

The records that you want to merge consist of a parent record level and might consist of multiple child 
record levels. The child records can have a one-to-one or a one-to-many relationship with the parent record. 
For example, John Smith's record consists of name, date of birth, and gender details at the parent record 
level. The child record level includes addresses, email, and phone numbers.

Note: IDD application developers define the parent-to-child relationships when they define the structure of a 
business entity.

When you merge records, the duplicate parent records merge into a single parent record. If the records to 
merge have child records, you need to identify your scenario and act accordingly.

The following table describes the child record scenarios, the related actions, and the results of each action:

Child Record Scenario Action Result

Duplicate child records with 
one-to-one relationship

Automatic merge. The one-to-one child records from each parent record 
automatically become the child record of the merged parent 
record.

Some duplicate child records 
with one-to-many relationship

Select duplicate 
child records to 
merge.

The duplicate child records merge to become the child record 
of the merged parent record. The child records that are not 
selected become the child records of the merged parent 
record.

Unique child records with 
one-to-many relationship

Automatic 
inheritance.

The child records from each of the parent records become the 
child records of the merged parent record.

Example

Let's consider merging three duplicate records, where each record has a parent-level with name, date of birth, 
and gender details. The child record level includes the home address and phone numbers.

The following image shows how the three person records are merged:
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Scenario for Duplicate Records
You work for an insurance organization. A customer, Paula Laine, calls to review her home insurance policy. 
You ask Ms. Laine for her policy number, and enter the policy number in the Search box.

In the search results, you select the record that contains the policy number, and open the record in the 
Business Entity view. You confirm a few personal details and then answer Ms. Laine's questions about her 
policy.

After you answer her questions, you ask Ms. Laine if she has any other policies. Ms. Laine tells you that she 
has an automobile policy registered with a subsidiary of your organization. You enter the automobile policy 
number in the Search box, and the search returns the record that contains the automobile policy. You verify 
that the personal data matches the data in the other record.

After you end the conversation, you open the record that contains the home policy in the Matching Records 
view. From the similar records, you select the entity that contains the automobile policy. You click Preview 
and verify that both policies appear in the Policies section. In addition, you can see that the merged record is 
more complete overall, with data such as Ms. Laine's middle name and her mobile phone number coming 
from different source records. When you are satisfied that the merge preview represents the best version of 
the truth, you start the merge process.

Resolving Duplicate Records
Use the Matching Records view to identify duplicate records. You can resolve the duplicate records by 
merging them. To merge records, your user role must include the merge permission.

You can resolve the duplicate records by using the basic Matching Records view or the advanced Matching 
Records view. Use the basic Matching Records view when you want to merge only the duplicate parent 
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records. To merge the duplicate parent and child records, use the advanced Matching Records view. Your 
application might have one or both the Matching Records views configured.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

By Using the Basic Matching Records View

To resolve duplicate records using the basic Matching Records view, perform the following tasks:

1. Identify duplicate parent records.

2. Finalize the best version of the truth for parent records.

3. If child records exist, identify duplicate child records.

4. Finalize the best version of the truth for child records.

5. Merge duplicate records.

By Using the Advanced Matching Records View

To resolve duplicate records using the advanced Matching Records view, perform the following tasks:

1. Identify duplicate parent records.

2. Finalize the best version of the truth for parent records.

3. Merge duplicate records.

Identifying Duplicate Parent Records
To identify duplicate records, open the target record in the Matching Records view. The target record appears 
along with the matching records in the Matching Records view. Start by identifying duplicates at the parent 
record level.

1. Open the target record, and then, from the View list, select the name of the Matching Records view. 

Note: The record views that appear in the View list depend on the Data Director configuration and your 
user role privileges.

The matching records appear in the Matching Records view.

2. For the advanced Matching Records view only. Optionally, view only the records that satisfy a specific 
match rule. 

a. Click the Filter tab. 

b. Select Specify a match rule. 

c. Click in the field and select the match rule from the list. 

3. If duplicate records that you want to merge with the target record are missing in the Matching Records 
view, manually add the records. 

If you use queries to find records that you want to add, the queries must be created before you perform 
this step.

a. Click Add Candidate. 

The search user interface appears.

b. Find and select the records that you want to add. 

c. Click Select. 

The records are added to the Matching Records view.

Resolving Duplicate Records       61



4. Optionally, to show more information that might be helpful in determining duplicates, click Show, and 
select the options. 

Option Description

System fields Displays system fields. This option is not available in the basic Matching Records view.

Selected records Displays only the records that you select for merging. This option is not available in the basic 
Matching Records view.

Trust scores Displays trust scores for all the trust-enabled fields. Trust settings are managed by the MDM 
administrator.

5. Identify the duplicate records that you want to merge with the target record. 

a. Compare the data of each matching record with the target record. 

b. Select the duplicate records. 

Note: You cannot select records if your user role does not include permission to merge the records. 
To request changes to your role privileges, contact your MDM administrator.

The Merge Preview column shows the result of merging the records.

6. Optionally, remove records that you do not want to merge or are not duplicates. 

a. To remove a manually added record from the Matching Records view, from the Actions menu of the 
record, click Remove Candidate. 

b. To remove a system matched record from the Matching Records view and dissociate it as a match 
of the target record, from the Actions menu of the record, click Not a match. 

When you dissociate a matching record, the record does not automatically match again.

Finalizing the Best Version Of the Truth
After you identify the duplicate records that you want to merge, finalize the best version of the truth. The 
Merge Preview column in the Matching Records view displays the best version of the truth based on the trust 
scores. You can finalize the best version of the truth by promoting or overriding the values in the Merge 
Preview column with values that you think are correct.

1. Review the values in the Merge Preview column. 

2. If an incorrect value is displayed in the Merge Preview column, review the values for the field in the 
matching records, and perform one of the following actions: 

Action Description

Click the correct value The correct value appears in the Merge Preview column. Data Director promotes 
the correct value over the incorrect value.

Enter the correct value in 
the Merge Preview column

Data Director overrides the incorrect value with the value that you enter in the 
Merge Preview column.
Note: You can only edit fields for which you have edit privileges.

Identifying Duplicate Child Records
If you use the advanced Matching Records view, you can identify the duplicate child records by reviewing the 
child records and their descendant records in the Matching Records view. Select a target child record with 
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which you compare the child records of other parent records. Select the duplicate child records that you want 
to merge.

Note: As you work with the child records, you might find data that makes you decide that a parent record is 
not a duplicate. You can return to the record overview and clear the check box for that parent record. The 
data in the Merge Preview column is refreshed.

1. In the Navigate panel, expand a node and select a child record as the target record. 

The target child record appears next to the Merge Preview column. The remaining child records appear 
in the other columns.

Tip: If the record shows a pending status, the record cannot be merged with other records.

2. Select the duplicate child records that you want to merge with the target child record. 

Tip: If the record shows a pending status, you cannot select the record to merge with other records.

The Merge Preview column shows the result of merging the target child record with the duplicate child 
records.

3. If the target child record can be further expanded, then expand the record and select the node that is 
exposed. 

All the fields of the child records are displayed.

4. Repeat the process on the remaining child records. Optionally, you can perform the same process on 
descendant records. 

5. Click Merge. 

6. In the Merge Duplicates dialog box, confirm the merge. 

A manual merge request is saved in an internal change list.

Merging Duplicate Records
After you identify the duplicate records and finalize the best version of the truth, you can merge the duplicate 
records.

1. Optionally, preview the result of merging the records. 

a. Click Preview. 

The Record Preview appears.

b. Review the record. 

c. To return to the Matching Records view, click Back. 

2. Merge the duplicate records manually or queue the duplicate records for an Automerge job. 

• To manually merge the duplicate records, click Merge.

Based on your user role privileges, one of the following actions occur:

User Role Privilege Result

Requires a review process to 
merge records

The duplicate records that you selected go through the merge review 
workflow. The records remain in the active state, but the records are 
merged only after the merge proposal is approved.

Does not require a review 
process to merge records

The duplicate records that you selected are merged into a single record 
and remain in the active state.
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• To automatically merge the duplicate records, click the Actions menu, and then click Queue for 
Merge.

The records are queued for merge, and the records merge when the Automerge job runs. The 
Automerge job is run by the MDM administrator.

Note: If your user role does not have the privileges to merge records, the Queue for Merge menu item 
is not available.

Related Topics:
• “Establish the Best Version of the Truth” on page 67

• “Identifying Duplicate Parent Records” on page 61

Resolving Duplicate Child Records in a Single Record
To resolve duplicate child records within a single record, open the record in the Matching Records view. Do 
not select any other records.

1. Open the record that has duplicate child records, and then, from the View list, select the name of the 
Matching Records view. 

Note: The record views that appear in the View list depend on the Data Director configuration and your 
user role privileges.

The record appears in the Matching Records view.

2. In the Navigate panel, expand a node and select a child record as the target record. 

The target child record appears next to the Merge Preview column. The remaining child records appear 
in the other columns.

3. Select the duplicate child records that you want to merge with the target child record. 

The Merge Preview column shows the result of merging the target child record with the duplicate child 
records. The most trustworthy field values are highlighted. The highlighted values appear in the Merge 
Preview column.

4. Review the values in the Merge Preview column. 

5. If an incorrect value is displayed in the Merge Preview column, review the values for the field in the 
matching records, and perform one of the following actions: 

Action Description

Click the correct value The correct value appears in the Merge Preview column. Data Director promotes 
the correct value over the incorrect value.

Enter the correct value in 
the Merge Preview column

Data Director overrides the incorrect value with the value that you enter in the 
Merge Preview column.
Note: You can only edit fields for which you have edit privileges.

6. Repeat the process on the remaining child records. Optionally, you can perform the same process on 
descendant records. 

7. Merge the duplicate records manually or queue the duplicate records for an Automerge job. 

64       Chapter 6: Resolving Duplicate Records



• To manually merge the duplicate records, click Merge.

Based on your user role privileges, one of the following actions occur:

User Role Type Outcome

Requires a review process to 
merge records

The duplicate records that you selected go through the merge review 
workflow. The records remain in the active state, but the records are 
merged only after the merge proposal is approved.

Does not require a review 
process to merge records

The duplicate records that you selected are merged into a single record 
and remain in the active state.

• To automatically merge the duplicate child records, click the Actions menu, and then click Queue for 
Merge.

The child records are queued for merge, and the records merge when the Automerge job runs. The 
Automerge job is run by the MDM administrator.

Note: If your user role does not have the privileges to merge records, the Queue for Merge menu item 
is not available.
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C h a p t e r  7

Establishing the Best Version of 
the Truth

This chapter includes the following topics:

• Master Records and the Best Version of the Truth, 66

• Scenario, 67

• Establish the Best Version of the Truth, 67

• Understand Manual Updates to a Master Record, 68

• Unmerge Cross-reference Records, 69

Master Records and the Best Version of the Truth
Master records in the MDM Hub maintain the best version of the truth. The MDM Hub consolidates the most 
trustworthy data from several source systems into each master record to achieve the best version of the 
truth.

The MDM Hub stores source data in cross-reference records. In the Cross-reference Records view, a data 
steward can examine these cross-reference records and investigate which source data contributes to the 
master record. Data stewards can then make adjustments to how source data is consolidated to ensure that 
the master record represents the best version of the truth.

The MDM Hub calculates a trust score for the fields in the cross-reference records. The trust calculation is 
based on settings and rules that are establish by an administrator. For more information about configuring 
the rules that govern trust score calculations, see the Multidomain MDM Configuration Guide.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.
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Scenario
A data steward investigates why customer data in a master record does not represent the best version of the 
truth.

The phone number for a customer has recently changed to 555-5555. None of the cross-reference records 
contain this phone number, so the data steward selects the phone number field in the master record and 
enters the correct phone number.

A master record for a customer record shows the middle name of a customer as 'Stacy'. In fact, the correct 
spelling of the middle name is 'Stacey'. The data steward sees that a cross-reference record contains the 
correct spelling but does not contribute to the master record. The data steward selects the field with the 
correct spelling as the contributor to the master record.

The master record that represents Joe Smith actually contains two cross-reference records that represent 
customers who are not Joe Smith. The data steward unmerges these two mismatched cross-reference 
records from the master record representing Joe Smith. Master records are created from the unmerged 
cross-reference records.

Establish the Best Version of the Truth
Data stewards can use the Cross-reference Records view to examine the composition of the master record. 
Data stewards can then make adjustments to ensure the master record genuinely represents the best version 
of the truth.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

If the most trusted fields do not contain the best data, a data steward can perform the following actions to 
establish the best version of the truth:

Action Description How-to

Enter the correct 
value

If the correct value does not exist in any cross-
reference record, a data steward can enter the correct 
value in the master record.

Click the incorrect value in the Master 
Record column, and then enter the 
correct value. Press Enter, and then 
click Save.

Select the correct 
contributing field

If the field with the highest trust score does not 
contain the best version of the truth, a data steward 
can select the field that does contain the correct data 
to contribute the data to the master record.

Click the field that contains the correct 
data. Click Save

Remove 
mismatched 
source data

If a cross-reference record should not be associated 
with a particular master record, a data steward can 
unmerge the cross-reference record. A new master 
record is created from the unmerged cross-reference 
record.

Select the checkbox for the cross-
reference records that contain the 
mismatched data, and then click 
Unmerge.
For more information about 
unmerging, see “Unmerge Cross-
reference Records” on page 69.
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The following image shows the ways in which data stewards can establish the best version of the truth:

1. Enter the correct value
2. Select the correct contributing field
3. Select a cross-reference record to unmerge

Understand Manual Updates to a Master Record
In the Cross-reference Records view, the highlighted cells indicate the values with the highest trust score. 
You can manually update a value, regardless of the trust score for the field. When you manually update a 
value in the master record, the Master Record column shows the changed value. The cell highlight continues 
to identify the value with the highest trust score.

For example, consider a gender code field with the possible values: UNKNOWN, MALE, and FEMALE. In the 
following image, the gender code in the Master Record column is UNKNOWN, but the most trusted value is 
MALE:

1. The value in the master record is UNKNOWN.
2. The most trusted value (80%) is MALE.

The value in the Master Record column is the updated value of UNKNOWN. In the Admin column, the value 
UNKNOWN has a trust score of 45, because a validation rule downgrades the trust score whenever the value 
of the Gender Cd field is UNKNOWN.

Tip: Another way to update a value in the master record is to call the Put API with the TrustOverrideField 
parameter. After the update, the Put process recalculates the best version of the truth for all fields except the 
field with the trust override.
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Unmerge Cross-reference Records
If a cross-reference record should not be associated with a particular master record, a data steward can 
unmerge the cross-reference record. A new master records is created from the unmerged cross-reference 
record.

The following illustration shows the unmerge behaviour when a cross-reference record is unmerged from a 
master record that is comprised of five cross-reference records:
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C h a p t e r  8

Investigating Data Changes
This chapter includes the following topics:

• Investigating Data Changes Overview, 70

• Investigating Data Changes Scenario, 70

• Comparing Data Before and After Events, 71

Investigating Data Changes Overview
You can compare the best version of the truth at different moments in time for a particular record. If you 
suspect that the data in the record has changed inappropriately, you can use the History view to identify the 
data event that caused the data change.

The History view displays a chronology of data changes over the lifespan of the record. You can view the 
data that existed in the record at any point in time in the chronology. View the data before a data event and 
after a data event to determine if the event caused the inappropriate data change. A data event is any action 
that changes the data in a record, such as an edit or a merge operation.

Investigating Data Changes Scenario
A customer reports that he recently changed his email address and he wants to confirm that you have his 
current contact details. You look in the History view for the record that represents this customer.

The customer stated that he changed his address in October of the current year, so you look for data events 
in the History view chronology that occurred around that time. You see that multiple data events occurred in 
October for the record that represents the customer. You navigate to the Email child record and compare the 
data before and after the data events. You see that the new email address for the customer was added. After 
further investigation, you see that the middle name of the customer was added.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.
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Comparing Data Before and After Events
Use the History view to compare changes to master data.

1. With the record open, from the View list, select History. 

Note: The record views that appear in the View list depend on the Data Director configuration and your 
user role privileges.

The History view opens. Changes to the record appear on the timeline.

2. Optionally, select filters to show or hide different types of events. 

3. Optionally, select a time unit to group data events. To do this, click Options and choose a different 
timescale. For example, select M to select a monthly timescale. 

The following image shows data events grouped under the month of October:

4. Click the event labeled Email. 

The event details panel shows the record details before and after the event and the time when the record 
was updated. In this example, the email address has changed from jsmith@example.com to 
jxsmith88@example.com.
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5. Click the event labeled SMITH, JOHN. 

The following image shows that the display name of the record changed from John Smith to John Xavier 

Smith.
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C h a p t e r  9

Investigating Data Change Events 
for Effective Periods

This chapter includes the following topics:

• Investigating Data Change Events for Effective Periods Overview, 73

• Investigating Data Change Events Scenario, 73

• Viewing Data Change Events, 74

• Adding Data Change Events, 75

• Removing Data Change Events, 75

Investigating Data Change Events for Effective 
Periods Overview

A data change event is a change to data such as marital status, address, and phone number that is effective 
for a time period. Records can have multiple data change events. Use the Timeline view to investigate data 
change events of records.

The changes to data result in new effective periods or updates to an existing or a future effective period. You 
can use the Timeline view to view changes to data over a period of time. Also, you can add and remove data 
change events to and from the timeline. To manage the data change events, use the Business Entity view or 
the Data view.

Note: The Timeline view is available only to customers who upgraded from the subject area model to the 
business entity model. If timeline is enabled for base objects in the MDM Hub Store, the Timeline view is 
available for business entities that belong to the base objects.

Investigating Data Change Events Scenario
Your organization wants to renew and also offer a new insurance package to Alex Sam. To offer a suitable 
package, you need to investigate the data change events for the record for Alex Sam.

You open the record for Alex Sam in the Timeline view. You specify a specific point in time for which you 
want to view the data change events for Alex Sam. The data change events that occurred up to the date you 
specify appear in the Timeline view. You select data change events and view the details. You find that in the 
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past, Alex Sam was single and went by the name Alex Johns. You now have the information that will help you 
offer a suitable insurance package that will benefit Alex and the organization.

Viewing Data Change Events
You can view the data change events for a record in the Timeline view.

1. Open a record. 

2. From the View list, click Timeline. 

The record opens in the Timeline view. The data change events of the record that occur up to the current 
date appear in the view.

3. Optionally, to identify the data change events that occurred up to a specific point in time other than the 
current date, use the calendar in the History date up to field to select a date. 

The data change events that occur up to the specified point in time for the record appear.

The following image shows the data change events that occurred up to September 20, 2016 for the 
record, Alex Sam:

4. To move into view the portion of the timeline that has the data change events that you want to inspect, 
enter a date range or use the slider. 

The following image shows a portion of the timeline with data change events and the corresponding 
slider adjustment:

5. To view the details of the data change events, move the pointer over the squares. 

The following image shows the details of two data change events:
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6. To open a data change event, right-click the event, and then click View details on effective date. 

The data change event opens in a tab below the timeline. The data change event contains the record 
details for the specified effective period.

The following image shows the data change event for Alex that is effective on May 4, 1990:

The data change event shows that Alex Sam was single and went by the name Alex Johns.

Adding Data Change Events
You can add the data change events of a child record to the timeline in the Timeline view.

1. Open a record in the Timeline view. 

2. To view the child record, click the child record tab. 

The data change events for the child record appear.

3. Select the data change event that you want to add to the timeline, and then click Add Record to 
Timeline. 

The data change event of the child record is added to the timeline.

Removing Data Change Events
You can remove data change events for a child record from the timeline in the Timeline view.

1. Open a record in the Timeline view. 

2. Optionally, to identify the data change events that occurred up to a specific point in time other than the 
current date, use the calendar in the History date up to field to select a date. 

The data change events that occur up to the specified point in time for the record appear.

3. To move into view the portion of the timeline that has the data change events that you want to inspect, 
enter a date range or use the slider. 
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4. To remove a data change event, right-click the event, and then click Remove record from timeline. 

The data change event is removed from the timeline.
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Part II: Data Director with Subject 
Areas

This part contains the following chapters:

• Adding Subject Area Records, 78

• Investigating Data Changes in the History View (Legacy), 81

• Merging Records in the Matches View, 86

• Unmerging Records in the XREF View, 92

• Search Queries from the Data Tab, 98

• Working with Records in the Data Tab, 109

• Investigating Timeline Data in the Effective Periods View, 116

• Importing Data, 120
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C h a p t e r  1 0

Adding Subject Area Records
This chapter includes the following topics:

• Adding Records in the Data View Overview, 78

• Creating Records in the Data View, 79

Adding Records in the Data View Overview
To create records based on a subject area, use the New tab with the Subject Area option and select a subject 
area.

Note: To use the New tab, your user role must include the Create permission for subject areas.

Note: In the New window, if you see both the Business Entity option and Subject Area option, ask the MDM 
administrator which one to use. The Business Entity option opens an entity tab while the Subject Area option 
opens the Data tab.

Example of Adding Subject Areas in the Data View
You are an insurance agent for a large insurance company. You have a new customer, Anthony Lomax, on the 
phone. You want to add Mr. Lomax to the database.

To add Anthony Lomax, you perform the following steps:

1. You check for an existing record by running a search. The search returns no results.

2. In the navigation bar, click New. In the New window, select Person as the subject area.

3. In the Data view, you type in Mr. Lomax's information in the form.
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Creating Records in the Data View
To add a record based on a subject area, start from the New tab and select the subject area. The MDM 
administrator defines the subject areas and the types of data that you need to enter for the subject area.

1. In the navigation bar, click New. In the New window, select a subject area. 
For example, the application for an insurance company defines a Person subject area within a Customer 
subject area group. To add Anthony Lomax as a customer, a business user clicks New and then selects 
Customer > Person.

The Data tab contains a New Person tab with an empty data entry form. A field name with a red asterisk 
indicates a required field.

2. For each required field, click the field and type the value. 

3. For each optional field for which you have data, click the field and type the value. 

4. Optionally, type the URL to an image file in the image_url field. For best results, link to an image that is a 
maximum of 200 x 200 pixels. 

Note: For images, the MDM Hub stores the URL, not the file. If the location of the file changes, you must 
update the URL.

The following image shows some data for a record:

5. Click Apply. 

The application validates the data. If there are errors, correct them.

6. Add data to sections in the Data view. 

a. Expand a section, such as Address or Telephones. 

b. Click the Add icon. 

c. Fill in the fields. 
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The following image shows the Telephones section:

d. Click Apply. 

7. If you need to change the value of a field, click the Edit icon, edit the fields, and click Apply. 

8. After you finish adding data, save the data. 

• If your user role permits you to save data without a review, click Save. The application saves the 
record to the MDM Hub Store in active records.

• Otherwise, click Send for Approval. In the Create Task dialog box, review the task details, edit the 
details as required, and click OK. The application saves the record in pending records and initiates a 
review process.
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Investigating Data Changes in the 
History View (Legacy)

This chapter includes the following topics:

• Investigating Data Changes Overview, 81

• Opening the History View, 82

• Viewing Data Events in the History View Chronology, 82

• Comparing Data Before and After Data Events, 83

Investigating Data Changes Overview
You can compare the best version of the truth at different moments in time for a particular record. If you 
suspect that the data in the record has changed inappropriately, you can use the History view to identify the 
data event that caused the data change.

The History view displays a chronology of data changes over the lifespan of the record. You can view the 
data that existed in the record at any point in time in the chronology. View the data before a data event and 
after a data event to determine if the event caused the inappropriate data change. A data event is any action 
that changes the data in a record, such as an edit or a merge operation.

Scenario for Investigating Data Changes
A customer reports that they recently began receiving electricity bills for a property that does not belong to 
them. You suspect that the record that represents this customer was updated inappropriately. You look in the 
History view for the customer to determine which data event caused the problem.

The customer stated that the billing issue started in June of the current year, so you look for data events in 
the History view chronology that occurred around that time. You see that the record was merged in June. You 
compare the data before the merge and after the merge. A record for customer Joe Smith was merged with a 
record for customer John Smith. These records should be two distinct records because they represent two 
different customers.
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Opening the History View
Use the History view to investigate changes to master data.

u To open a record in the History view, perform one of the following actions: 

• In a Search tab that displays search results, select a record. Click Actions > History.

• Open a record and click the History icon.

The History view opens. Changes to the record appear on the timeline.

Viewing Data Events in the History View Chronology
Data events appear on the chronology as squares. Identify when data events occurred, and then use the 
slider to move the relevant portion of the chronology into view.

1. Identify the data events that have occurred over the lifespan of the record. 

On the chronology slider, data events appear as black squares.

2. Move the scroll box to bring the data event you want to inspect into view. 

3. Enter a date range or zoom in or out to adjust the History view to a convenient time scale. 

82       Chapter 11: Investigating Data Changes in the History View (Legacy)



4. Move the pointer over the squares to view the details of the data event. 

Comparing Data Before and After Data Events
You can view the best version of the truth for a record at a specific points in time, and then compare the 
differences. View the data before and after a data event to determine how the data event affected the data in 
the record.

1. To view the data as it existed before a data event, position your pointer in the chronology to the left of 
the data event, right-click, and click View Entity Details. 

An orange line appears in the chronology to indicate the point in the chronology for which you are 
viewing data.

2. Below the chronology, examine the record data for that point in time. 
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The date for which the data is effective appears in the top leftmost side of the view.

3. To view the data in a record as the data existed after a data event, right-click the chronology to the right 
of the data event. Click View Entity Details. 
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An orange line appears in the chronology to indicate the point in the chronology for which you are 
viewing data.

The History view displays the record data for that date below the chronology.

4. Examine the record data for that point in time and note any differences from the data that existed before 
the data event. 

Comparing Data Before and After Data Events       85



C h a p t e r  1 2

Merging Records in the Matches 
View

This chapter includes the following topics:

• Merging Records Overview, 86

• Opening the Match Merge Comparison View, 88

• Selecting Merge Candidates, 88

• Overriding the Merge Preview Results, 89

• Sending a Merge Proposal for Review, 90

Merging Records Overview
You can merge two or more records that contain data for the same record, such as a customer, into a single 
consolidated record. The record that results from the merge represents the best version of the truth for that 
record.

Before you merge similar records, you can view the matches for the record in the Matches view. When you 
open a record in the Matches view, the SearchMatch API searches for matching records based on the match 
columns and rule definitions. The IDD application displays the matching record that the SearchMatch API 
retrieves and the matching record from the matches table.

When you merge record, the root records of the record are consolidated into a single root record. The child 
records from each of the root records become child records of the merged root record.
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The following image shows the effect of a merge on the root records and child records:

You can open a record in the Match Merge Comparison view. You can view similar record that are potential 
matches. You can then select records that are potential matches as merge candidates. You can preview the 
result of a merge between the record and the merge candidates that you select.

If you want to change the winning field value, select a winning field from a different record or manually enter 
a new value for a field. After you are satisfied that the values in the Merge Preview column are the most 
correct, you can send the proposed merge for approval.

Example of Merging Records
You are on the phone with a customer. When you open the record, you see similar records that potentially 
represent the same customer. You select potential matches as merge candidates, and then preview the result 
of the merge.

The merge preview looks good, except that you confirm with the customer that the following values are 
incorrect:

• The records contain two different birth dates for the customer: 23 June 1970 and 19 June 1970. 
Informatica Data Director selects 23 June 1970 as the correct birthday, but the customer's birthday is 19 
June 1970. You manually select 19 June 1970 as the correct birth date.

• The customer mentions that the spelling of the first name that you have on file is incorrect. You override 
the merge result for the first name and manually enter the correct spelling.

After you are satisfied that the merge preview represents the best version of the truth, you send the proposed 
merge for review.
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Opening the Match Merge Comparison View
Use the Match Merge Comparison view to investigate records with similar data.

u To open a record in the Match Merge Comparison view, perform one of the following actions: 

• In a Search tab that displays search results, select two or more records. Click Actions > Compare.

• Open a record and click the Matches icon.

The Match Merge Comparison view opens. Potential matches for the record appear with a merge 
preview.

Selecting Merge Candidates
You can use the Match Merge Comparison view to see if Data Director has identified any records that 
potentially match another record. You can then select the potential matches as merge candidates.

The Match Merge Comparison view displays the values for the record to which you are comparing in the left 
hand column. Any records that are potential matches appear in columns to the right of the current record. 
The merge preview shows the values for the record that would result if you merged the current record with 
any records that you have selected as merge candidates. When the Match Merge Comparison view first 
appears, the potential matches are not selected as merge candidates.

1. In the Match Merge Comparison view, review the values in the potential matches. 

2. Select the check box for each record that you determine is a duplicate of the current record. 

The Merge Preview column displays the record that would result from a merge of the current record and 
the records that you selected as merge candidates. The highlighted fields contribute data to the preview 
of the merged record.
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Overriding the Merge Preview Results
Informatica Data Director determines which field contains the best version of the truth based on the trust 
score of the field. The field with the highest trust score is considered the most trustworthy. The trust 
calculations are configured in the MDM Hub Console. You can manually select or enter a value to override the 
trust calculation.

1. In the Merge Preview column, move the pointer over the right-side of a field to reveal the Trust Override 
button. 

2. Click the Trust Override button. 

A dialog box opens. The name of the field appears in the title bar of the dialog box.

3. To choose the value that is the most trustworthy, select the value. 

4. To enter a new value, select the empty field, and then enter the new value. 

5. Click OK. 
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The values you selected and entered are considered to be the most trustworthy and appear in the preview of 
the merged record.

Sending a Merge Proposal for Review
After you are satisfied with the merge results that appear in the Merge Preview column, you can send the 
merge proposal for review.

1. Ensure you are satisfied with the results in the Merge Preview column. 

2. Click Actions > Create Merge Task. 

The Create Task dialog box opens.

3. In the Title field, enter a meaningful title for the merge task. 

For example, enter Merge A. Joshi.

4. Change any default task attributes. 

5. Optionally, add comments or attachments for the task reviewer. 

Note: The File Attachments section is available only if your IDD global properties are configured to 
enable attachments for tasks. For more information, see the Multidomain MDM Data Director 
Implementation Guide.

6. Click OK. 
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A merge review process begins.
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C h a p t e r  1 3

Unmerging Records in the XREF 
View

This chapter includes the following topics:

• Unmerging Records Overview, 92

• Opening the XREF View, 95

• Sending an Unmerge Proposal for Review, 96

Unmerging Records Overview
You can unmerge a record that was merged with another record. Use the XREF view to see the records that 
contribute to the best version of the truth for a record. If you identify a cross-reference record that should not 
be merged with the record, you can unmerge the record if you have permission or you can create an unmerge 
task. You can unmerge the cross-reference record only or you can unmerge the cross-reference record with 
lineage.

When you unmerge the cross-reference record only, the child records that were associated with the cross-
reference record you unmerge continue to be associated with the merged record.
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The following image shows the result when you unmerge the cross-reference record only:

When you unmerge the cross-reference record with lineage, the child records are associated with the 
unmerged record, just as they were before the merge.
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The following image shows the result when you unmerge the cross-reference with lineage:

You can unmerge record in the XREF view. The cross-reference view shows the best version of the truth for 
the record and the cross-reference records that have merged with the record. The cross-reference records 
are organized by the source system from which they originated. The highlighted fields show which values 
contribute to the best version of the truth. You can select a cross-reference record and create an unmerge 
task for the record to be unmerged from the record.
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The following image shows the XREF view:

1. Best version of the truth
2. Contributing cross-reference records

Example of Unmerging Record
You realize that two records should not be merged into a single record. You want to undo the merge 
operation.

You look at the record in the XREF view to see which cross-reference records should be unmerged. One 
cross-reference record represents Joe Smith and the other cross-reference record represents John Smith. 
The child record contains address information that applies to Joe Smith. You create an unmerge task and 
recommend to the task reviewer that the cross-reference record be unmerged with lineage. Unmerge with 
lineage associates the appropriate address records with the unmerged record.

Opening the XREF View
Use the XREF view to unmerge merged records. You can also view the source systems and pending cross-
reference records.

u To open a record in the XREF view, open a record and click the XREF icon. 

The XREF view opens. Fields display the master data for the selected record. The source systems 
connected to the record appear below the fields.
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Sending an Unmerge Proposal for Review
Use the XREF view to examine the cross-reference records that are consolidated into a record. You can select 
a cross-reference record to unmerge.

1. View the record in the XREF view. 

2. Examine the cross-reference records in the lower half of the view. Identify the cross-reference record to 
unmerge. 

You can click the Details tab to view child record data.

3. Right-click the cross-reference record and select Create Unmerge Task. 

The Create Task dialog box opens.

4. In the Title field, enter a meaningful title for the merge task. 
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For example, enter Unmerge Joe Smith from John Smith.

5. Change any default task attributes. 

6. Optionally, add comments or attachments for the task reviewer. 

Note: The File Attachments section is available only if your IDD global properties are configured to 
enable attachments for tasks. For more information, see the Multidomain MDM Data Director 
Implementation Guide.

7. Click OK. 

An unmerge review process begins.
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C h a p t e r  1 4

Search Queries from the Data Tab
This chapter includes the following topics:

• Search Queries from the Data Tab Overview, 98

• Types of Searches, 98

• Basic and Extended Search Queries, 99

• Advanced Search Queries, 101

• Search Results, 104

• Saved Search Queries, 105

Search Queries from the Data Tab Overview
Use the Search Form to run a search query in the Data tab. When you run a query, a search tab opens with the 
search results. Each search tab is labeled by the search query name, so that you can distinguish each search 
action. You can open multiple search tabs to perform different types of data search within subject areas and 
across subject area groups.

You can search using any of the following search types: Basic, Extended, and Advanced. The current search 
criteria is displayed at the top of your search results for easy reference. If you use a query frequently, 
consider setting this as your default query. Depending on your environment, in addition to searching with a 
subject area, you might be able to search across all subject areas within a subject area group.

Types of Searches
In the Data tab, you can perform the following types of searches:

• Basic Search. Search text, with or without a wildcard.

• Extended Search. Search match-enabled attributes. Supports fuzzy logic matching.

• Advanced Search. Search using a query statement.

Basic Search
Basic Search uses simple text comparisons to retrieve data based on your search criteria. Basic Search is 
case sensitive, so you must be careful to use uppercase letters and lowercase letters in the way you expect 

98



them to appear in the master data. You can use a wildcard character in place of a character that could be 
either uppercase or lowercase. Example: %upplies.

Note: 

• In Microsoft SQL Server environments, Basic Search is not case sensitive.

• In Microsoft SQL Server environments, you cannot use square brackets ([]) and a like operator in a search 
request. To use square brackets in a search query, enclose the first square bracket ([) in an extra pair of 
square brackets ([[]). For example, to look for a record that starts with a first name like %[ABC123]%, use 
the following search query:

first_name like '%[[]ABC123]%'
Consider using a Basic Search in the following circumstances:

• You can get reliable results by providing exact text matches and wildcard patterns (or lookup values) in 
your search criteria.

• You need to search on all available attributes.

Extended Search
Extended Search uses matching logic and match-enabled attributes to search for records. Extended Search is 
not case sensitive.

Consider using an Extended Search in the following circumstances:

• You want to expand your search because you did not get the expected results from a Basic Search.

• You want to search using fuzzy logic, which can make reliable matches by taking into account spelling 
variations, possible misspellings, and other differences that can make matching data non-identical. For 
example, using fuzzy logic, you can match on variations of the word "Street", such as "St." or "St".

If you use Extended Search, note the following restrictions:

• Fewer attributes might be available to search on. For Extended Search, you can search only on attributes 
that are configured as match-enabled attributes. On the Search tab, attributes that are not match-enabled 
are unavailable (grayed out) for search.

• If Extended Search is not available (grayed out) on the Search tab, it means that the selected subject area 
or subject area group does not have an available match-enabled attribute.

• On the Search tab, one attribute (identified by an asterisk) is always required.

Note: 

• To optimize results and performance, you must define extended searches appropriately.

• When running an Extended Search, you can view the match score for the searched query. You can use the 
match score to determine how proximate the search result is when compared to the searched query. The 
maximum value for a match score is 100.

Advanced Search
Use the Advanced Query Builder to construct complex query statements.

Basic and Extended Search Queries
You can easily switch between constructing a Basic Search or an Extended Search query.
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Wildcards in Basic Search
In your search criteria for Basic Search, wildcards are special search symbols that allow you to specify a text 
pattern instead of specific characters. You would use wildcards to increase your chances of finding the data 
you want, particularly if you did not know the exact text or were searching for text that is very similar.

Note: Wildcards are used in Basic Search only. They are not needed in Extended Search because searching is 
fuzzy by default.

IDD allows you to use two different wildcard characters

• asterisk (*)

• percent sign (%)

Their usage and effect on search is identical. These characters are interchangeable, so you can use either 
one.

You can use wildcards in two different ways:

Wildcard Represents Description

Placeholder for all 
characters to the end

The search looks for the characters to the left of the wildcard, and accepts any 
characters thereafter. For example, if you specified the following search criteria for First 
Name:
Mar*
or
Mar%
IDD could return results for:
Mary, Mark, Marilyn, Marty

Placeholder for a single 
character

The search accepts any single character in the position of the wildcard. For example, if 
you specified the following search criteria for First Name:
T*m
or
To*
IDD could return results for:
Tim, Tom 

Tip: When using wildcards in Basic Search, make sure that you have positioned the wildcard character 
correctly. Incorrect placement can yield unexpected search results.

Specify Search Criteria
After you have an open query on the Search tab, you can specify the search criteria that describes the data 
you are looking for.

• You must specify search criteria for any required attribute, which is indicated by an asterisk (*).

• If Extended Search is not available (grayed out), it means that the selected subject area does not have 
available match-enabled attributes.

• If you select Extended Search, only match-enabled attributes will be available. Unavailable attributes are 
grayed out. You will not be able to specify search criteria for unavailable attributes.

• For Basic Search, you can use wildcards to specify text patterns for searching.

• If a selected attribute is configured as a lookup (for example, a list of countries), you will see a drop-down 
list of values to search on.
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Note: 

• For a timeline-enabled primary object, you can perform a search query for an effective date by specifying 
the search criteria and the effective date in the Search workspace.

• If you are performing a search for a timeline-enabled record and if the effective period is blank, the data in 
the search result is based either on the current effective date or from the base object value.

• To clear the search criteria, select Reset from the Actions menu. To clear the selection in a drop-down list, 
click DELETE or BACKSPACE.

Creating Basic or Extended Queries
To create a query, open the Search Form.

1. To open the Search Form, in the navigation bar, click Data. 

2. If the Search Form is not visible, click Search Form. 

3. From the Actions menu, click New > Standard for Basic and Extended queries. 

4. In the Query Builder window, select the subject area or subject area group through which you want to 
search. 

5. Expand the Available Attributes list and select the attributes that you want to include as search criteria 
for this query. 

Based on how the application developer configured Informatica Data Director, you can search for data 
that is outside the selected subject area or subject area group, such as cross-reference data or other 
subject areas.

6. In the Added Attributes list, rearrange the sequence of the attributes so that they appear in the order you 
want in the search query screen. 

7. If available, select the attribute by which you want the results table sorted, and specify a sort order of 
ascending or descending. 

8. Click OK. 

The query appears in the Search tab.

9. To use the query again, save the query before you build or open another query. 

Advanced Search Queries
Use the Advanced Query Builder to construct complex queries using free form query text. Advanced Search 
provides capabilities for specify search conditions that go beyond the capabilities of standard (basic and 
extended) queries. Advanced search criteria are used in the query's SQL WHERE clause.

Advanced Search uses SQL syntax and supports:

• Logical operators - AND/OR/NOT

• EXIST, NOT EXISTS, and COUNT conditions

• Comparisons operators range comparison (=, >, <, >=, <=, BETWEEN)

Be sure to validate your query syntax. You cannot save a query with invalid syntax.
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Logical Operators
Use logical operators when a search query contains multiple conditions.

The following table describes the operators that you can use and provides an example for each operator:

Operator Description Example

AND Evaluates two conditional expressions and:
- Returns TRUE if both conditions are TRUE.
- Returns FALSE if either condition is FALSE
- Otherwise returns UNKNOWN.

MATCH_PATH_COMPONENT.C_MT_ADDRESS|CITY_NAME 
= 'New York' AND COLUMN.C_PARTY|
ORGANIZATION_NAME = 'Informatica LLC'

OR Evaluates two conditional expressions and:
- Returns TRUE if either condition is TRUE.
- Returns FALSE if both conditions are 

FALSE.
- Otherwise, returns UNKNOWN.

MATCH_PATH_COMPONENT.C_MT_ADDRESS|CITY_NAME 
= 'London' OR 
MATCH_PATH_COMPONENT.C_MT_ADDRESS|CITY_NAME 
= 'Paris'

NOT Negates the conditional expression that 
follows.
- Returns TRUE if the following condition is 

FALSE.
- Returns FALSE if the following condition is 

TRUE.
- If it is UNKNOWN, it remains UNKNOWN.

MATCH_PATH_COMPONENT.C_MT_ADDRESS|
COUNTRY_CODE = 'USA' and NOT 
MATCH_PATH_COMPONENT.C_MT_ADDRESS|CITY_NAME 
= 'Los Angeles'

Conditional Operators
Use conditional operators to restrict your search results based on a supported condition.

The following table describes the operators that you can use and provides an example for each operator:

Operator Description Example

EXISTS Returns true if at least one row 
meets the specified condition in the 
subquery. NOT EXISTS is also a 
valid construct.

EXISTS(C_MT_PERSON_DETAILS, 
MATCH_PATH_COMPONENT.C_MT_PERSON_DETAILS|
BIRTH_CITY = 'NEW YORK') 

COUNT Returns the number of rows that 
meet the specified condition.

COUNT(C_MT_ADDRESS, 
MATCH_PATH_COMPONENT.C_MT_PARTY_ADDRESS_REL|
ADDRESS_TYPE = 'Shipping')
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Comparison Operators
Use comparison operators when you want to restrict the search results based on the values for the attribute 
you search on.

The following table describes the operators that you can use and provides an example for each operator:

Operator Description Example

= equals MATCH_PATH_COMPONENT.C_MT_CUSTOMER|ACCOUNT_CD = 
'123456879'

> greater than MATCH_PATH_COMPONENT.C_MT_ADDRESS|POSTAL_CD > 42000

< less than MATCH_PATH_COMPONENT.C_MT_ADDRESS|POSTAL_CD < 30000

>= greater than or equals MATCH_PATH_COMPONENT.C_MT_CUSTOMER|SALES >= 1000000

<= less than or equals MATCH_PATH_COMPONENT.C_MT_CUSTOMER|SALES <= 1000000

BETWEEN between two values (inclusive) MATCH_PATH_COMPONENT.C_MT_ADDRESS|POSTAL_CD BETWEEN 
94000 AND 96000

Date Syntax in Advanced Search Queries
You must use the correct syntax to ensure a query returns the expected results when the query contains date 
system columns.

All date system columns, such as the CREATE_DATE column, have a granularity of milliseconds. If you use 
the '=' comparison operator in a query, you must specify the date to a granularity of milliseconds.

For example, the following query does not return results for records created on August 23, 2013 because it 
does not specify a date with a granularity of milliseconds:

Person.CREATE_DATE = '23/Aug/2013' 
To run a query for a specific date without specifying a granularity of milliseconds, you can run a query on a 
range for that date.

For example, the following query returns records created on August 23, 2013:

Person.Create Date >= '23/Aug/2013' AND Person.Create Date < '24/Aug/2013' 

Creating Advanced Search Queries
To create an advance query, use the Advanced Query Builder.

1. In the navigation bar, click Data. 

In the Data tab, a new tab opens with the Search Form displayed.

2. From the Actions menu, select New > Advanced. 

The Advanced Query Builder - New Query dialog box opens.

3. Select the subject area that you want to search from the Subject Area list. 

4. Select the attributes that you want to include in the search from the Available Attributes field. 

• To include a count for the attribute in your results, click Insert COUNT.
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• To check for the existence of data, click Insert EXISTS.

When you select an attribute, the attribute appears in the Query Filter Criteria field.

5. Add logical operators, conditional operators, and comparison operators to the query as required. 

6. Optionally, select a sort option from the Sort Results By list and select an ascending or descending sort 
order. 

7. Optionally, enable Case Insensitive search. 

8. To verify the query syntax, click Validate Query. 

• If the query contains syntax errors, the Query Validation Error dialog box opens with a description of 
the syntax errors. Click Close, correct all syntax errors, and then revalidate the query.

• If the query does not contain syntax errors, a message confirms that the query is valid. Click Close.

9. Click OK. IDD revalidates the query to ensure no query syntax errors exist. 

If IDD does not detect syntax errors, a search tab opens in the Data tab.
If IDD detects syntax errors, the Query Validation Error dialog box opens. Resolve the query issues and 
then click OK again.

10. Click Run Search. 

The query results appear in the Search tab.

Example of an Advanced Search Query
COLUMN.C_PARTY|LAST_NAME like 'H%'
MATCH_PATH_COMPONENT.C_MT_PERSON_DETAILS|REMARKS is not NULL
COLUMN.C_PARTY|GENDER_CD = 'M'

Search Results
After you run a search, the search results appear in a search tab. You can open a business entity from the 
search results. You can also export search results.

Opening Records from Search Results
To investigate a record, you can select it from the search results and open the record in the Data tab. You 
search by using the search form in the Data tab, by clicking Queries, or by using the Search box in the header.

When you open a record that is timeline-enabled, specify an effective period for which to view the record. The 
default value in the field for the effective date is the current date. If you leave the effective date field empty, 
all the record versions are opened.

1. Search for the record. 

2. In the search results, select the record. 

3. Open the record in one of the following views: 

View Description

Data To view and edit the record, click Open.
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View Description

Matches To compare the record with potentially duplicate records, click Actions > Compare.

Hierarchy To view a diagram of the relationships between records, click Open Hierarchy.

Business Entity To view and edit the record in context with other sources of information about the record, click 
Entity View.

4. If prompted, specify the effective period that you want to investigate. 

The record opens in the view.

Related Topics:
• “Resolving Duplicate Records” on page 56

Exporting Search Results
If available in your environment, you can export all or selected search results to a CSV file.

• To export all results, click Actions > Export > All Results.

• To export some of the results, press the Ctrl key and click the records. Click Actions > Export > Selected 
Results.

Saved Search Queries
Consider saving the search queries that you expect to reuse.

To run a query, you must first open it so that it appears in the search form. You can open any available query 
in the list of saved queries. Available queries are queries that you have created, in addition to queries that 
others have made public.

You must have read privileges on the columns in the query, read privileges on the subject area, and read 
privileges on the package that is configured as the search package in the configuration manager tool for the 
subject area.

Saving Search Queries
To save a query so you can use it again, save it in the query builder. When you save a query, Informatica Data 
Director recognizes you as the owner of the query.

1. On the Search tab, select Save from the Actions menu. If you want to save it under a different name, 
click Save As instead. 

2. In the Save window, you can specify a different query name. 

3. Indicate whether you want to make this your default query. 

4. Depending on your environment and role, you might have the option to mark this query as Public, which 
allows others to use it as well. 

5. Click Save. 
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Running Saved Search Queries
You run saved search queries from the Search Form.

1. At the top of the Search Form, select Saved Queries. 

2. Select a saved query or use the default query. 

3. Click Open Query. 

4. Enter values in the fields if required for your search. 

5. Click Run Search. 

The search results appear.

Viewing Details About Saved Queries
You can view query details, such as creation date and owner.

1. At the top of the Search Form, select Saved Queries.

2. Pause over a query.
A popup window displays information about the query.

Setting Your Default Query
The default query is the query that appears when you open a Search tab. Usually, the default query is the 
query that you expect to use most frequently in your job. Each user can set their own default query.

By default, no default query is defined. You must explicitly designate the saved query that you want to use. 
You can change the default query later if you find that you are using another query more frequently.

1. At the top of the Search Form, select Saved Queries.

2. Select the query that you want to designate as the default query.

3. From the Actions menu, click Set As Default.
The query name changes to a bold font.

Renaming Saved Queries
If you created a saved query, you can change the name of the query.

1. At the top of the Search Form, select Saved Queries.

2. Right-click the query name, and then click Rename.

3. Type a different name.

4. Click Save

Editing Saved Queries
To change a query that you created, you can edit it and save the changes. You cannot edit queries that you do 
not own.

1. Open the query that you want to edit. 

2. From the Actions menu in the search form, click Edit. 

3. In the Query Builder window, make the changes you want. 
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4. Click OK. 

5. Save your changes. 

Deleting Saved Queries
It is a best practice to delete queries you no longer need. You must be the creator of the query to be able to 
delete it.

1. At the top of the Search Form, select Saved Queries.

2. Right-click the query name, and then click Delete Query.

Sharing Saved Queries
You can share queries with colleagues by making the queries public or by sharing a bookmark link.

Making Saved Queries Public
Any Informatica Data Director user can use saved public queries. Only the owner can change their public 
queries.

1. In the Search Form, select Saved Queries. 

2. Right-click the saved query, and then click Mark as Public / Private. 

3. To ensure that the query is public, pause on the query. In the popup window, verify that the Visibility 
setting is set to Public. 

Sharing Query Bookmarks
To share a specific query with colleagues, copy the bookmark link and paste it in a text or email. When the 
user follows the bookmark link, the Informatica Data Director opens, prompts the user to log in, and then 
displays the bookmarked search query.

1. In the Search Form, open the query you want to share. 

2. From the Actions menu, click Show Bookmark. 

3. Copy the bookmark link. Share the link with another user. 

The user can follow the link to view the query.

Exporting Saved Queries
When you migrate an Informatica Data Director configuration from one environment to another, the saved 
search queries are not migrated. You can export the saved queries to the target environment if you need to 
use them.

1. Open the Search Form, and then select Saved Queries. 

2. Right-click the query that you want to export, and then click Export Queries. 

The query XML file is downloaded to your browser's default download location.
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Importing Saved Queries
When you migrate an Informatica Data Director configuration from one environment to another, the saved 
search queries are not migrated. You can import the saved queries from the source to the target 
environment.

If a query has the same name as the query that is being imported and is owned by the same user, the import 
process overwrites the query. If a query has the same name as the query that is being imported but is a 
public query that is owned by another user, the import process creates a version of the query with the same 
name for the user that imports the query.

If a query has errors, the import process ignores the queries. When queries are ignored, the message Some of 
the queries were not imported appears. To view the errors, check the Hub server log files.

1. At the top of the Search Form, select Saved Queries. 

2. Right-click in the Search Form, and then click Import Queries. 

3. In the Import Queries dialog box, click Browse. Select the XML file that contains the saved queries. 

4. Click Import. 
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C h a p t e r  1 5

Working with Records in the Data 
Tab

This chapter includes the following topics:

• Working with Records in the Data Tab Overview, 109

• Opening Records from Search Results, 110

• Creating Filters for Child Records, 111

• Switching Between Form and Table View, 112

• Viewing System Columns, 112

• Copying a Record, 112

• Editing Data In Records, 113

• Editing Effective Periods, 113

• Adding an Effective Period, 114

• Display Aggregated Period for Timeline-Enabled Record, 114

• Investigating a Record, 114

• Deleting a Record, 115

Working with Records in the Data Tab Overview
Use the Data tab to investigate records.

From the Data view in the Data tab, you can review and edit records. You can also use the left navigation 
icons to view the history of a record, its cross-reference records, and possible merge candidates.

You can use the Search Form in the Data view to find records. For more information about searching from the 
Data tab, see “Search Queries from the Data Tab Overview” on page 98.

Pending Records in the Data Tab
A pending record contains data that is pending approval.

In the Data tab, pending records are treated in the following ways:

• In search results, records with pending records appear in the results.
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• In the Data view, when you open a newly created record that is pending approval, the view contains the 
pending data in the parent record and all its child records.

• In the Data view, when you open a record with pending changes to the parent record, the view contains the 
approved data, not the pending changes.

• In the Data view, when you open a record with pending changes to child records, the view contains the 
approved data, not the pending changes.

• In the Data view, when you open a record with new pending child records, the view does not contain the 
new pending child records.

Opening Records from Search Results
To investigate a record, you can select it from the search results and open the record in the Data tab. You 
search by using the search form in the Data tab, by clicking Queries, or by using the Search box in the header.

When you open a record that is timeline-enabled, specify an effective period for which to view the record. The 
default value in the field for the effective date is the current date. If you leave the effective date field empty, 
all the record versions are opened.

1. Search for the record. 

2. In the search results, select the record. 

3. Open the record in one of the following views: 

View Description

Data To view and edit the record, click Open.

Matches To compare the record with potentially duplicate records, click Actions > Compare.

Hierarchy To view a diagram of the relationships between records, click Open Hierarchy.

Business Entity To view and edit the record in context with other sources of information about the record, click 
Entity View.

4. If prompted, specify the effective period that you want to investigate. 

The record opens in the view.
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Related Topics:
• “Resolving Duplicate Records” on page 56

Creating Filters for Child Records
In the child tab, if there are multiple child records, you can filter the child records based on the column name 
and its values to view only a specific (or subset) of entries. All the filters created in the data view are only 
temporary for that session, when the record is closed, you will lose all the created filters.

Filtering option is only available for One:Many and Many:Many child relationships. Also, if multiple filter 
conditions are applied, the result contains all the records that satisfy the AND condition and if multiple 
conditions are set for the same column, the result contains all the records that satisfy the OR condition.

1. In the Data view, click the child tab and click the Filter button. 

The Filter dialog box appears.

2. In the Column drop-down list, select a column value. 

Note: 

• Only column names of strings and numbers data types are supported for display in the Column drop-
down list.

• Lookup values are not displayed in the Column drop-down list.

3. Select one of the following filter conditions from the drop-down list: 

Available for Data Type Condition Description

Strings and Numbers = Column value must be equal to the filter criteria

Strings and Numbers != Column value must not be equal to the filter criteria

Numbers > Column value must be greater than the filter criteria

Numbers < Column value must be lesser than the filter criteria

Numbers >= Column value must be greater than or equal to the filter criteria

Numbers <= Column value must be lesser than or equal to the filter criteria

Strings and Numbers Is NULL Column value must be null for inclusion in the filter results

Strings and Numbers Is not NULL Column value must not be null for inclusion in the filter results

Strings Starts with Column value must start with the filter criteria

Strings Ends with Column value must end with the filter criteria

Strings Contains Column value must contain the filter criteria

Numbers Between Column value must be between the filter criteria

4. In the Value field, enter a filter criteria. 
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5. If you want to create an additional filter condition, click the add button (green plus button). 

Note: If you want to delete a filter condition, click the delete button (red cross button).

6. Click Apply. 

Note: If you want to clear filter, click the Clear Filter button.

Switching Between Form and Table View
In certain cases, you can switch between two different views of data:

• Form View shows a single record, with the record attributes displayed vertically, like a paper form. Click 
Switch to Form View if you want to isolate your investigation to a single record.

• Table View shows a list of records (one or more) in a tabular form. Each row in the table represents a 
separate record. Click Switch to Table View to see a summary list of all the associated records.

Note: 

• For subject area children, the default view (form or table) may vary depending on how your IDD is 
configured.

• For the selected child record, only associated grandchild records are displayed either in form or table 
view.

Viewing System Columns
To view system columns for the record that appears in the Data view, select System Columns from the 
Actions menu. Data Director opens a window that displays the system column details.

You can view system columns to view record metadata, such as the date on which the record was created, 
who created the record, and the row ID.

Copying a Record
You can copy a parent record and some of its children to create a record that is similar to an existing record. 
You cannot copy a timeline-enabled record.

1. In the Data tab, open the record in the Data view. 

2. Click Actions > Copy. 

3. In the new record window, change the attribute data you want. 

4. Select Save or Send for Approval, as applicable. 
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Editing Data In Records
You can edit data in a record. When you edit data, you cannot change the effective period for the record.

1. Open a record for which you want to edit the data. 

You cannot edit a record that is in the pending state because it is part of a workflow and is pending 
approval.

2. Click Actions > Edit Data. 

3. Edit the data. 

4. Click Apply. 

The fields that you edit appear highlighted.

5. Click Save. 

Data Director writes the changes to the database.

Editing Effective Periods
To correct an incorrect effective period, edit the effective period of the record. You can edit the effective 
periods for records for which you track data change events. When you edit the effective period for a record, 
Data Director saves the record with the changed effective period.

1. Open the record version for which you want to edit the effective period. 

You cannot edit a record that is in the pending state because it is part of a workflow and is pending 
approval.

a. Open the record that has the effective period that you want to edit. 

b. Click the Show Effective Periods link for the record. 

c. In the Effective Date field, use the date chooser to select a date that is within the effective period 
that you want to edit. 

d. Click Apply. 

The record version that is valid for the effective period that you want to edit opens.

2. Click Actions > Edit Period Dates. 

3. In the Edit Effective Period date fields, use the date chooser to select the correct start date and end date 
of the effective period. 

4. Select the primary and child records that you want to include in the record version that you update. 

5. Click Save. 

Data Director saves the record version with the updated effective period.
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Adding an Effective Period
You can add a record version that is applicable for a new effective period. The effective period that you add 
must be adjacent to the existing effective period. You can add effective periods to records for which you 
track data change events.

1. Open a record for which you want to add an effective period. 

2. Select the record version that you want to copy to the new effective period. 

3. Click Actions > Create New Period. 

4. In the Create New Effective Period date fields, use the date chooser to select the effective start and end 
dates. 

5. Select the primary and child records that you want to include in the new record version. 

6. Click Save. 

Data Director creates a new record version with the effective period that you specify.

Display Aggregated Period for Timeline-Enabled 
Record

For a timeline-enabled record, you can click the link Show Effective Periods to view the calculated 
aggregated period of effective periods for the record. Aggregated period is the time period where the data of 
the record does not change for any of the object (parent, children, and grandchildren). It is the intersection of 
all the effective periods for the record.

For example, if you save the effective period for the parent record for a time period 01-May-2012 to 31-
May-2012 and then you save the effective period of the child record of the same record for a time period 01-
May 2012 to 15-May-2012. The aggregated period for the record as on 01-May-2012 is 01-May 2012 to 15-
May-2012.

Note: 

• The link Show Effective Periods is available after the Save operation is completed.

• In the Data view, after you click the link Show Effective Periods, you can view the effective start date and 
effective end date of the object (parent, children, and grandchildren).

• The aggregated period displayed for the record is directly related to the date selected in the Effective Date 
field.

Investigating a Record
In the Data tab, you can change your view of the record. You can view the history of a record, its cross-
reference records, its possible merge candidates, and a diagram of related records.

1. Open the record in the Data view. 

2. If prompted, specify the effective period that you want to investigate. 

3. Based on your investigation path, select one of the following views: 
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• To view and edit the record, click the Data icon. The Data view opens.

• To view pending changes, click the XREF icon. The XREF view opens.

• To view a history of changes to the record, click the History icon. The History view opens.

• To compare the record with potentially duplicate record, click the Matches icon. The Match Merge 
Comparison view opens.

• To view a diagram of the relationships within and between records, click the Open Hierarchy button. 
The Hierarchy view opens.

• To view and edit the record in context with other sources of information about the record, click the 
Entity View button. An entity tab opens. The tab displays the name of the record.

Deleting a Record
You can delete a record that you want to remove. To delete the record displayed in the Data view, select 
Delete from the Actions menu.

Data Director marks the record as deleted and no longer displays the record, but does not remove the record 
from the database. When you delete a parent record, Data Director does not mark the child records as 
deleted. When you delete a timeline-enabled record, Data Director marks the record as deleted for all the 
effective periods.
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C h a p t e r  1 6

Investigating Timeline Data in the 
Effective Periods View

This chapter includes the following topics:

• Investigating Data Change Events for Effective Periods Overview, 116

• Opening the Effective Periods View, 117

• Viewing Data Change Events, 117

• Adding Data Change Events, 118

• Removing Data Change Events, 119

Investigating Data Change Events for Effective 
Periods Overview

A data change event is a change to data such as marital status, address, and phone number that is effective 
for a time period. Records can have multiple data change events. Use the Effective Periods view to 
investigate data change events of records.

The changes to data result in new effective periods or updates to an existing or a future effective period. You 
can use the Effective Periods view to view changes to data over a period of time. Also, you can add and 
remove data change events to and from the timeline. To manage the data change events, use the Data view.

Note: If timeline is enabled for base objects in the MDM Hub Store, the Effective Periods view is available for 
those base objects.

Example of Viewing Data Change Events
Your organization wants to renew and also offer a new insurance package to Alex Sam. To offer a suitable 
package, you need to investigate the data change events for the business entity Alex Sam.

You open the business entity for Alex Sam in the Effective Periods view. You specify a specific point in time 
for which you want to view the data change events for Alex Sam. The data change events that occurred up to 
the date you specify appear in the view. You select data change events and view the details. You find that in 
the past, Alex Sam was single and went by the name Alex Johns. You now have the information that will help 
you offer a suitable insurance package that will benefit Alex and the organization.
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Opening the Effective Periods View
Use the Effective Periods view to investigate data with effective dates.

Note: This view is available only if your administrator enabled the timeline feature.

u To open a record in the Effective Periods view, perform one of the following actions: 

• In a Search tab that displays search results, select a record. Click Actions > Show for Effective Date.

• Open a record and click the Effective Periods icon.

The Effective Periods view opens.

Viewing Data Change Events
You can view the data change events for a record in the Effective Periods view.

1. Open a record in the Effective Periods view. 

The data change events of the record that occur up to the current date appear in the view.

2. Optionally, to identify the data change events that occurred up to a specific point in time other than the 
current date, use the calendar in the History date up to field to select a date. 

The data change events that occur up to the specified point in time for the record appear.

The following image shows the data change events that occurred up to September 20, 2016 for the 
record, Alex Sam:

3. To move into view the portion of the timeline that has the data change events that you want to inspect, 
enter a date range or use the slider. 

The following image shows a portion of the timeline with data change events and the corresponding 
slider adjustment:

4. To view the details of the data change events, move the pointer over the squares. 
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The following image shows the details of two data change events:

5. To open a data change event, right-click the event, and then click View details on effective date. 

The data change event opens in a tab below the timeline. The data change event contains the record 
details for the specified effective period.

The following image shows the data change event for Alex that is effective on May 4, 1990:

The data change event shows that Alex Sam was single and went by the name Alex Johns.

Adding Data Change Events
You can add the data change events of a child record to the timeline in the Effective Periods view.

1. Open a record in the Effective Periods view. 

2. To view the child record, click the child record tab. 

The data change events for the child recod appear.

3. Select the data change event that you want to add to the timeline, and then click Add Record to 
Timeline. 

The data change event of the child record is added to the timeline.
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Removing Data Change Events
You can remove data change events for a child record from the timeline in the Effective Periods view.

1. Open a record in the Effective Periods view. 

2. Optionally, to identify the data change events that occurred up to a specific point in time other than the 
current date, use the calendar in the History date up to field to select a date. 

The data change events that occur up to the specified point in time for the record appear.

3. To move into view the portion of the timeline that has the data change events that you want to inspect, 
enter a date range or use the slider. 

4. To remove a data change event, right-click the event, and then click Remove record from timeline. 

The data change event is removed from the timeline.
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Importing Data
This chapter includes the following topics:

• Data Import Overview, 120

• Enabling Data Import in the MDM Hub Server, 121

• Importing the Data Import Template, 122

• Importing Source Data from a File, 122

Data Import Overview
An MDM administrator can permit authorized users to import data from a source file by using Data Director. 
You can import up to 10,000 records from a single source file.

Note: The data import feature is available only when you use Data Director with subject areas.

You import data to perform the following tasks:

• Create multiple primary, child, and grandchild records in a single bulk operation.

• Update multiple primary, child, and grandchild records in a single bulk operation.

To import data, you need the source file and a data import template. The data import template contains 
import profiles that map the data in the source file to columns in base object tables.

Data Director does not perform a match for duplicates operation for the data that you import.

Source File
You import data from a source file.

You can use one of the following file formats to contain your source data:

• .csv. A flat file with the data separated by a delimiter, such as a comma.

• .xlsx. A Microsoft Excel workbook with the data organized by columns in a spreadsheet.
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Data Import Template
The data import template describes how the data in a source file maps to the columns in the base object 
tables in the Operational Reference Store. To create a data import template, you require familiarity with the 
structures of both the source file and the Operational Reference Store schema.

The data import template is an XML configuration file that contains the import profiles that Data Director 
uses to import data. An import profile defines the mapping between the structure of the data in the source 
file and the user-defined columns in a base object table. You define a separate import profile for each subject 
area.

In an import profile, you can specify the format for date and numeric fields. To specify the format, follow the 
Java SimpleDateFormat pattern for date fields and the Java DecimalFormat pattern for numeric fields.

The Resource Kit includes a sample template file and a sample source file. You can find the files in the 
following location: <MDM Hub installation directory>/hub/resourcekit/samples/BDD/import

Data Import Example
For example, a data steward wants to import customer records from a Microsoft Excel spreadsheet. In the 
spreadsheet, column 1 contains first names and column 2 contains last names.

The Operational Reference Store contains a base object table called C_PARTY that has columns for the first 
name and the last name. The IDD application defines a Person subject area.

The data steward asks the MDM administrator to create a data import template to match the organization of 
the data in the source file. In the template, the developer defines an import profile for the Person subject area 
with the following mappings:

• Map column 1 in the source file to the FIRST_NAME column in the C_PARTY base object.

• Map column 2 in the source file to the LAST_NAME column in the C_PARTY base object.

The following code sample shows the import profile for this example:

<?xml version="1.0" encoding="UTF-8"?>
<DataImportTemplateConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
                          xsi:noNamespaceSchemaLocation="data-import-template.xsd">
    <ImportProfile name="IMPORT_SA_PERSON" displayName="Import profile for SA Person" 
                subjectArea="Person" effectivePeriodStart="6" effectivePeriodEnd="7" 
                effectiveDateFormat="dd.MM.yyyy">
  <PrimaryObject>
      <Column index="1">C_PARTY|FIRST_NAME</Column>
      <Column index="2">C_PARTY|LAST_NAME</Column>
                ...
     </PrimaryObject>
    </ImportProfile>
</DataImportTemplateConfig>

Enabling Data Import in the MDM Hub Server
To be able to import data, the Data Import option must appear in the New window. If the option appears, you 
can skip this step.

If the Data Import menu item is missing, ask the MDM administrator to enable the 
cmx.dataview.enabled=true property in the Hub Server properties file. For more information about Hub 
Server properties, see the Multidomain MDM Configuration Guide.

1. Stop the application server that hosts the Hub Server. 
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2. Navigate to the following location: 

<MDM Hub installation directory>/hub/server/resources/
3. Open the cmxserver.properties file and set the following property: cmx.dataview.enabled=true 
4. Save the file. 

5. Start the application server. 

Importing the Data Import Template
From the IDD Configuration Manager, an MDM administrator imports the data import template into the Data 
Director (IDD) application. The import process validates the template.

1. Log in to the IDD Configuration Manager. 

2. Select the application. 

3. Click Import > Import to existing IDD application. 

The Import to existing IDD application window opens.

4. From the Configuration type list, select Data Import Template. 

5. Click Browse and select the XML file that contains the data import template. 

6. Click Import. 

The import process validates the template. The Validation Result window opens and displays any errors.

7. If there are validation errors, resolve the errors in the template and then re-import the template. 

8. In the Validation Result window, click OK. 

Importing Source Data from a File
Use the import wizard to import the data from the source file to the Operational Reference Store. Data 
Director uses the Services Integration Framework Put API to import the data.

Important: You cannot roll back changes after you start the import process.

1. In the navigation bar, click New. Select Data Import and the type of subject area. 

Note: If you do not see the Data Import option, the IDD application is not configured to show the option 
and enable data import. Contact the MDM administrator.

The General page of the import wizard opens.

2. If the template contains more than one import profile, select the import profile that you want to use from 
the list. 

3. Click Browse and select the source file. 

4. Click Next. 

The Import Properties page opens.
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5. If the source file is a .csv file, specify the following properties: 

Property Description

Delimiters Specify the character that represents the break between data values in the source file.

Code page Specify the character encoding to use to interpret the data in the source file.

Text qualifier If quotes appear around text strings, specify the type of quotes.

6. If the source file is an .xlsx file, from the Worksheet name list, select the worksheet that contains the 
data. 

7. To control what data is imported from the source file, set the following properties: 

Property Description

Header If you want to omit the first line or row because it contains headings rather than data, 
select First line is header.

Start value import at 
line

If you want to start the import somewhere other than the first line or row, enter the line 
number.

8. Review the preview of the data. 

9. Click Next. 

The Import Progress page opens.

10. Click Start. 

The import process starts. When the import process ends, a message appears.

Note: For worksheets, the process attempts to import rows that contain data, rows that are empty but 
formatted, and rows that are empty but appear between rows that contain data. Data Director rejects the 
empty rows without processing them.

11. Click Finish. 
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Part III: Hierarchies and 
Relationships

This part contains the following chapter:

• Investigating Hierarchies and Relationships, 125
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Investigating Hierarchies and 
Relationships

This chapter includes the following topics:

• Investigating Hierarchies and Relationships Overview, 125

• Opening a Record in the Hierarchy View, 125

• Displaying Records and Relationships on the Canvas, 126

• Investigating Related Records, 131

• Changing Records and Relationships for a Record, 134

• Sharing the Hierarchy View of a Record, 137

• Troubleshooting the Hierarchy View, 138

Investigating Hierarchies and Relationships Overview
A record can have relationships to other records. When the Hierarchy Manager is enabled, you can view a 
graph that shows how a record is related to other records.

Use the Hierarchy view to investigate relationships and the related records.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

Opening a Record in the Hierarchy View
Use the Hierarchy view to examine the relationships between the open record and other records.

u To open a record in the Hierarchy view, perform one of the following actions: 

• In a Search tab search results, select a record. From the Actions menu, click Hierarchy.

• In the record view that displays an opened record, click Hierarchy from the View list.

Note: The record views that appear in the View list depend on the Data Director configuration and 
your user role privileges.
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• In the Data tab search results, select one or more records and click Open Hierarchy.

• In the Data tab, open a record and click Open Hierarchy.

The Hierarchy view opens. The selected record and the related record appear on the canvas.

Displaying Records and Relationships on the Canvas
You can change the way that records and relationships appear on the Hierarchy canvas. You can change the 
layout, create and apply filters, hide or show related records, or change other canvas display options.

Selecting a Layout
Different layouts can reveal different insights into record relationships. You can customize the size and 
spacing in some of the layouts.

1. In the canvas, click the Layouts tab. 

The Layout panel opens.

2. Click a layout icon. 

Layout Layout Name

Hierarchy.

Tree.

Circular.

Taxonomy.

Network.

Explorer View.
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3. Click Apply. 

The canvas displays the record relationships in the selected layout. If you can customize the layout, one 
or more options appear in the Layouts panel.

4. To customize the layout, set the layout options. 

• To increase a value, move the slider to the right, and then click Apply.

• To decrease a value, move the slider to the left, and then click Apply.

• In the Network layout, you can choose whether to show spheres of influence. When selected, the 
Sphere of influence option encloses each record in a circle. The size of the circle reflects the number 
of direct relationships held by each record. The more direct relationships, the larger the circle.

Filtering Records and Relationships
Use filters to show or hide a set of records and relationships. For example, you might want to simplify the 
view so that you can focus on a particular relationship.

Defining a Filter
Use the Filters panel below the canvas to select filter options to apply to the canvas.

To enable a filter option, select the option check box. To disable a filter option, clear the check box. Filter 
options are cumulative. You can select as many or as few as you need to clarify the relationships on the 
canvas. In logical terms, filters are joined by the AND operator.

1. In the Hierarchy view, click the Filters tab that is located below the canvas. 

The Filters panel opens.

2. In the Hierarchies section, select the check boxes for one or more types of business entities. 

The filter affects all selected types of business entities.

3. Click the name of a business entity type. 

The relationship filter options for the selected business entity type appear to the right. The Data Director 
application developer defines the list of filter options.

4. Optionally, change the relationship filter options for the record. 

5. Optionally, click General and change the general filter options: 

Option Description

Hide unconnected entities Hides records with no relationship to the selected record.

Show pending relationships Shows relationships that are currently under review.

6. Optionally, click Relationship Directions and change the directional filter options: 

Option Description

Show Parents Shows the parents of the selected record.

Show Children Shows the child entities of the selected record.
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Option Description

Show Unknown Shows records where the relationship between the records is unknown.

Show Undirected Shows related records where the type of relationship is not specified.

Show Bidirectional Shows related records where the direction of the relationship goes both ways.

7. Click Apply. 

The application applies the selected filter options to the canvas.

Saving a Filter
If you expect to reuse the filter options that you applied to the canvas, save the options as a filter. After you 
save a filter, you can choose to make the filter the default filter whenever the selected record is displayed in 
the canvas.

1. In the Filters panel, click Saved Filters. 

2. Type a name in the Filter Name field. 

3. To share the filter with colleagues, select Public. 

4. Click Save. 

The filter options that are currently applied to the view are saved.

5. To always apply this filter with the selected record, click the Default for Entity button. 

Applying a Saved Filter
When you apply a saved filter, the filter applies to the types of business entities selected in the filter.

1. In the Filters panel, click Saved Filters. 

2. Select the filter from the Filter Name list. 

The filter options reflect the settings in the selected filter.

3. Click Apply. 

The canvas reflects the settings in the applied filter.

Applying a Default Hierarchy Filter
When you apply a default hierarchy filter, the filter applies to the selected business entity type.

1. In the Filters panel, click Defaults. 

2. Select the filter from the Default hierarchy list. 

The filter options reflect the settings in the selected filter.

3. Click Apply. 

The canvas reflects the settings in the applied filter.
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Deleting a Saved Filter
You can delete saved filters that you no longer use. If the filter is public, check with colleagues before you 
delete it.

1. In the Filters panel, click Saved Filters. 

2. Select the filter from the Filter Name list. 

The filter options reflect the settings in the selected filter.

3. Click Delete. 

Hiding and Showing Records on the Canvas
You can hide or show selected records and records relationships on the canvas. When you hide a record in 
the canvas, the record relationship to the primary record remains intact, but the record relationship is not 
shown on the canvas.

After you hide a record, the Hierarchy view updates the remaining records that are related to the hidden 
record. In the canvas, the related records show the number of visible relationships out of the total number of 
relationships, and display a plus sign icon to show that some relationships are hidden. In the relationship 
table, the row that represents the hidden entity does not have a canvas icon.

Showing Direct and Indirect Relationships
In the Hierarchy view, direct and indirect relationships between records are expressed in hops. A hop is a 
relationship between records. A direct relationship is one hop, while an indirect relationship is more than one 
hop. For example, given records A, B, C, and D, the relationship A--D is one hop, A--B--D is two hops, and A--B--
C--D is three hops. You can change the number of hops that appears for a selected record.

1. In the canvas, click a record. 

The Actions menu appears.

2. Perform one of the following actions: 

• To view direct relationships, click Actions > Fetch > One Hop.

• To view direct and indirect relationships, click Actions > Fetch > Many Hops (#).

3. Optionally, you can change the number of hops that are shown by the Many Hops (#) option. 

a. Click Actions > Fetch > Preferences. 

b. In the Show Many Hops dialog box, set a value between 2 and 20. 

c. Click Execute. 

d. In the entity box, click the Actions menu. 

The Many Hops (#) menu item reflects the value that you set.

e. To apply the new number of hops to the canvas, click Fetch > Many Hops (#). 

Hiding a Record
If the graph is complex, you can simplify the graph by hiding records that are not meaningful to your 
investigation. When you hide a record, the record and the record relationships are hidden. You cannot hide 
the primary record or a record that functions as the anchor of the graph in the canvas.

1. In the canvas, click the record. 

The entity Actions menu appears.
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2. Click Actions > Hide > Hide Entity. 

In the canvas, the record and the record relationships are hidden.

Hiding Selected Records
Select one or more records to hide. You cannot hide the primary record or a record that functions as the 
anchor of the graph in the canvas.

1. In the canvas, select records by pressing the Ctrl key and clicking the records. 

Selected records are highlighted.

2. On the toolbar, click Actions > Hide Selected Entities. 

In the canvas, the selected records and the record relationships are hidden.

Hiding the Children of a Record
You can hide the children of a selected record. To qualify as a child record, the Direction type of the child 
record must be Child.

1. In the canvas, click the record. 

The entity Actions menu appears.

2. Click Actions > Hide > Hide Children. 

In the canvas, the children of the selected records are hidden.

Showing a Hidden Record
You can show a hidden record and the record relationships in the canvas.

1. In the canvas, click a record. 

2. If the relationship table is closed, click the arrow button to open the relationship table. 

The relationship table displays all records that are directly related to the selected record.

3. In the relationship table, select the hidden record that you want to show in the canvas. 

4. Right-click and click Add to Canvas. 

In the canvas, the record and the record relationships are displayed.

Showing All Hidden Record Relationships
When a entity box includes a plus sign icon in the lower left corner, the record has relationships to hidden 
record. You can show all the hidden records.

u To show all hidden records, click the Show icon in the entity box. 

The hidden records and the record relationships are shown on the canvas.

Navigating the Canvas
In the canvas, you can zoom in or out on the graph, move around the graph, or move quickly to another part of 
the graph.

• To zoom in or out on the graph, move the slider up or down.
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• To view hidden adjacent parts of the graph, use the direction arrows to move the hidden records into view.

• To navigate quickly through a large hierarchy graph, click the Navigation tab and click a different area of 
the graph. The area appears in the canvas.

Setting Canvas Options
You can set options that control the canvas.

• To increase the height of the canvas, click the Full Screen Mode icon. The application header and 
workspace bar are hidden.

• To show the canvas legend, click the Other tab. The legend appears on the left.

• To use simple graphics in the canvas when the number of records exceeds a threshold, click the Other 
tab, set a threshold value, and click Apply.

Investigating Related Records
As you investigate the relationships for the selected record, you might need to review the details for a related 
record or for a relationship.

You can view the following kinds of details:

• Record data

• Source systems and pending records

• System columns

• Relationship details

• Hierarchy

• History of changes

Viewing Record Data
If you need more information about a record, you can view the record data. For example, when the hierarchy 
contains similar records, you might want to confirm that you have the correct record before taking an action.

1. In the canvas, click a record. 

The entity Actions menu appears.

2. Click Actions > View > Details. 

3. In the Entity Details window, review the summary details. 

• If the details are sufficient to allow you to continue your work, click Close.

• If you need more information about the record, click More Details. The record opens in a new tab. 
You can review all the data about the record and, if necessary, edit the data.
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Viewing Source Systems and Pending Changes
You can view information about contributing source systems and pending changes for a selected record.

In the MDM Hub Store, the information is stored as cross-reference (XREF) records.

1. In the canvas, click a record. 

The entity Actions menu appears.

2. Click Actions > View > Cross References. 

3. In the Cross References dialog box, review records. 

• If the details are sufficient to allow you to continue your work, click Cancel.

• If you need to make changes, edit values, and then click Save.

Viewing System Columns
Data stewards might be interested in viewing the values in the system columns for a selected record. For 
example, you can view values for the Rowid Object column and Creator column.

1. In the canvas, click a record. 

The entity Actions menu appears.

2. Click Actions > View > System Columns. 

3. In the System Columns window, review the values. 

4. When you are finished, click Close. 

Viewing and Editing Relationship Details
If you need more information about a relationship, you can view details about the relationship, such as the 
relationship type.

1. In the canvas, click a relationship line. 

The relationship Actions menu appears.

2. Click Actions > View Relationship Details. 

3. In the Edit Relationship dialog box, review the details about the relationship. 

Option Description

Diagram Displays a diagram of the related records and the direction of the relationship.

Hierarchy The type of the business entity, such as organization or household.

Relationship Type The type of relationships that are possible between the records, such as employee or 
relative.

Rel Start Date The start date of the relationship. If the date occurs in the past, the relationship is active. If 
the date occurs in the future, the relationship will start on the specified date. If the field is 
empty, a start date was not set.
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Option Description

Rel End Date The end date of the relationship. If the date occurs in the past, the relationship has ended 
and is inactive. If the date occurs in the future, the relationship will end on the specified 
date. If the field is empty, the relationship is currently considered permanent.

Switch Entities You can switch the order of the record to change the direction of the relationship. The 
Switch Entities button is enabled for some Relationship Types.

Other fields Additional fields might appear for some Relationship Types.

4. Optionally, to change the relationship details, edit options and click Save. 

Viewing the Hierarchy for a Related Record
To view the relationships for a related record, you can open the related record in a Hierarchy view.

1. In the canvas, click a record. 

The entity Actions menu appears.

2. Click Actions > Open in New Tab. 

A tab opens and displays the hierarchy for the selected record.

Viewing a History of Relationship Changes
You can investigate how relationships have changed for the record that appears in the Hierarchy view.

1. On the toolbar, click Actions > Show History. 

2. In the Change History window, below the timeline, drag the timeline slider to the period that you want to 
investigate. You can expand the period by extending the edges of the timeline slider. 

A box highlights the selected time period.

3. Right-click the timeline and click Select a Date. 

4. In the Select a Date dialog box, select a date and time, and then click OK. 

An orange line marks the comparison date on the timeline. The left-side graph changes to reflect the 
graph as it looked on the selected date and time. The right-side graph continues to show the current 
version of the graph.

5. In the Relationships row of the timeline, look for change boxes. 

• If the row is empty, there are no changes.

• Otherwise, pause on a change box to see a change summary. To see details, right-click the box and 
click View Event Details. In the Event Details window, review changes, and then click Close.

6. After you finish your investigation, click Close. 

The Change History window closes.
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Changing Records and Relationships for a Record
In the Hierarchy view, you can add, edit, and delete related records and relationships for the selected records. 
If an effective date is set, the update is valid for the selected effective date.

Adding a Record to the Canvas
To create a relationship to a record that is not on the canvas, search for the record and add it to the canvas.

1. On the toolbar, click Add to Canvas. 

If you navigated to the Hierarchy view from the View list in an entity tab, the Smart Search dialog box 
opens. If you navigated to the Hierarchy view from the legacy Data tab, the Search dialog box opens.

2. If the Smart Search dialog box opens, perform the following steps: 

a. Optionally, select the type of business entity. 

b. Type the search term. 

c. Click Search. 

If the search process finds matches, the matching records appear in the search results.

d. Optionally, use the filters to narrow the search results. 

e. If the record appears in the search results, select the record and click Select. 

The record appears on the canvas.

3. If the legacy Search dialog box opens, perform the following steps: 

a. Enter the search criteria. 

b. Click Run Search. 

c. If the record appears in the search results, select the record and click Add to Canvas. 

The record appears on the canvas.

4. Next steps. Create a relationship between the added record and other records. 

Adding a Relationship
You can create a relationship between two unrelated records as long as a relationship type exists for the 
business entity types.

1. Ensure that both records are visible on the canvas. You might need to use the slider to zoom out the 
canvas. 

2. Drag and drop one entity box on top of the other entity box. 

3. In the Add Relationship dialog box, configure the following options: 

Option Description

Diagram Displays a diagram of the related records and the direction of the relationship.

Hierarchy The type of the business entity, such as organization or household.

Relationship Type The type of relationships that are possible between the records, such as employee or 
relative.
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Option Description

Rel Start Date The start date of the relationship. If the date occurs in the past, the relationship is active. If 
the date occurs in the future, the relationship will start on the specified date. If the field is 
empty, a start date was not set.

Rel End Date The end date of the relationship. If the date occurs in the past, the relationship has ended 
and is inactive. If the date occurs in the future, the relationship will end on the specified 
date. If the field is empty, the relationship is currently considered permanent.

Switch Entities You can switch the order of the record to change the direction of the relationship. The 
Switch Entities button is enabled for some Relationship Types.

Other fields Additional fields might appear for some Relationship Types.

4. Click Save. 

In the canvas, a relationship line appears between the two records. If the relationship is directional, the 
line includes an arrowhead to show the direction.

Editing a Record from the Hierarchy View
As you work with related records in the Hierarchy view, you might find that you need to edit data.

1. In the canvas, click a record. 

The entity Actions menu appears.

2. Click Actions > Edit > Edit Entity. 

A tab opens and displays the record in the Business Entity view.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

3. Edit data as required and save the changes. 

4. To return to the Hierarchy view, click the tab that contains the Hierarchy view. 

Finding Duplicate Records from the Hierarchy View
Data tab only. When you open the Hierarchy view from within the Data tab, you can select a record and 
search the master data for potential duplicates of the record.

1. In the canvas, click a record. 

The entity Actions menu appears.

2. Click Actions > Find > Duplicates. 

The application searches for similar records. A new tab contains the results of the search.

3. To return to the Hierarchy view, click the tab that contains the Hierarchy view. 
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Initiating a Merge from the Hierarchy View
While working with a graph, you might identify potential merge candidates among the related records. Or, as 
you investigate a related record, you might want to check for merge candidates. If you find merge candidates, 
you can initiate the merge from the Hierarchy view.

Merge candidates must be of the same type of business entity. For example, to merge customers, both 
records must be of type Customer.

1. If you see two records in the graph that you want to merge, initiate the merge. 

a. In the Hierarchy view, ensure that both records are visible on the canvas. You might need to use the 
slider to zoom out the canvas. 

Note: If your MDM administrator created a custom view for this purpose, the name of the view might 
be different.

b. Click one of the records. 

c. Press the Alt key while you drag the record onto the other record. An arrow icon indicates that you 
can merge the records. An X icon indicates that you cannot merge the records. 

A tab opens and displays the merge candidates. The view contains the destination record, the 
dragged record, and a merge preview.

2. Data tab only. Alternatively, you can search the master data for possible merge candidates for a selected 
record. 

a. In the canvas, click a record. 

The entity Actions menu appears.

b. Click Actions > Find > Merge Candidates. 

c. In the Search window, enter search criteria, and then click Run Search. 

d. In the search results, select candidates for the merge. 

e. Click OK. 

The view contains the record, the selected candidates, and a merge preview.

3. Review the merge preview, make changes as required, and initiate the merge. 

4. To return to the Hierarchy view, click the tab that contains the Hierarchy view. 

Deleting a Record from the Hierarchy View
As you work with related records in the Hierarchy view, you might find that you want to delete a record. When 
you delete a record, the record is removed from the view, and the record is marked for deletion in the MDM 
Hub Store. All the relationships between the deleted record and the selected record are also deleted. You 
cannot delete the record whose hierarchy you are viewing.

1. In the canvas, click the record that you want to delete. 

The entity Actions menu appears.

2. Click Actions > Edit > Detete Entity. 

The record and the record relationships are removed from the canvas and the relationship table. The 
record is marked for deletion in the MDM Hub Store.
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Deleting a Relationship
You can delete relationships between records. You can delete the relationship immediately, or you can cause 
the relationship to expire with an end date.

The End Date Relationship option is available under the following circumstances:

• The end date is empty.

• The relationship belongs to the current source system specified for the application.

• One cross-reference record persists in the database for the current effective period where the record does 
not intersect with effective periods from other source systems.

You delete relationships from the canvas.

1. In the canvas, click the relationship line. 

The relationship Actions menu appears.

2. Click Actions. 

3. Choose how you want to delete the relationship. 

• To delete the relationship and mark it with an end date, click End Date Relationship. When prompted 
for confirmation, click Yes. The end date is set to the date before the selected effective date.

• To delete the relationship from the selected effective period without adding an end date, click Delete 
Relationship.

• To delete the relationship for all effective dates, click Delete All Relationship Periods.

The relationship line disappears and the relationship is deleted from both affected records.

Sharing the Hierarchy View of a Record
You can share the Hierarchy view of a record either as a bookmark or as an image. For example, if you want 
to share a graph with a colleague who has access to Data Director, share a bookmark. If you want to 
communicate with other colleagues, you can create an image of the graph and insert in a document or other 
text-based communication tool.

If you want to communicate with other colleagues, you can create an image of the graph and insert in a 
document or other text-based communication tool.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.

Sharing a Bookmark to the Hierarchy View
Data tab only. If you want to share the Hierarchy view of a record with other Data Director users, you can 
send the users a bookmark URL. The user needs to log in to Data Director.

The bookmark is a fully qualified URL. You can copy the URL to any text-based communication tool, such as 
email, text message, instant message, or document.

1. Open a record in the Hierarchy view. 

2. On the toolbar, click the Actions > Show Bookmark. 

3. In the Bookmark URL window, select the entire URL, right-click, and click Copy. 

4. Click Close. 
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5. Open the target text-based communication tool, and paste the URL. 

Saving an Image of the Graph
If you want to share a graph with colleagues, you can export it in JPEG format. You can then use the image in 
a report or in an email to interested colleagues.

The export process saves images to the browser's default directory for downloads.

1. With the record open, from the View list, select Hierarchy. 

Note: The record views that appear in the View list depend on the Data Director configuration and your 
user role privileges.

2. If you want to capture a portion of the graph, display the portion of the graph in the canvas. 

3. On the toolbar, click Actions > Export to JPG. 

4. In the Export Graph dialog box, choose how much of the graph to capture. 

• To capture the visible portion of the graph, select View Port.

• To capture the entire graph, select Fit. Optionally, you can change the width and height of the image 
by using the sliders.

5. Click Export. 

The export process creates the image and saves the image to the downloads directory.

Troubleshooting the Hierarchy View

The Hierarchy View does not load and an icon indicates that you need the Adobe Flash Player.

When you use Data Director in Google Chrome, the Hierarchy Manager in the Hierarchy view does not load 
because Flash is disabled by default.

To enable Flash, from the Home page in Data Director, click the Information icon in the address bar. In the 
Flash menu, select Allow. Reload the page to update your settings, and then try using the Hierarchy view.

Note: If your MDM administrator created a custom view for this purpose, the name of the view might be 
different.
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Part IV: Workflows and Reviews
This part contains the following chapters:

• Participating in Review Processes, 140

• Review Processes Reference, 155
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Participating in Review Processes
This chapter includes the following topics:

• Participating in Review Processes Overview, 140

• Task Manager, 141

• Claiming Tasks, 145

• Resolving Tasks, 146

• Organizing Work on Tasks, 151

Participating in Review Processes Overview
When a business user changes data in Data Director, the change might trigger a review process. A review 
process is an automated business process workflow that notifies business managers and data stewards 
when changes are ready for their review. 

Note: If the Task Manager is not enabled in your application, your user role might not have permission to 
participate in a review process. In some cases, the review process might not be required in your environment.

The type of review process depends on how the MDM administrator configured your application and whether 
the default review processes are in use. By default, there are different review processes for edits, merges, 
and unmerges.

Example of a Review Process for Edits
The staff in the Finance department use Data Director to keep supplier banking information up to date. A 
supplier representative contacts a Finance staff member and requests a change to the supplier's banking 
information.

In the Finance department, each Data Director user credential includes one of the following user roles:

• User. Staff members have permission to add and change records, but the changes must go through a 
review process before the master data is updated.

• Manager. A manager is a type of business user with additional permissions. A manager reviews changes, 
but cannot approve changes. If a manager agrees with a change, he escalates it to a senior manager.

• SrManger. A senior manager is a type of manger with additional permissions. A senior manager reviews 
changes and has the authority to approve them.
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A staff member edits the supplier data as requested by the supplier representative. The following steps 
describe what happens during the review process.

1. A staff member changes the banking information of the supplier and saves the change. In the MDM Hub 
Store, the state of the supplier records changes from active to pending. The proposed edit is saved in a 
cross-reference record. The save action initiates the review process.

2. An instance of a review process starts and begins executing activities.

3. When the review process reaches the first people activity, it generates a task notification for managers. 
For example, in the default review process, the first people activity is Review No Approve. All managers 
with the role of Manager receive a task notification in the task inbox with the task type of Review No 
Approve.

4. A manager claims the task. The task is assigned to the manager and the task disappears from the task 
inboxes of the other managers.

5. The manager opens the supplier record, reviews the edit, and agrees with the edit. The manager resolves 
the task by clicking Escalate.

6. The review process marks the task as complete, and follows the Escalate flow to the next activity.

7. When the review process reaches the next people activity, the process generates a task notification for 
senior managers. For example, in the default review process, the second people activity is Final Review. 
All senior managers with the role of SrManager receive a task notification in the task inbox with the task 
type of Final Review.

8. A senior manager claims the task. The task is assigned to the senior manager and the task disappears 
from the task inboxes of the other senior managers.

9. The senior manager opens the supplier record, reviews the edit, and agrees with the edit. The senior 
manager resolves the task by clicking Approve.

10. The review process marks the task as complete, and follows the Approve flow. The review process 
notifies the MDM Hub that the change is approved, and then the review process ends. The MDM Hub 
changes the banking information in the supplier banking record. The supplier records change to the 
active state.

Task Manager
Use the Task Manager to organize, claim, and resolve tasks that are generated by review processes.

To go to the Task Manager, in the navigation bar, click Task Manager. Alternatively, you can click the title of a 
task from the task inbox in the Home page. In this case, the Task Manager displays the selected task and its 
associated record. 

Task Manager       141



The following image shows the Task Manager with a task selected: 

1. Task panel
2. Review panel

Task Panel
The task panel lists the details of the tasks. You can use the predefined filters to select the type of tasks that 
you want to view in the task panel.

When you open the Task Manager from the navigation bar, the task panel displays all the tasks. When you 
open a task from the task inbox of the Home page, the task panel displays only the details of the selected 
task. 
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The following image shows the task panel of the Task Manager:

1. Quick filters
2. Search

The following table lists the user interface elements of the task panel :

User Interface 
Element

Description

Quick filters Filters the tasks based on the predefined filter that you select.
Use one of the following filters:
- My Open Tasks. Shows your open tasks.
- My Closed Tasks. Shows the tasks that you closed.
- All Tasks. Shows all the closed, claimed, and unclaimed tasks that are assigned to your user 

group.
- All Unclaimed Tasks. Shows all the unclaimed tasks that are assigned to your user group. 
- All Closed Tasks. Shows all the tasks that the users in your user group closed.
- All Claimed Tasks . Shows all the tasks that the users in your user group claimed.

Search Searches the displayed tasks for the specified text. 

The following table lists the details that the task panel can display :

Task Detail Description

Task Title A link that displays a short description of the review task. To review the record and take action on 
the task, click the task title. The task opens in the Task Manager and displays the associated 
record in the review panel. If your role permits it, you can edit the record from this view before 
taking action on the task. 

Type Name of a people activity within the process. 
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Task Detail Description

Priority Priority of the task. The task priority can be Low, Normal, or High. When generating tasks, the 
review process assigns the same priority to all tasks of the same type. 

Task Status and 
Due Date

Status of the task and the date the task is due.
Status of the task can be Open or Closed. When the task status is Open, you can view the record 
associated with the task.
The review process calculates a default due date based on the task creation date plus a 
predefined time period.
The due date of each task is prefixed with one of the following colored dots:
- Green. Indicates that the task is not overdue.
- Red. Indicates that the task is overdue.
- Amber. Indicates that the task will be overdue in the next 24 hours.

Owner Name of the signed-in user. 

ID Instance ID of the review process that generated the task. 

Submitted Date 
and Creator

Name of the user who created the task, and the date on which the user created the task. 

Note: If you and your colleagues require different task details, contact your MDM administrator. The MDM 
administrator can update the application to display the desired details.

Review Panel
Use the review panel to review the changed record, the comments added to the task, and the workflow 
diagram. The content of the review panel differs based on the type of change that was made to the record. 

The following image shows an edited record in the review panel: 
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The following table describes the elements in the review panel: 

Element Description

Record Details Displays the details of the record associated with the task. 

Comments Displays a list of comments added to the task. 

Workflow Diagram Displays a graphical representation of the process flow associated with the task. 
You can view the workflow diagram only if you have the ActiveVOS abAdmin role assigned. 

Task Details Displays the task details in edit mode. 

Actions Actions that you can perform on the task. The possible actions depend on the task definitions in 
the review process. Sample actions can be Approve, Reject, and Disclaim.

More Actions Additional actions that you can perform on the task. 

Edit Opens the record in edit mode. 

Open Opens the record in a separate tab. 

Claiming Tasks
Multiple users can share the same reviewer role. To work on a task, you must claim the task. This ensures 
that other users cannot work on the task while you work on it. Before you can claim a task, check for 
comments or attachments. 

1. Click Task Manager. 

The task panel contains a list of tasks.

2. In the task panel, select All Unclaimed Tasks. 

The task panel lists all the unclaimed tasks of your user group.

3. Select a task that you want to claim. 

The record appears in the review panel.

4. Optionally, review the comments and attachments. 

a. Click the Comments tab, and then review the comments. 

b. Click Task Details. 

c. Download attachments in the File Attachments section. 

d. Click Cancel. 

5. To claim the task, click Claim. 

The task panel is updated, and your user name appears in the Owner field of the task.
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Resolving Tasks
You resolve a task by reviewing the new or changed record and then taking an action. The possible actions 
depend on the task definitions in the review process. 

Reviewing Edited Records
When you open a task to review an edited record, the fields that contain edited values are marked. 

In the MDM Hub Store, the proposed edits are contained in a cross-reference record that is set to the pending 
state. 

1. In the task inbox of the Home page, click a task that is a request to review an edited record. 

The record opens in the review panel of the Task Manager.

Note: If you open an unassigned task, be sure to claim it before you start work.

2. Optionally, review the comments and attachments. 

a. Click the Comments tab, and then review the comments. 

b. Click Task Details. 

c. Download attachments in the File Attachments section. 

d. Click Cancel. 

3. Look for highlighted fields and decide if the edits are valid. 

4. If you see a typographical error or an incorrect value for which you know the correct value, click Edit, and 
edit the field. 

Note: The next step depends on whether you have enough information to resolve the task or if you think 
someone else should assess it.

5. To resolve the task, click an appropriate action button, or click More Actions and select one of the 
following actions: 

Action Description

Approve If you agree with the edits and the task type permits you to approve changes, click Approve. The 
ActiveVOS® Server marks the related Final Review people activity as completed and performs the next 
activity in the process. 

Escalate If you agree with the edits, but the task type does not permit approval at this point in the workflow, 
click Escalate. The ActiveVOS Server marks the related Review No Approve people activity as 
completed and performs the next activity in the process.

Reject If you disagree with the one or more edits, click Reject and type an explanation in the Comment box. 
The ActiveVOS Server notifies the person who edited the record. 
Note: If a source system updates the rejected record, the record goes through the approval process 
again.

<Other> If you see other options in the menu, then your organization uses a custom business process. If the 
purpose of the option is not clear and your role permits access to the ActiveVOS console, you can 
open the process to understand the workflow. Otherwise, contact the person who created the 
business process.

The task is closed.
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6. To change the ownership of the task without resolving the task, click an appropriate action button, or 
click More Actions and select one of the following actions: 

Action Description

Reassign To ask another person to review the proposed changes, click Reassign, select the user, and type an 
explanation in the Comment box. The task is reassigned to the selected person.
Note: If this option is not available, click Task Details and select the user from the Assignee list.

Disclaim To return the task to the pool of unassigned tasks, click Disclaim and type an explanation in the 
Comment box. Someone with the same role needs to take action on the task.

The task remains open, but is no longer assigned to you.

7. If prompted, add comments or attachments to provide additional information about the task. 

Note: Whether you are prompted and required to add a comment or attachment depends on the Data 
Director configuration. A red line appears to indicate required fields.

Related Topics:
• “Claiming Tasks” on page 145

• “Task Manager” on page 141

Reviewing New Records
When you open a task to review a new record, all field values in the record need to be validated. If you are one 
reviewer in a progressive multiple step review process, validate only the fields that you are responsible for 
validating.

In the MDM Hub Store, the parent record and child records are in the pending state until the new record is 
approved. 

1. In the task inbox of the Home page, click a task that is a request to review a new record. 

The record opens in the review panel of the Task Manager.

Note: If you open an unassigned task, be sure to claim it before you start work.

2. Optionally, review the comments and attachments. 

a. Click the Comments tab, and then review the comments. 

b. Click Task Details. 

c. Download attachments in the File Attachments section. 

d. Click Cancel. 

3. Determine if the values in the record meet your business requirements. 

Note: The next step depends on whether you have enough information to resolve the task or you think 
someone else should assess it.
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4. To resolve the task, click an appropriate action button, or click More Actions and select one of the 
following actions: 

Action Description

Approve If you think the record is acceptable, and the task type permits you to approve it, click Approve. The 
ActiveVOS Server marks the related Final Review people activity as completed and performs the next 
activity in the process.

Escalate If you think the record is acceptable, but the task type does not permit approval at this point in the 
workflow, click Escalate. The ActiveVOS Server marks the related Review No Approve people activity 
as completed and performs the next activity in the process.

Reject If you disagree with the one or more values, click Reject and type an explanation in the Comment box. 
The ActiveVOS Server notifies the person who added the record.
Note: If a source system updates the rejected record, the record goes through the approval process 
again.

<Other> If you see other options in the menu, then your organization uses a custom business process. If the 
purpose of the option is not clear and your role permits access to the ActiveVOS console, you can 
open the process to understand the workflow. Otherwise, contact the person who created the 
business process.

The task is closed.

5. To change the ownership of the task without resolving the task, click an appropriate action button, or 
click More Actions and select one of the following actions: 

Action Description

Reassign To ask another person to review the proposed changes, click Reassign, select the user, and type an 
explanation in the Comment box. The task is reassigned to the selected person.
Note: If this option is not available, click Task Details and select the user from the Assignee list.

Disclaim To return the task to the pool of unassigned tasks, click Disclaim and type an explanation in the 
Comment box. Someone with the same role needs to take action on the task.

The task remains open, but is no longer assigned to you.

6. If prompted, add comments or attachments to provide additional information about the task. 

Note: Whether you are prompted and required to add a comment or attachment depends on the Data 
Director configuration. A red line appears to indicate required fields.

Related Topics:
• “Claiming Tasks” on page 145

• “Task Manager” on page 141

148       Chapter 19: Participating in Review Processes



Reviewing Merge Tasks
When you open a task to review a merge task, the primary record appears beside the records that are 
selected for the merge.

1. In the task inbox of the Home page, click a task that is a request to review a merge proposal. 

The record opens in the review panel of the Task Manager.

Note: If you open an unassigned task, be sure to claim it before you start work.

2. Optionally, review the comments and attachments. 

a. Click the Comments tab, and then review the comments. 

b. Click Task Details. 

c. Download attachments in the File Attachments section. 

d. Click Cancel. 

3. Review the merge preview and determine if the merge is valid. The fields that appear in the merge 
preview are highlighted. 

Note: The next step depends on whether you have enough information to resolve the task or if you think 
someone else should assess it.

4. If required, make changes to the proposed merge task. 

a. To change the proposed merge task, perform any of the following tasks: 

Task Procedure

Add records that you want 
to merge.

Click Add Candidate. You can search for records and add the records to the 
view.

Remove records that you do 
not want to merge.

From the Actions menu, select an option:
- Remove Candidate. Removes a manually added record from the review 

panel.
- Not a Match. Removes a system matched record from the review panel 

and dissociates it as a match of the target record.

Finalize the best version of 
the truth.

Select the field with the correct value or enter the correct value in the Merge 
Preview column.

b. Click Update. 

The merge task is updated.

5. To resolve the task, select one of the following actions: 

Action Description

Merge If you agree with the merge proposal and the task type permits you to approve changes, click Merge. 
The ActiveVOS Server marks the related Merge people activity as completed and performs the next 
activity in the process.

Cancel If you disagree with the merge proposal, click Cancel and type an explanation in the Comment box. The 
ActiveVOS Server notifies the person who proposed the merge.
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Action Description

<Other> If you see other options in the menu, then your organization uses a custom business process. If the 
purpose of the option is not clear and your role permits access to the ActiveVOS console, you can 
open the process to understand the workflow. Otherwise, contact the person who created the business 
process.

The task is closed.

6. To change the ownership of the task without resolving the task, click an appropriate action button, or 
click More Actions and select one of the following actions: 

Action Description

Reassign To ask another person to review the proposed changes, click Reassign, select the user, and type an 
explanation in the Comment box. The task is reassigned to the selected person.
Note: If this option is not available, click Task Details and select the user from the Assignee list.

Disclaim To return the task to the pool of unassigned tasks, click Disclaim and type an explanation in the 
Comment box. Someone with the same role needs to take action on the task.

The task remains open, but is no longer assigned to you.

7. If prompted, add comments or attachments to provide additional information about the task. 

Note: Whether you are prompted and required to add a comment or attachment depends on the Data 
Director configuration. A red line appears to indicate required fields.

Related Topics:
• “Claiming Tasks” on page 145

• “Task Manager” on page 141

• “Resolving Duplicate Records” on page 60

Reviewing Unmerge Tasks
When you open a task to review an unmerge tasks, a preview shows the result of the unmerge.

1. In the task inbox of the Home page, click a task that is a request to review an unmerge proposal. 

The unmerge preview for the record appears in the review panel of the Task Manager.

Note: If you open an unassigned task, be sure to claim it before you start work.

2. Optionally, review the comments and attachments. 

a. Click the Comments tab, and then review the comments. 

b. Click Task Details. 

c. Download attachments in the File Attachments section. 

d. Click Cancel. 

3. Review the unmerge preview and determine if the unmerge is warranted. The fields that appear in the 
preview are highlighted. 

Note: The next step depends on whether you have enough information to resolve the task or if you think 
someone else should assess it.
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4. To resolve the task, click an appropriate action button, or click More Actions and select one of the 
following actions: 

Action Description

Unmerge If you agree with the unmerge proposal and the task type permits you to approve changes, click 
Unmerge. The ActiveVOS Server marks the related Unmerge people activity as completed and 
performs the next activity in the process.

Cancel If you disagree with the unmerge proposal, click Cancel and type an explanation in the Comment box. 
The ActiveVOS Server notifies the person who proposed the unmerge.

<Other> If you see other options in the menu, then your organization uses a custom business process. If the 
purpose of the option is not clear and your role permits access to the ActiveVOS console, you can 
open the process to understand the workflow. Otherwise, contact the person who created the 
business process.

The task is closed.

5. To change the ownership of the task without resolving the task, click an appropriate action button, or 
click More Actions and select one of the following actions: 

Action Description

Reassign To ask another person to review the proposed changes, click Reassign, select the user, and type an 
explanation in the Comment box. The task is reassigned to the selected person.
Note: If this option is not available, click Task Details and select the user from the Assignee list.

Disclaim To return the task to the pool of unassigned tasks, click Disclaim and type an explanation in the 
Comment box. Someone with the same role needs to take action on the task.

The task remains open, but is no longer assigned to you.

6. If prompted, add comments or attachments to provide additional information about the task. 

Note: Whether you are prompted and required to add a comment or attachment depends on the Data 
Director configuration. A red line appears to indicate required fields.

Related Topics:
• “Claiming Tasks” on page 145

• “Task Manager” on page 141

Organizing Work on Tasks
When you have a long list of tasks, you can organize tasks by sorting and filtering the list, changing task 
properties, and assigning tasks to others. 

For example, you might want to work on the tasks that have the highest priority or on the tasks that are due 
soonest. After you filter the list of tasks, you might find tasks that need a higher priority or that can be 
postponed. You can edit the task properties to better reflect the urgency within the business to resolve tasks. 
And, if you have the authority to assign tasks to managers, you can assign the task to a manager from the 
task properties. 
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Related Topics:
• “Task Manager” on page 141

Editing Due Date, Priority, and Other Task Properties
As you work with tasks, you might decide that some task properties need to be changed. For example, if 
changes are made to the record of an important client, you might want to increase the priority of the review 
task. Or, if you plan to be away and want to finish a set of tasks before you leave, you can change the due 
dates for the tasks to represent a date before your planned absence.

1. In the navigation bar, click Task Manager. 

2. In the task panel, select the task you want to edit. 

3. In the review panel, click Task Details. 

The following image shows the Task Details dialog box:

4. Edit one or more of the following fields to change the task properties: 

Field Description

Task Title Enter a title that is more meaningful to you. A good title includes at least the name of the 
record and the change that initiated the review.

Priority Select a priority that reflects the urgency within the business to resolve this change.
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Field Description

Due Date Select a due date that reflects the urgency within the business to resolve the change.

Assignee Reassign this task to someone else.

File Attachment Attach files to provide additional information about the task. Attachments appear in the 
Task Details dialog box.
Note: The File Attachment field is available only if the task supports attachments.

Add Comment Add comments to explain edits to the task properties and to track questions and answers 
about the task. Comments appear in the Comments tab.

Assign Back to 
Pool

Return the task to the pool of unassigned tasks so that other users can claim the task.
Note: The Assign Back to Pool button is available only if the task belongs to another user.

5. Click Save. 

Assigning Your Tasks to Other Users
If the Assignee list is enabled in the Edit Task dialog box, you can reassign tasks.

Note: If you want to enable reassignments, contact your MDM administrator. The MDM administrator must 
implement a business process management (BPM) adapter that supports reassignments.

1. In the navigation bar, click Task Manager. 

The task panel contains a list of your assigned tasks and all unassigned tasks.

2. In the task panel, select My Open Tasks. 

The task panel displays all your open tasks.

3. Select the task that you want to assign to another user. 

The record appears in the review panel.

4. To provide additional information about the task, click Task Details, and then add a comment or a file 
attachment. 

Note: If you do not have the options for comments or attachments, contact your MDM administrator to 
request that they enable comments and attachments.

5. To assign the task, select the user from the Assignee list. 

6. Click Save. 

Assigning Tasks Back to the Pool
When a user in your user group is not available, you can send the user's tasks to the pool of unassigned tasks 
so that other users can claim them. The option to assign the tasks back to the pool is available only if the 
task belongs to another user.

1. Click Task Manager. 

2. In the task panel, select the task that you want to send to the pool. 

3. In the review panel, click Task Details. 

4. Click Assign Back to Pool. 
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Disclaiming Tasks
If you claim or are assigned a task that you feel would be better handled by someone else, you can disclaim 
the task. Disclaimed tasks return to the pool of unassigned tasks. 

1. Click Task Manager. 

2. In the task panel, select an assigned task. 

The record appears in the review panel

3. In the review panel, click More Actions > Disclaim. 

4. If prompted, add comments or attachments to provide additional information about the task. 

Note: Whether you are prompted and required to add a comment or attachment depends on the Data 
Director configuration. A red line appears to indicate required fields.
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Review Processes Reference
This chapter includes the following topics:

• Review Processes Reference Overview, 155

• Update With Approval Workflow, 156

• One Step Approval Workflow, 156

• Two Step Approval Workflow, 157

• Merge Workflow, 157

• Unmerge Workflow, 157

Review Processes Reference Overview
A review process is an automated business process. When a user adds, edits, merges, or unmerges records, 
the action can initiate a review process. A review process ensures that business managers or data stewards 
review and ultimately approve the data before it becomes master data. 

Your user role determines whether a change to the master data triggers a review. For example, if your user 
role permits you to add or edit data but not approve changes, then when you save an edit or merge records, 
the action triggers a review process.

Multidomain MDM ships with the following default review processes:

• Update with Approval Workflow

• One Step Approval Workflow

• Two Step Approval Workflow

• Merge Workflow

• Unmerge Workflow

Note: If you see different process names or task types in your task inbox, someone in your organization has 
changed the review processes or created custom processes.

The following sections describe the purpose of each review process and identify the people activities within 
each process. To view an entire process, open the process in the ActiveVOS Console.
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Update With Approval Workflow
In the Update With Approval Workflow process, a data steward reviews the changed entity before either 
canceling the update or sending the update through a two-step approval process.

The following table summarizes the people activities within the process:

People Activity Role Assigned Description

Update DataSteward A data steward reviews the update and either cancels the update or sends it 
through a two-step approval process.

Review No Approve Manager A manager reviews an update and either rejects it or sends it on for Final 
Review.

Final Review SrManager A senior manager reviews the update and either rejects it or approves it.

Notification DataSteward If approved, the data steward receives a notification that the update is 
approved.

One Step Approval Workflow
The One Step Approval Workflow process requires one senior manager to review and then approve or reject 
the update.

The following table summarizes the people activities within the process:

People Activity Role Assigned Description

Final Review SrManager A senior manager reviews an update and either approves it or rejects it.

Notification DataSteward If the update is approved, the record is flagged for promotion and the data 
steward is notified.

Update DataSteward If the update is rejected, the data steward is notified and can cancel the update.
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Two Step Approval Workflow
The Two Step Approval Workflow process requires at least two business managers to participate in the 
review and approval process.

The following table summarizes the people activities within the process:

People Activity Role Assigned Description

Review No Approve Manager A manager reviews an update and either rejects it or escalates it to Final 
Review.

Final Review SrManager A senior manager reviews the update and either approves it or rejects it.

Notification DataSteward If approved, the record is flagged for promotion and the data steward is 
notified.

Update DataSteward If rejected, the data steward is notified and can cancel the update.

Merge Workflow
When you select merge candidates, you can create a task that initiates the Merge Workflow process in the 
ActiveVOS Server.

The following table describes the people activity within the process:

People Activity Role Assigned Description

Merge DataSteward A data steward reviews the candidates and either merges the records or cancels 
the action.

Unmerge Workflow
When you unmerge records, you can create a task that initiates the Unmerge Workflow process in the 
ActiveVOS Server.

The following table describes the people activity within the process:

People Activity Role Assigned Description

Unmerge DataSteward A data steward reviews the candidate and either unmerges the records or 
cancels the action.
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