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Preface
Data Transformation Agent for BizTalk is written for developers who want to transform structured or 
unstructured data in the Microsoft BizTalk Server environment. The book explains how to install, configure, 
and use the Data Transformation integration features that operate within BizTalk.

Informatica Resources

Informatica My Support Portal
As an Informatica customer, you can access the Informatica My Support Portal at 
http://mysupport.informatica.com.

The site contains product information, user group information, newsletters, access to the Informatica 
customer support case management system (ATLAS), the Informatica How-To Library, the Informatica 
Knowledge Base, Informatica Product Documentation, and access to the Informatica user community.

Informatica Documentation
The Informatica Documentation team takes every effort to create accurate, usable documentation. If you 
have questions, comments, or ideas about this documentation, contact the Informatica Documentation team 
through email at infa_documentation@informatica.com. We will use your feedback to improve our 
documentation. Let us know if we can contact you regarding your comments.

The Documentation team updates documentation as needed. To get the latest documentation for your 
product, navigate to Product Documentation from http://mysupport.informatica.com.

Informatica Web Site
You can access the Informatica corporate web site at http://www.informatica.com. The site contains 
information about Informatica, its background, upcoming events, and sales offices. You will also find product 
and partner information. The services area of the site includes important information about technical 
support, training and education, and implementation services.

Informatica How-To Library
As an Informatica customer, you can access the Informatica How-To Library at 
http://mysupport.informatica.com. The How-To Library is a collection of resources to help you learn more 
about Informatica products and features. It includes articles and interactive demonstrations that provide 
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solutions to common problems, compare features and behaviors, and guide you through performing specific 
real-world tasks.

Informatica Knowledge Base
As an Informatica customer, you can access the Informatica Knowledge Base at 
http://mysupport.informatica.com. Use the Knowledge Base to search for documented solutions to known 
technical issues about Informatica products. You can also find answers to frequently asked questions, 
technical white papers, and technical tips. If you have questions, comments, or ideas about the Knowledge 
Base, contact the Informatica Knowledge Base team through email at KB_Feedback@informatica.com.

Informatica Support YouTube Channel
You can access the Informatica Support YouTube channel at http://www.youtube.com/user/INFASupport. 
The Informatica Support YouTube channel includes videos about solutions that guide you through performing 
specific tasks. If you have questions, comments, or ideas about the Informatica Support YouTube channel, 
contact the Support YouTube team through email at supportvideos@informatica.com or send a tweet to 
@INFASupport.

Informatica Marketplace
The Informatica Marketplace is a forum where developers and partners can share solutions that augment, 
extend, or enhance data integration implementations. By leveraging any of the hundreds of solutions 
available on the Marketplace, you can improve your productivity and speed up time to implementation on 
your projects. You can access Informatica Marketplace at http://www.informaticamarketplace.com.

Informatica Velocity
You can access Informatica Velocity at http://mysupport.informatica.com. Developed from the real-world 
experience of hundreds of data management projects, Informatica Velocity represents the collective 
knowledge of our consultants who have worked with organizations from around the world to plan, develop, 
deploy, and maintain successful data management solutions. If you have questions, comments, or ideas 
about Informatica Velocity, contact Informatica Professional Services at ips@informatica.com.

Informatica Global Customer Support
You can contact a Customer Support Center by telephone or through the Online Support.

Online Support requires a user name and password. You can request a user name and password at 
http://mysupport.informatica.com.

The telephone numbers for Informatica Global Customer Support are available from the Informatica web site 
at http://www.informatica.com/us/services-and-training/support-services/global-support-centers/.
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C h a p t e r  1

Integrating Data Transformation 
with BizTalk

This chapter includes the following topics:

• Integration Overview, 8

• Installation, 10

Integration Overview
Data Transformation can enhance the capabilities of Microsoft BizTalk Server by supporting the conversion 
of many document formats that BizTalk does not natively support. Some examples of the formats that Data 
Transformation can interface with BizTalk are Microsoft Word documents, HL7 messages, and COBOL data 
structures.

Data Transformation can work with BizTalk either in the parsing or serialization direction. In BizTalk 
terminology, parsing is called disassembly and serialization is called assembly.

Data Transformation Services
The integration features described in this document allow you to run Data Transformation services in BizTalk. 
A service has one of the following types:

• Parser. Converts any format to XML.

• Serializer. Converts XML to any format.

• Mapper. Converts XML to XML.

• Transformer. Modifies the data in any format.

• Streamer. Splits large inputs into portions for processing by the other transformation types.

For example, you can use a parser service in a BizTalk pipeline to transform binary or text inputs to XML. The 
inputs can contain structured, semi-structured, or unstructured data.

Similarly, you can use a serializer service in a BizTalk pipeline to transform XML to other data formats. By 
combining a parser and a serializer, you can use Data Transformation to transform any data format to any 
other data format, via XML.

For more information about creating and deploying services, see the Data Transformation Getting Started 
Guide and the Data Transformation User Guide.
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About BizTalk
Microsoft BizTalk Server is an integration system that moves data between business applications. The 
following table describes the levels at which BizTalk can operate:

Level Description

BizTalk messaging BizTalk uses a pipeline messaging structure to receive an input message, transform the 
message to another format, and send the message to a destination.
You can think of BizTalk messaging as a way to transmit messages from point A to point B, 
optionally transforming the data on the way. The message movement is linear, without branch 
points or conditional logic control.

BizTalk 
orchestration

Orchestration allows you to define a message flow. The flow can contain multiple steps and 
conditional logic that determine how to process a message.
Orchestration allows an application to have multiple inputs and outputs, with any flow of data 
between them.

How Data Transformation Enhances BizTalk
Internally, BizTalk works with messages in XML format. The role of Data Transformation is to transform 
external data formats to and from XML.

Data Transformation provides an integration component, called the Data Transformation Agent for BizTalk, 
that you can insert in a BizTalk messaging pipeline. The Agent runs a Data Transformation service that 
performs the transformation.

If you insert the Agent on the input end of a pipeline, it must run a Data Transformation service whose output 
is XML. This is typically a parsing service.

If you insert the Agent on the output end of a pipeline, it must run a Data Transformation service whose input 
is XML. This is typically a serialization service.

Optionally, you can insert Data Transformation Agents on both the input and output ends. BizTalk runs the 
two Agents sequentially on the data. The result is that Data Transformation converts an external format, via 
XML, to another external format.

You can incorporate a pipeline that uses the Data Transformation Agent in a BizTalk orchestration flow. In 
this way, you can use Data Transformation in orchestration applications.

Integration Approach
The approach for integrating Data Transformation with BizTalk is as follows:

1. Use Informatica Developer to configure a transformation.

2. In Informatica Developer, deploy the transformation as a service that can run in Data Transformation 
Engine.

3. Create a BizTalk project that uses the Data Transformation Agent.

4. Configure the Agent to run the Data Transformation service.

For more information about steps 3 and 4, see Chapter 2, “Using Data Transformation with BizTalk” on 
page 11.
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Installation
This section explains how to install the Data Transformation Agent for BizTalk on a Microsoft Windows 
platform.

System Requirements
You can install the Data Transformation Agent for BizTalk on a system meeting the following requirements:

• A Microsoft Windows platform supporting Data Transformation. For more information about the Windows 
platform requirements, see the Data Transformation Administrator Guide.

• Microsoft BizTalk Server, version 2004 or 2006, installed on the same computer.

• If you install Informatica Developer on the same computer as BizTalk Server 2004, you must install the 
Microsoft SP2 service pack for BizTalk Server.

Installing
To install the Data Transformation Agent for BizTalk:

1. Confirm that BizTalk is installed on the system and operates properly.

2. If BizTalk is currently running, stop it.

3. Run the Data Transformation setup file, and follow the on-screen instructions.

You must install at least the following components:

• Data Transformation Engine, which is required for the Agent operation

• Data Transformation Agent for BizTalk

On the Service Repository Path Selection page, be sure to enter a real drive and directory path. Data 
Transformation Agent for BizTalk does not support a virtual repository location, such as one that is 
defined in the subst command.

Uninstalling
To uninstall the Data Transformation Agent for BizTalk:

1. Open the Windows Control Panel and double-click Add and Remove Programs. 

2. Remove the Data Transformation software.

Upgrading to a New Version
To upgrade to a new version of the agent:

1. If you are upgrading from version 8.5 or earlier of the agent, uninstall the existing version by using the 
Control Panel > Add or Remove Programs option.

2. Install the new version.
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C h a p t e r  2

Using Data Transformation with 
BizTalk

This chapter includes the following topics:

• Usage Overview, 11

• Creating a Data Transformation Service, 12

• Building a BizTalk Server Pipeline, 12

• Deploying the BizTalk Project, 14

• Using the Pipeline in a BizTalk Scenario, 15

• Running the BizTalk Application, 16

• Troubleshooting, 16

• Example: Creating a File-Transfer Scenario that Uses Data Transformation, 17

Usage Overview
Data Transformation integrates into Microsoft BizTalk Server as a custom disassembler, which converts 
source documents to XML, or as a custom assembler, which converts XML to an output format.

Specifically, you can configure a BizTalk scenario that runs a Data Transformation service on the message. 
The scenario receives a message, transforms it, and transmits it to a destination.

BizTalk can run a scenario independently, or it can incorporate a scenario in an orchestration application.

The following sections provide detailed instructions for configuring a scenario that uses Data 
Transformation.

Note: Depending on your BizTalk version, the appearance of the BizTalk windows might differ slightly from 
the illustrations in this chapter.

Background: BizTalk Objects
In this chapter, you will work with several BizTalk objects.

A BizTalk scenario has a receive port and a send port, which are the input and output ends, respectively.

To use Data Transformation as a custom disassembler (parser), you will build a receive pipeline. You will 
associate the pipeline with the receive port. More specifically, you will associate the pipeline with a receive 
location of a scenario.
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To use Data Transformation as a custom assembler (serializer), you will build a send pipeline. You will 
associate the pipeline with the send port of a scenario.

You can also associate receive and send pipelines with orchestration ports.

Steps for Using
To create and use a custom disassembler or assembler, you can perform the following steps:

1. Use Informatica Developer to create a parser, serializer, mapper, or transformer, and deploy it as a Data 
Transformation service.

2. In Microsoft Visual Studio 2005, create a BizTalk project, and configure a receive pipeline or a send 
pipeline that uses the Data Transformation service.

3. Deploy the BizTalk project.

4. In a BizTalk scenario, assign the pipeline to a send port, receive location, or orchestration port.

5. Run and test the BizTalk application.

The following sections provide detailed instructions for the steps. At the end of the chapter, we provide a 
step-by-step example that illustrates how to perform the procedures in a file-transfer scenario.

Creating a Data Transformation Service
In Informatica Developer, create a parser, serializer, mapper, or transformer that processes the desired data, 
and deploy it as a Data Transformation service (Project > Deploy), which will be available to any Receive Port.

If you plan to use Data Transformation as a disassembler, the output of the service must be XML, and the 
input must not be XML. Typically, the service runs a parser or a streamer.

If you plan to use Data Transformation as a custom assembler, the input of the service must be XML. The 
output can have any format. Typically, the service runs a serializer.

For more information about deploying services, see the Data Transformation User Guide.

Building a BizTalk Server Pipeline
You must create one or more BizTalk pipelines that use Data Transformation. Each pipeline has one of the 
following types:

• Receive pipeline. Uses Data Transformation as a disassembler.

• Send pipeline. Uses Data Transformation as an assembler.

The following paragraphs explain the procedures.

Building a Receive Pipeline that Uses Data Transformation

1. Open Microsoft Visual Studio 2005. 

2. To create a new BizTalk project, click File > New > Project. 
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3. In the New Project window, select BizTalk Projects, select Empty Biztalk Server Project, assign a name 
such as Transformation Pipelines, and select a location for the project. 

4. To create a receive pipeline: 

• In the Solution Explorer, right-click the project and click Add > Add New Item > Receive Pipeline.

• Assign a name to the pipeline such as DT Receive Pipeline.

The pipeline file, DT Receive Pipeline.btp, appears under your project in the Solution Explorer.

5. Configure the pipeline to use Data Transformation as the disassembler: 

• View the toolbox and select the BizTalk Pipeline Components.

• Find the DT Disassembler component in the toolbox, or add it if necessary. For more information, see 
“ Data Transformation Components not in Toolbox” on page 16.

• Drag DT Disassembler to the Disassemble box of the pipeline.

6. Set DT Disassembler to work with a specific Data Transformation service: 

• Click DT Disassembler in the Disassemble box.

• In the Properties window, set the Service property to the name of the Data Transformation service 
that the pipeline runs.

7. If you plan to use the pipeline in an orchestration project that uses the BizTalk promote-to-context 
feature, set the SchemaPath property. The property must point to an XSD schema file that defines the 
XML structure generated by the Data Transformation service, including the elements that are promoted. 
See the Microsoft BizTalk documentation for an explanation. 

8. If the Data Transformation service runs a streamer, you can set the StreamerChunkSize property. The 
property is a buffer size that the system passes to the streamer. The chunk size affects the performance 
but has no effect on the output. The default is 1024 KB. 

9. Right-click the project in the Solution Explorer and click Build. 

Building a Send Pipeline that Uses Data Transformation

1. Open Visual Studio 2005 

2. To create a new BizTalk project, click File > New> Project. 

3. In the New Project window, select BizTalk Projects, assign a name such as Transformation Pipelines, 
and select a location for the project. 

4. Create a send pipeline: 

• In the Solution Explorer, right-click the project, and click Add > New Item > Pipeline Files > Send 
Pipeline.

• Assign a name to the pipeline, for example, DT Send Pipeline.

The pipeline file (DT Send Pipeline.btp) appears under your project in the Solution Explorer.

5. Configure the pipeline to use Data Transformation as the assembler: 

• View the toolbox, and select the BizTalk Pipeline Components.

• Find the DT Assembler component in the toolbox, or add it if necessary. For more information, see 
“ Data Transformation Components not in Toolbox” on page 16.

• Drag DT Assembler to the Assemble box of the pipeline.
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6. Set DT Assembler to work with a specific Data Transformation service, typically a serializer. You cannot 
run a streamer service in an assembler. 

• Click DT Assembler in the Assemble box.

• In the Properties window, set the Service property to the name of the Data Transformation service 
that the pipeline runs.

7. Right-click the project in the Solution Explorer and click Build. 

Deploying the BizTalk Project
After you create a receive or send pipeline that uses Data Transformation, you must deploy the BizTalk 
project.

This section presents typical instructions for deploying the project. For more information, see the Microsoft 
BizTalk Server documentation.

1. Confirm that a BizTalk database exists: 

• In Visual Studio 2005, click View > BizTalk Explorer.

• If no database exists, right-click BizTalk Configuration Databases and click Add Database. Type a 
period (.) in the SQL Server box. For the database, select BizTalkMgmtDb, and click OK.

2. Create a Visual Studio 2005 strong name key for your project: 

• Open a Windows command prompt.

• Change to the folder where the BizTalk project is stored.

• Run the sn.exe utility with the -k switch to create a strong name key file. The utility is located in the 
Microsoft Visual Studio 2005 installation folder, in the subfolder SDK\v2.0\Bin.

• The command displays a message stating that a key pair has been written.

For example, to create a file called DTPipeline.snk, type the following at the command prompt:

"c:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Bin\sn.exe" –k DTPipeline.snk
3. Return to Visual Studio 2005, and add the strong name key file to your BizTalk project: 

• In the Solution Explorer, right-click the project and click Properties.

• In the left pane of the project properties, select Assembly, which is located under Common 
Properties.

• In the right pane, find the Assembly Key File property. Click the option at the right of the property, and 
browse to the strong name key file.

• Click OK to accept the new property setting.

4. Right-click the project in the Solution Explorer and click Deploy. This deploys the project. 

Redeploying
If you later edit the BizTalk pipeline, you must redeploy the project.

To redeploy:

1. Confirm that the project is marked to allow redeployment:

• Right-click the project in the Solution Explorer and click Properties.

14       Chapter 2: Using Data Transformation with BizTalk



• In the left pane, select Deployment, which is located under Configuration Properties.

• In the right pane, set Redeploy to True and click OK.

2. Right-click the project in the Solution Explorer and click Deploy. This redeploys the project.

Using the Pipeline in a BizTalk Scenario
After you deploy the BizTalk project, you are ready to use the pipeline in a BizTalk scenario.

You can assign a send pipeline to the send port of the scenario. You can assign a receive pipeline to a 
receive location belonging to the receive port of a scenario. You can assign either type of pipeline to an 
orchestration port.

Assigning a Send Pipeline to a Send Port
The following procedure assumes that you already have a BizTalk scenario to which you will add a pipeline.

1. In Visual Studio 2005, use the View menu to open the BizTalk Explorer. 

2. Right-click the database and click Refresh. 

3. Under the Send Ports node, double-click CM SendPort. 

The Static One-Way Send Port Properties Configurations Send General page appears.

4. In the left pane of the Static One-Way Send Port Properties Configurations Send General page, select 
Send Pipeline. If a send pipeline does not exist, you can create one. For more information, see “Creating 
a Disassembling Process” on page 17. 

5. In the right pane click Send Pipeline, and select the send pipeline from the drop-down list to its right. 

6. Refresh the database again. 

Assigning a Receive Pipeline to a Receive Location
1. Open the BizTalk Explorer. 

2. Right-click the database and click Refresh. 

3. Under the Receive Ports node, expand the tree of the receive port. Double-click the receive location. 

4. In the Receive Location properties, assign the receive pipeline. 

5. Refresh the database. 

Assigning a Pipeline to an Orchestration Port
In addition to the above options, you can assign pipelines that use Data Transformation to orchestration 
ports. You must set the binding of the orchestration port to declarative with a shortcut or to dynamic. For 
more information, see the Microsoft BizTalk documentation.

Using the Pipeline in a BizTalk Scenario       15



Running the BizTalk Application
When you have completed the configuration steps described above, you can run the application in BizTalk 
Server and test that it works correctly with Data Transformation.

To run the BizTalk application:

1. Close Visual Studio 2005.

2. Open the BizTalk Administration Console.

3. In the left pane, right-click the BizTalk Server and start it.

4. Supply an appropriate input.

For example, if the Data Transformation service is a parser that processes text files, drag an appropriate 
text file to the receive location. If the service is a serializer, drag an XML file to the receive location.

5. BizTalk processes the file and writes the output to the destination that you defined for the send port. 
Confirm that the output is correct.

Troubleshooting
The following paragraphs provide some troubleshooting instructions for BizTalk applications that use Data 
Transformation.

Data Transformation Components not in Toolbox
If the DT Disassembler or DT Assembler components are not in the BizTalk Pipeline Component toolbox, add 
them.

To add the Data Transformation components to the toolbox:

1. Click Tools > Choose Toolbox Items. 

2. Click the BizTalk Pipeline Component tab. 

3. In the Name column, find DT Disassembler and DT Assembler and check their boxes. 

If the components do not appear, click the Browse button and select 
Itemfield.ContentMaster.BizTalkPipeline.dll from the Data Transformation installation folder.

4. Click OK. 

The DT Assembler and DT Disassembler components appear in the toolbox.

Viewing the Windows Event Log
If your application did not create an output file in the destination folder, BizTalk or Data Transformation might 
have encountered an error. You can view the error message in the Windows application event log. Look for 
errors having a BizTalk or Data Transformation label.

To view the event log, navigate to Console Root/Event Viewer/Application in the BizTalk Administration 
Console. Alternatively, open the Event Viewer from the Windows Control Panel. Double-click an event to view 
its details.

You can also view the Data Transformation event log. For more information about the event log, see the Data 
Transformation Engine Developer Guide.
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Changing the Type of a Service
If you change the startup component of a transformation in Informatica Developer, for example, from a 
parser to a streamer, BizTalk may take several minutes to display the new type. You can update the type 
immediately by restarting the BizTalk service.

Example: Creating a File-Transfer Scenario that Uses 
Data Transformation

In the above sections, we assumed that you already have a BizTalk scenario, and we provided instructions for 
using Data Transformation in it.

In this section, we provide a step-by-step example of how to create a simple file transfer scenario. The 
scenario uses Data Transformation either to disassemble (parse) a source document or to assemble 
(serialize) the transferred data.

Preliminaries
Before you start creating the scenario, perform these steps, if you have not already done so:

1. Deploy a parser, mapper, or serializer as a service. For more information, see “Creating a Data 
Transformation Service” on page 12.

2. Create a BizTalk pipeline that uses the Data Transformation service.

If you deployed a parsing service, create a receive pipeline. For more information, see “ Building a 
Receive Pipeline that Uses Data Transformation ” on page 12.

If you deployed a serialization service, create a send pipeline. For more information, see “ Building a 
Send Pipeline that Uses Data Transformation” on page 13.

3. Deploy the BizTalk project in which the pipeline is defined. For more information, see “Deploying the 
BizTalk Project” on page 14.

Then continue as described below.

Creating a Disassembling Process
If you deployed a Data Transformation parsing service, perform the following steps. The steps create a 
BizTalk disassembling process that uses your receive pipeline.

If you deployed a serialization service, you must modify the procedure slightly. For more information, see 
“Creating an Assembling Process” on page 19 before proceeding. Then return here and continue the 
configuration.

1. In Visual Studio 2005, open the BizTalk project that you created above, if it is not already open. 

2. Create a receive port, which will use the Data Transformation receive pipeline that you defined above. 

• In the BizTalk Explorer, right-click Receive Ports and click Add Receive Port.

• Select a Static One-Way Port and click OK.

• Assign a name to the port, such as MyReceivePort1, and click OK.

3. Define a receive location for the receive port: 

Example: Creating a File-Transfer Scenario that Uses Data Transformation       17



In the BizTalk Explorer, right-click the Receive Locations node, which is under the receive port that you 
created. Click the Add Receive Location option.

Assign a name to the receive location.

4. In the receive-location properties, select Configurations/General and change the Transport Type to FILE. 

5. Click the … symbol to the right of Address (URI). In the dialog box: 

• Enter a receive location, which is a folder path where the receive port will find its input data.

• Enter a file mask such as *.txt, defining the file type that is processed by the receive port. The file 
mask should be the file type that your Data Transformation parser accepts as input.

• Click OK.

• Set the Receive Handle property to BizTalkServerApplication.

• Set the Receive Pipeline property to the name of the receive pipeline that you defined above.

• Click OK.

6. Create a send port as follows: 

• In the BizTalk Explorer, right-click Send Ports and click Add Send Port.

• Select a Static One-Way Port and click OK.

• Assign a name to the port, such as MySendPort1, and click OK.

7. In the left pane of the send-port properties, expand the tree and select the Configurations/Transport/
Primary node. In the right pane, change the Transport Type to FILE. 

8. Click the browse button at the right of Address (URI). At the prompt, enter a destination location, which 
is a folder path where the send port stores its output. 

For the filename, enter OF%MessageId%.xml. The %MessageID% variable means that the send port inserts a 
unique message ID for each output file that it generates. For example, the send port might output a file 
called OF{16ADAD18-F50D-4345-8F4B-C2F0CAFBC06F}.xml.

9. Click OK to return to the send-port properties window. 

10. Select the Configurations/Send/General node. In this node, you can assign a pipeline to the send port. 

Since you are using Data Transformation in the disassembling direction, do not assign the Data 
Transformation pipeline here. Instead, assign a BizTalk default pipeline that does not change the data. 
From the drop-down pipeline list, select the following entry:

Microsoft.BizTalk.DefaultPipeline.PassThruTransmit
11. Bind the receive port that you created to the send port: 

• Select the Configurations/Filters & Mpas/Filters node.

• Click the right hand side to add a row.

• In the new row, click the Property column and select BTS.ReceivePortName.

• In the Value column of the same row, enter the name of your receive port and click OK.

12. Start the send port: 

• In the BizTalk Explorer, right-click the send port and click Enlist.

• Right-click the send port again, and click Start.

13. Enable the receive location: 

• In the BizTalk Explorer, right-click the receive location, and click Enable.
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Creating an Assembling Process
If you deploy a Data Transformation serialization service instead of a parsing service, you must perform the 
same configuration as for a disassembling process, with one significant exception. You must assign the Data 
Transformation pipeline to the send port instead of the receive port.

Follow the same steps as for a disassembling process, with the following changes. For more information, see 
“Creating a Disassembling Process” on page 17.

• In the receive-location properties (step 4), change the file mask to *.xml. This means that the input is an 
XML file.

• In the receive-location properties (step 4), assign the BizTalk default pass-through pipeline, instead of the 
Data Transformation pipeline.

• In the send-port properties (step 8), change the file name to the appropriate file type. For example, if the 
Data Transformation serializer outputs text files, change the file name to OF%MessageID%.txt.

• In the send-port properties (step 10), assign the send pipeline that uses the Data Transformation service, 
instead of the BizTalk default pipeline.

Running the Scenario
You can now run the scenario in BizTalk. For more information, see “Running the BizTalk Application” on 
page 16.
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