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Abstract
To manage the time spent on archiving data, archive data in small batches over time. This article explains how to 
create and configure entities for batch archiving. It also explains how to configure and schedule the archive project.

Supported Versions
• Data Archive 6.2.2
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Overview
To manage the time spent on data archive activities, archive data in batches over a period of time.

When an archive job runs, it increases the load on the production system. Depending on the size of the data that you 
want to archive, an archive job might take a significant amount of time to complete. To reduce the impact of a single 
long archive job on your production system, archive the data in batches at an optimal time and frequency to meet your 
business needs.
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Because the archive job processes a small amount of data at a time, you minimize the time it takes to detect errors in 
the archive job, resolve the errors, and restart the archive job. Also, because the size of the archive query correlates 
with the amount of data and the number of table relationships, you lower the chances of Data Archive stalling over a 
lengthy archive query.

If the tables are partitioned on the source, you archive each partition in batches.

To archive data in batches, you create and configure an entity with the tables that you want to archive. Then, create the 
archive project and specify the number of rows in a batch and the number of batches you want to archive at a time. If 
the tables in the entity have partitions, specify the partition name. Schedule the archive jobs to run when your 
production system is in least demand, such as between midnight and 4am each week day. The archive job acts on the 
number of batches that you specify. After Data Archive archives all of the batches in the entity or partition, you can 
access the archived data through the Data Discovery portal.

The following image shows a sample entity with two tables. A batch contains rows from one table. Each batch in an 
entity contains the same number of rows. However, the last batch in a table might contain fewer rows than the number 
you specified. You can specify each archive job to process the same number of batches or specify a different number 
of batches for each archive job.

Rules and Guidelines for Batch Archive
Consider the following rules and guidelines when you archive an entity or partition in batches:

• The source must be an Oracle database.

• The ILM repository must be on an Oracle database.

• The target must be the Informatica Data Vault.

• If the tables in the entity have partitions, the tables must have the same partition names.
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• If the tables in the entity have partitions, then you must specify the partition name in the archive project.

• You must select the Archive and Purge action for the Data Archive project.

Note: Although you specify the Archive and Purge action for the project, Data Archive does not delete the data 
from the source. After you verify that the data is in the Data Vault, delete the data from the source according to 
your organization's policy.

• You can include only one entity in the Data Archive project.

• Data Archive creates the XA_TABLE_BATCHES table in the Staging database. Do not delete this table.

• To optimize the archive job and to balance the load on the source, specify the number of active Java thread 
counts you want to run at a time. You specify the thread count in the informia.maxActiveAMThread property 
located in the conf.properties file. The archive job processes one batch at a time for each active thread. For 
example, if you specify a thread count of four, then the archive job processes four batches at a time.

Prerequisites
Before you begin, verify the following prerequisites:

1. Create database users and assign privileges. For information about required database users and privileges, 
see Chapter 3 of the Informatica Data Archive Administrator Guide.

2. Configure properties in the conf.properties file. For information about the conf.properties file, see 
Chapter 2 of the Informatica Data Archive Administrator Guide.

3. Start the ILM application server. For information about starting the ILM application server, see Chapter 1 of 
the Informatica Data Archive Administrator Guide.

4. Configure system profile properties on the Configuration Settings page in Data Archive. For information 
about system profile properties, see Chapter 2 of the Informatica Data Archive Administrator Guide.

5. To determine the optimal number of rows in a batch and the number of batches in a job, run archive jobs with 
varying number of rows in the test environment. Time each job. Review the results and determine the number 
of records that you can archive in the period of time allocated for data archiving.

Airline Example
You use an application called Airline for airline ticket details. The application resides on an Oracle source database. To 
improve source database performance and reduce costs to support the application, you want to archive some of the 
application data.

Four of the Airline application tables contain transactional data related to ticket purchases and coupons. You want to 
archive these four tables together.
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The following table lists the Airline application tables and columns that contain transactional data that you want to 
archive together:

Table Columns

TICKET - TICKET_NUMBER
- ISSUE_DATE
- CUST_ID
- PASSENGER_NAME
- LOCATION

TICKET_COUPON - TICKET_NUMBER
- COUPON
- FROM_CITY
- TO_CITY
- IS_USED

TICKET_SAVE - TICKET_NUMBER
- ISSUE_DATE
- CUST_ID
- PASSENGER_NAME

TICKET_COUPON_SAVE - TICKET_NUMBER
- COUPON
- FROM_CITY
- TO_CITY
- IS_USED

The TICKET table is the parent table. The other tables in the entity are child tables. All tables are partitioned by year. 
The tables have the following partition names:

• 2006-2008

• 2009-2011

• 2012-2014

You want to archive data older than 2012. Because you want to maintain access to the data, you want to archive it to 
the Data Vault. You can allocate four hours each week day for archive activity.

You have 1 billion rows from the parent and child tables with data that is older than 2012. Because of the large amount 
of data that you want to archive, you decide to archive the data in batches. Based on archive jobs that you ran on the 
test environment, you determine that you can archive 100 million rows in a four hour period. You set the number of 
rows in a batch to 5 million. You set the number of batches in each job to 20. By running one archive job a day, you 
expect to archive the 1 billion rows of data over 10 week days.

Batch Archive Tasks
To archive data in batches to the Data Vault, perform the following tasks through the Enterprise Data Manager and 
Data Archive user interfaces:

1. Start the Enterprise Data Manager.

2. Create an application version.

3. Create an application module.

4. Import metadata from the source database.

5. Define the primary key.

5



6. Define the foreign keys.

7. View the association tree.

8. Create an entity.

9. Configure the entity for batch archive.

10. Create a source connection in Data Archive.

11. Create a target connection in Data Archive.

12. Create a Data Vault Access role.

13. Assign the Data Vault Access role to the user.

14. Create and schedule the archive project.

15. Review the row count report.

16. Validate archive data in the Data Vault.

Step 1. Start Enterprise Data Manager
Open Enterprise Data Manager from Data Archive.

1. In Data Archive, select Accelerators > Enterprise Data Manager. 

The Save As window opens.

2. Save RunEdm.jnlp on the local machine. 

3. To open Enterprise Data Manager, run RunEdm.jnlp. 

Note: You must have Java 7 installed on the machine where you run Enterprise Data Manager.

Step 2. Create an Application Version
Create an application version for the application that you plan to archive.

1. In Enterprise Data Manager, right-click Custom Apps Only on the Explorer pane. 

2. Select New Application Version. 

3. Enter the application version name. 

In this example, the application version name is Loyalty_Oracle11g.

4. Click Finish. 
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5. Click the Save icon. 

The Loyalty_Oracle11g application version appears below the Custom Apps Only application.

Step 3. Create an Application Module
After you create an application version, create an application module.

1. In the Explorer pane, right-click the application version. 

2. Select New Application Module. 

The Application Module Wizard appears.

3. Enter a name and an optional description for the application module. If you enter a description, it will appear 
next to the application module in the Explorer pane. 

In this example, the application module name is AIRLINE_LOYALTY. 

4. Click Finish. 

7



In the Explorer pane, the application module appears underneath the application version.

5. Click the Save icon. 

Step 4. Import Metadata from the Source Database
To import table metadata for the application, first define a connection to the source database and then specify the 
application module or schema to import.

When you import metadata, you import a list of tables and other metadata from the source database.

1. In Enterprise Data Manager, expand the application Custom Apps Only in the Explorer pane. 

The list of application versions appear.

2. Click the application version that you created. 

3. Click File > Import Metadata from Database. 

The Connect to Import Metadata from Database window appears.

4. In the Connect to Import Metadata from Database window, create a connection to the Airline source 
database. Configure the following parameters to create a connection: 

Database Type

The type of database that you want to connect to.

Database Host

The name of the machine that hosts the source data.

Database Port

The port number that the source database uses.
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Service Name

Unique identifier or system identifier for the source database server.

User Name

The name of the user that connects to the source database. The user is the owner of the application 
module and tables that you want to import the metadata for.
For Oracle, the user name is the same as the name of the application module.

Password

The password for the database user name.

5. Click OK. 

The Import Metadata from Database Wizard opens.

6. Select the schemas that you want to import metadata from. Double-click a schema to move it to the Selected 
box. Alternatively, select the schema and use the down arrow. 
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In this example, the airline application contains a schema called LOYALTY that includes the tables you want 
to archive.

7. Click Next. 

8. Choose one of the following options: 

• Submit Import Metadata as a Background Job.
Runs the job in the background. If you run the job in the background, you can continue to perform other 
tasks.

• Continue Import Metadata through EDM.
Runs the job in the foreground. If you run the job in the foreground, you must wait until the job completes 
to perform another task. Additionally, if you run the job in the foreground and you have a large volume of 
metadata to import, you might receive memory errors. You might want to run the job in the foreground if 
you have a low volume of metadata to import.

In this example, you submit the metadata as a background job so that you can continue to perform other 
tasks.

9. Click Next. 
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10. Select Update metadata for existing tables. 

11. Click Finish. 

You receive a message that the wizard started the Import Metadata from Database job. You can use the job 
ID in the message to monitor the job status in Data Archive.

12. Click OK to close the message window. 

13. To view the status of the job, go to the Data Archive user interface. 

14. Click Jobs > Monitor Jobs. 

When the job is complete, the job status is COMPLETED. You can expand the job icon on the left to view job 
details.
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Step 5. Define the Primary Key
To create a primary constraint, define a primary key on the table that you want to designate as the parent table.

After you import metadata from the source, determine which transactions you want to archive. Before you create a 
primary constraint, you must identify the parent tables of the transactions that you want to archive. Then define a 
primary key on the parent tables.

1. Click View > Refresh. 

2. Click View > Constraints. 

3. Expand the application version that contains the parent table. 

4. To view the tables, expand the schema or application module. 

5. Select the parent table. 

In this example, the parent table is TICKET.

6. In the Canvas pane, click the Constraints tab. 

7. Click the Add icon. 

A new row appears in the constraints table.
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8. Double-click the Name column and enter a name for the constraint. 

In this example, the constraint is named TICKET_NUMBER PK.

9. Click the Type column and select Primary. 

10. Click Enabled. 

11. In the Details pane, click the Add icon. 

A row appears in the Child Table Columns table.

12. Click the Type column and select column as the type of primary key. 

13. Click the Name column and select the column to use as the primary key. 

In this example, the column is TICKET_NUMBER.

14. Click Save. 

Step 6. Define the Foreign Keys
To create referential constraints, define foreign keys on the tables that you want to designate as child tables.

1. Click View > Constraints. 

2. Expand the application version that contains the child table. 
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3. To view the tables, expand the application module. 

4. Select the child table. 

In this example, you select the table TICKET_COUPON.

5. In the Canvas pane, click the Constraints tab. 

6. Click the Add icon. 

A row appears in the constraints table.

7. Double-click the Name column and enter a name for the constraint. 

In this example, the constraint is named "TICKET_NUMBER FK."

8. Click the Type column and select Referential. 

9. Click Enabled. 

10. In the Details pane, click Find to select the parent table with the primary key that you created. 
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The Find Table window appears.

11. To move the table to the Selected box, select the parent table and click the Down arrow. 

12. Click Finish. 

The selected parent table appears in the Details pane.

13. Next to Parent Constraint Name, select the primary constraint that you created. 

14. Click the Add icon. 
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A row appears in the Child Table Columns table.

15. Click the Type column and select column as the type of foreign key. 

16. Click the Name column and select the column to use as the foreign key. 

17. Click Save. 

18. Repeat the process for each child table that you want to include in the entity. 

In this example, you create referential constraints on the TICKET_SAVE, TICKET_COUPON, and 
TICKET_COUPON_SAVE tables.

Step 7. View Association Tree
After you create constraints, you can view a graphical representation of the table relationships.

1. Click View > Refresh. 

2. Click View > Constraints. 
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3. In the Explorer pane, select the parent table for which you want to view table relationships. 

4. Click View > Association Tree. 

The Association Tree window appears.

5. Verify that the constraints you created between the tables are correct. 
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Step 8. Create an Entity
After you define constraints, create an entity with the tables that you want to archive as a group.

An archive entity consists of related tables that you want to archive together. An entity also includes an interim table 
that the Enterprise Data Manager generates and names when you create the entity. You can create an entity manually 
or use the Multiple Entity Creation wizard to generate the entity.

In this example, you use the Multiple Entity Creation wizard to generate an entity containing the four tables that you 
imported from the LOYALTY schema.

1. Click View > Constraints. 

2. In the Explorer pane, select the application version that contains the entity tables. 

3. Select and expand the application module that contains the entity tables. 

4. Right-click the parent table that you created a primary constraint on. 

This table will become the entity driving table.

5. Select New Entity. 

The Multiple Entity Creation Wizard appears.
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6. To ensure that the child tables you created are added to the entity, select Yes - Within Module and click the 
Down arrow. 

7. Click Next. 

8. Under Tables Types, select All and click the Down arrow. 

9. Click Finish. 

A message appears to inform you that the entity was successfully created.

10. Click OK. 
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11. To view the entity you created, expand the application version and module on the Database Archive tab. 

12. Click Save. 

Step 9. Configure the Entity for Batch Archive
Configure the entity to enable Data Archive to archive the data in batches.

To configure the entity for batch archive, you must perform the following tasks:

• Create batch archive parameters for the entity.

• Delete entity steps that delete the apps table.

• Add the batch archive package to the Run Procedure in Generate Candidate step.

Batch Archive Parameters

Batch archive parameters define the amount of data that you want to archive at a time. If the tables are partitioned on 
the source database, then batch archive parameters also define the partition that you want to archive the data from.

You create the batch archive parameters in Enterprise Data Manager for the entity. You specify the value for the 
parameter in the Data Archive user interface before you run an archive project. When the archive job runs, the 
parameters select the data that meets the parameter criteria and the job creates a list called the archive candidates 
list.

Create the following batch archive parameters for the entity:
P_INFA_MIN_ROWS_PER_BATCH

Placeholder for the number of rows that you want to archive in each batch.

P_INFA_NUM_BATCHES_PER_JOB

Placeholder for the number of batches that you want to process in an archive job.

P_INFA_PART_NAME

Placeholder for the name of the table partition that you want to archive from.

Delete Apps Table

The Delete Apps Table step deletes the application tables from the source database. Data Archive cannot delete data 
from the source after a batch archive. You must delete this step from the entity.

Batch Archive Package

The batch archive package is called infa_gen_step_pkg.gen_steps. The package contains a series of steps that allow 
the archive job to archive the entity in batches. You add the infa_gen_step_pkg.gen_steps package to the Run 
Procedure in Generate Candidate step.
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Configuring the Entity for Batch Archive
To enable Data Archive to process the entity in batches, you must create batch archive parameters. Then, configure the 
entity steps to include a batch archive package and exclude the step that deletes the apps tables.

1. Click View > Database Archive. 

2. In the Explorer pane, expand the application version and module that contain the entity. 

3. Select the entity. 

4. On the Canvas pane, click the Parameters tab. 

5. Click the Add icon three times. 

Three rows appear.

6. Add a batch-archive parameter to each row. The following table lists the information to create the batch 
parameters: 

Order Column Name Data type Required

1 P_INFA_MIN_ROWS_PER_BATCH Number of rows in each batch Number Yes

2 P_INFA_NUM_BATCHES_PER_JOB Number of batches in each job Number Yes

3 P_INFA_PART_NAME Partition name of tables Varchar Yes if the tables have 
partitions.

The following image shows the three batch archive parameters.

7. Click File > Save. 

8. On the Canvas pane, click the Steps tab. 

9. Use the Delete icon to delete the Delete Apps tables steps. 

10. Click the Add icon to add a row. 

11. Click the cell in the Action column and select Run Procedure in Generate Candidates. 

12. Click the cell in the Procedure column and enter: infa_gen_step_pkg.gen_steps 
13. Verify that the Run Procedure in Generate Candidates step is the first step. If necessary, use the arrow 

buttons to move the Run Procedure in Generate Candidates step to the first row. 

14. Click File > Save. 
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Step 10. Create a Source Connection
Create a connection to the source database that stores the application data that you want to archive.

When you create a source connection, you define general properties and database properties. The ILM engine job uses 
the attributes that you specify to connect to the source database. Use the same source connection information that 
you entered to import the metadata in Enterprise Data Manager.

1. Go to the Data Archive user interface. 

2. Choose one of the following options: 

• If you do not have an existing source connection, click Administration > New Source Connection.

• If you have an existing source connection, click Administrator > Manage Connections. Click the Source 
tab. Click the copy icon for the source connection that you want to copy.

The Create or Edit an Archive Source page appears.

3. Define the following general properties: 

Connection Name

Name of the source connection. When you create an archive project and assign a source, you select the 
connection name that you define here.

Connection Description

Long text description for the connection name. When you manage connections, you can use this field to 
filter the list of connections.

Connection Type

Database connection type that determines how you connect to the source database.

Application Version

Business application and application versions that the database connection type supports. The possible 
values depend on the database connection type.

4. Define the following database properties: 

Host

IP address of the source application database server. When the source application server is in an Oracle 
Real Application Cluster, enter the IP address of node1 and the IP address of node 2, separated by a 
comma.

Port

Port of the source application database server. When the source application server is in an Oracle RAC, 
enter the port number of node 1 and port number of node 2, separated by a comma.

Service Name

Unique identifier or system identifier for the source application database server.

When you define an Oracle RAC source database server, enter the service name.

Admin Schema Name

Default administration database user for the source database server, such as SYSTEM.

The administration database user has DBA rights to the database, including the ability to run DDL and 
access system-level objects.

Admin Login Name

Admin Login Name is the same as the schema name.
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Password

Password for the administration login name.

Apps Schema Name

Database user that owns the tables with the data that you want archive. For example, APPS for Oracle 
applications.

Application Login Name

Login name that connects to the source database that contains the data that you want to archive. This 
user does not require special permissions as this value is used for the database connection. You can 
provide any user name, such as a database connection user or a read-only user.

Password

Password for the administration login name.

Staging Schema Name

Staging database user for the source database.

Staging Login Name

Login name for the staging database.

Password

Password for the staging login name.

Staging Tablespace

Tablespace in the staging database user that stores the interim and staging tables when you run an 
archive cycle. The archive job stores the interim tables in this tablespace. The archive job only stores 
staging tables if you enable staging. When you archive data in batches, Data Archive stores the 
XA_TABLE_BATCHES table in this tablespace.

Note: You do not need to enter or update values for the other parameters on the Create or Edit an Archive 
Source page.
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The following graphic shows the source connection parameters:

5. Click Save. 

The system validates the database connection. The Manage Connections page appears with the source 
connection listed on the Source tab.
The following graphic shows the available source connections:

Step 11. Create a Target Connection
Create a connection to the Data Vault which is the target destination for the data that you want to archive.

When you create a target connection, you define general properties and database properties. The Data Vault Loader job 
uses the attributes that you specify to connect to the target.

1. Go to the Data Archive user interface. 
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2. Choose one of the following options: 

• If you have an existing target connection, click Administration > New Target Connection.

• If you have an existing target connection, click Administrator > Manage Connections. Click the Target tab. 
Click the copy icon for the target connection you want to copy.

The Create or Edit an Archive Target page appears.

3. Define the following general properties: 

Connection Name

Name of the target connection. When you create the archive project and you assign a target, you select 
the connection name that you define here.

Connection Description

Long text description for the connection name. When you manage connections, you can use this field to 
filter the list of connections.

Connection Type

Database connection type that determines how you connect to the target database.

Application Version

Business application and application versions that the database connection type supports. The possible 
values depend on the database connection type.

4. Define the following database properties: 

Staging Directory

Directory in which the Data Vault Loader job temporarily stores data as it completes the archive process. 
Enter the absolute path for the directory.
The directory must be accessible to the ILM application server.

Number of Rows Per File

Maximum number of rows that the Data Vault Loader stores in a file in the Data Vault. Default is 1 million 
rows.

Data Vault Data Directory

Directory in which the Data Vault Loader job stores the data. Enter the absolute path for the directory.

Data Vault Archive Folder Name

Name of the archive folder. The Data Vault archive folder corresponds to the database in the Data Vault.

Data Vault Host

Host name or IP address of the machine that hosts the Data Vault Service.

Data Vault Port

Port number used by the ssasql command line program and other clients such as the Data Vault SQL 
Tool and ODBC applications to connect to the Data Vault. Default is 8500.

Data Vault Administration Port

Port number used by the Data Vault Agent and the Data Vault Administration Tool to connect to the Data 
Vault. Default is 8600.

Data Vault User

Name of the administrator user account to connect to the Data Vault Service.
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You can use the default administrator user account created during the Data Vault installation. The user 
name for the default administrator user account is dba.

Data Vault User Password

Password for the administrator user account.

Confirm Password

Verification of the password for the administrator user account.

Note: You do not need to enter or update values for the other parameters on the Create or Edit an Archive 
Target page.

The following graphic shows the target connection parameters:

5. Click Save. 

The system validates the database connection. The Manage Connections page appears with the target 
connection listed on the Target tab.
The following graphic shows the available target connections:
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Step 12. Create a Data Vault Access Role
To validate data through the Data Discovery portal, you create a Data Vault access role. After you create the Data Vault 
access role, you assign the role to the user who performs the data validation step. You also assign the role to the entity 
when you create the archive project. Users with an access role can view archived data in entities with the same access 
role.

When you create a Data Vault access role, you define the name, description, and a period of time that the role is valid.

1. Click Administration > Manage Roles. 

2. Click New Access Role. 

The role name cannot contain special characters.

The Create or Edit a Role page appears.

3. Enter the following Data Vault access role properties: 

Role Name

Name of the role.

Description

Description of the role. When you assign the role to a user, the description appears in the menu of 
available roles.

Valid from

Start date of the user account validity period. Click the calendar icon to select a date.

Valid until

End date of the user account validity period. Click the calendar icon to select a date.

The following image shows the Data Vault access role properties:

4. Click Save. 

The role appears on the Manage Roles page.

After you create the access role, assign the role to a user and the entity that you want to archive.

Step 13. Assign the Data Vault Access Role to User
After you create the Data Vault access role, assign the role to a user. You can assign the role to the default 
administrator user, AMADMIN, or to a user that you create for archive projects.

1. Click Administration > Manage Users. 

The Manage Users page appears.

2. Click the Edit icon next to the user that you want to assign the access role to. 

The Edit Users page appears.

27



3. Click Add Role. 

A new line appears in the Roles table.

4. From the Role menu, select the role that you want to assign to the user. 

Note: The roles appear in the menu as the description you entered when you created the role.

In the airline example, you assign the Data Vault access role AirlineLoyaltyRole, to the user 
AirlineLoyaltyUser.

5. Click Save. 

Step 14. Create and Schedule the Archive Project
To archive data, you must create an archive project. When you create an archive project, you specify the source and 
target connections and the entity to include. Then, you configure the different phases in the archive process and 
schedule the jobs to archive the batches in the partition or entity.

1. In Data Archive, click Workbench > Manage Archive Projects. 

The Manage Archive Projects page appears.

2. Click New Archive Project. 

The Create or Edit an Archive Project page appears.

3. Enter the name of the archive project in Project Name. 

4. Optionally, enter a description. 

5. Click Action and select Archive and Purge. 

6. Select the Source connection. 

A list of source connection properties appear with default values.

7. Update the following source connection properties or keep the default values: 

• Insert Degree of Parallelism. The number of concurrent threads for parallel insertions.

• Update Degree of Parallelism. The number of concurrent threads for parallel updates.

8. Select the Target connection. 

The target connection properties appear.
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9. Update the following target connection properties: 

• Include Reference Data. Select this option if you want the archive project to include transactional and 
reference data from ERP tables.

• Reference Data Store Connection. Required when you use a history database as the source.

In the airline example, you keep the default values for the source and target connection parameters.

10. Click Next. 

11. Click Add Entity. 

The list of entities appear.

12. Select the batch archive entity and click Select. 

Note: When you create an archive project for batch archive, you can add only one entity.

13. Specify values for the following entity parameters: 

• Candidate Generation Report Type. Determines the report that the archive project generates during the 
candidate generation step. You can select Summary, Detail or None.

• Enabled. Determines whether to exclude the entity from archiving. Clear the check box to exclude the 
entity from archiving. Default is enabled.

• Policy. Displays a list of retention policies that you can select for the entity. If you do not select a 
retention policy, the records in the entity do not expire.

• Role. The Data Vault access role for the archive project. The access role determines who can view data 
from Data Discovery searches.
Select the Data Vault access role.

14. Select the Equals operator and enter a value for the batch archive parameters you created in Enterprise Data 
Manager. 

In this example, you renamed the batch archive parameters to the following names:

• Number of rows in each batch. The user specified name for the P_INFA_MIN_ROWS_PER_BATCH 
parameter. Required.
In this example, enter the value 25,000,000.

• Number of batches in each job. The user specified name for the P_INFA_NUM_BATCHES_PER_JOB 
parameter. Required.
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In this example, enter the value 4.

• Partition name of tables. The user specified name for the P_INFA_PART_NAME parameter. Required if the 
tables have partitions.
In this example, enter the name of the first partition 2006-2008.

The following image shows the batch archive parameters:

15. Click Next. 

The archive steps appear.

16. Select the Row Count Report check box for the step Copy to Destination. 

The following image shows the archive steps:

17. Select Publish and Schedule. 

The Schedule Job page appears.

18. In the Schedule section, select On. 

19. Specify the start date and time for the first archive project. Specify the recurrence information. 
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In this example, you specify the job to start at midnight every weekday.
The following image shows the Schedule Job section:

20. Click Schedule. 

The Monitor Jobs page appears with the status of the extract job and the Data Vault Loader job.
When the Data Vault Loader job is complete, the job status is COMPLETED.

Note: The archive project is complete after all the batches in the partition or entity are archived.

21. To check the archive status of the batches in the partition, view the XA_TABLE_BATCHES located on the staging 
database. 

22. After the batches in the previous partition are archived, schedule the archive project again to archive the next 
partition. In this example, the next partition is 2009-2011. 

a. Click Workbench > Manage Archive Projects. 

The Manage Archive Projects page appears.

b. Click the project. 

The Create or Edit an Archive Project page appears.

c. Click Next. 

The Identify Entities tab appears.

d. Optionally, change the value for the Number of batches in each job parameter. 

e. In the Partition name of tables parameter, enter the next partition name: 2009-2011 
f. Click Next. 

g. Click Publish and Schedule. 

h. Click Schedule. 

i. To check the archive status of each batch in the partition, view the XA_TABLE_BATCHES located on the 
staging database. 
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After You Schedule the Archive Project
After you schedule the Data Archive project, Data Archive goes through the following process:

1. Creates metadata that specifies the rows that belong to each batch. Data Archive maintains this metadata in 
the XA_TABLE_BATCHES table in the staging database. Each row in the XA_TABLE_BATCHES table corresponds to 
a batch and specifies the row range in a batch. It also shows the status of each batch during the archive 
process.
The following image shows a sample XA_TABLE_BATCHES table:

2. Data Archive runs the archive jobs at the schedule you specified to sequentially archive all the batches in the 
entity or partition.

3. Data Archive updates the archive status of the batch in the XA_TABLE_BATCHES table.

Step 15. Review Row Count
Review the row count report to verify that the Data Vault Loader job archived the data to the Data Vault.

1. In Data Archive, click Jobs > Monitor Jobs. 

2. Wait for the Data Vault Loader job to complete. 

3. Expand the view for the job. 

4. Expand the view for the Archive Crawler program. 

5. Click View Row Count Report. 

The row count report opens in PDF format.

6. For each table name, check the Discrepancy column. 

If the Discrepancy column is 0, then the Data Vault Loader job moved the data from the source to the Data 
Vault.
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Step 16. Validate Data through the Data Discovery Portal
After Data Archive archives the last batch in the partition or entity, use the Data Discovery portal to search and examine 
data in Data Vault.

Verify that the status of every batch in the partition or entity is set to Completed in the XA_TABLE_BATCHES table.

Use the Browse Data option to access the Data Discovery portal. Specify the archive folder, entity, schema, and table 
you want to browse. Specify the table columns to display in the search results. You can use a WHERE clause to limit the 
search results. You can also specify the sort order of the search results. Before you run the search, you can preview the 
SQL statement that the Data Discovery portal uses to access the data.

1. Click Data Discovery > Browse Data. 

2. Specify the following search parameters: 

Archive Folder

Archive folder that contains the entity of the archived data that you want to search.

No. of Rows

Maximum amount of rows in the search results. Default is 100.

Entity

Entity that contains the table that you want to view archived data from.
Optional. Select the entity to limit the amount of tables shown in the list of values.

Schema

Schema that contains the table that you want to view.

Table

Table that includes the archived data that you want to view.

After you select the table, Data Archive populates the Available Columns list.

3. Use the arrows to move the columns that you want to display to the Display Columns list. 

4. Optionally, enter a WHERE clause in the Where Clause box to filter the search results. 

5. Optionally, specify the sort order of the search results in the Order By box. 

6. Optionally, click Preview SQL to view the generated SQL query. 

7. Click Search. 

33



The records that match the search criteria appear.

8. Verify that the values for the records in Data Vault match the values for the same records on the source 
database. 

After You Archive
After you archive the data, you can access the data and enable compliance. You can also delete the data from the 
source.

You can access the archived data in the Data Vault in the following ways:

• Browse, search, and extract data through the Data Archive data discovery option.

• Query data with the Data Vault SQL Tool.

• Submit an SQL query through Data Visualization to create a report.

• Use a third-party tool to access data in Data Vault.

You can enable compliance in the following ways:

• Apply a retention policy to retain data for a required period of time.

• Apply a legal hold to protect data from modification.

Access to data in Data Vault is based on a system of users and the roles assigned to the user. A user must have the 
same role as the entity to access and enable compliance to the data in Data Vault.

After you verify that you can access your data in the Data Vault, you can start deleting the data from the source in 
accordance with your organization's policy.

Author
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