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Preface
This guide provides information on how to use the SSA-NAME3 Developer’s Workbench - a Java GUI tool that 
helps a programmer understand and prototype SSA-NAME3 calls.

This guide is intended for designers, developers and DBA's of SSA-NAME3. The Workbench in itself is not a 
search and match application. It assists the developer build a search and match application.

Learning About Informatica SSA-NAME3
This section provides details of documentation available with the SSA-NAME3 product.

Introduction to SSA-NAME3
Provides an overview of SSA-NAME3. It is written in a way that can be read by someone who has no prior 
experience of the product and wants a general overview of SSA-NAME3. It explains the problems SSA-NAME3 
overcomes and provides an overview of how this is done. One chapter is dedicated to providing an overview 
for Application Programmers.

Getting Started
This manual is intended to be the first technical material a new developer or designer reads before installing 
or using the SSA-NAME3 software, regardless of the platform or environment. Its goal is to help a new user 
get the software installed and produce a working prototype application that calls SSA-NAME3 and executes 
searches against their own data.

To achieve this it provides a "script" to follow which includes pointers to pertinent sections of the other 
manuals.

Application & Database Design
This manual contains tips and techniques useful for setting up and optimizing a name search and matching 
application, including database issues, and illustrates best-practice techniques, common pitfalls, and 
strategies regarding the subject of name and address matching.

Installation Guide
This manual provides information on how to install the SSA-NAME3 product.
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SSA-NAME3 Workbench User Guide
This is a guide to using the SSA-NAME3 Workbench - a Java GUI tool that helps a programmer understand 
and prototype SSA-NAME3 calls. The Workbench is also used for:

• Generating Sample Program Code;

• Executing SSA-NAME3 Calls;

• Testing different SSA-NAME3 run-time options;

• Producing debugging and support information for Informatica Corporation

Note: The Workbench in itself is not a search and match application. It assists the developer build a search 
and match application.

API Reference
The ultimate goal of an SSA-NAME3 implementation is for application programs to be able to call SSA-
NAME3’s API Functions to build keys and search strategies and to compute match scores and decisions.

This manual describes a typical program process flow for building an identity search application, and also 
lists in detail each of the API Functions. It describes the parameters required by these functions and the 
information returned.

Population Override Manager User’s Guide
This is a guide to using the SSA-NAME3 Population Override Manager - a Java GUI tool that allows a trained 
data analyst to override some of the Standard Population rules that are supplied with the product, or provided 
in the form of a Custom Population. The types of rules that can be overridden using this tool are:

• Edit-list rules

• Frequency tables

• Scalar Frequency Tables

• Matching Purposes

Note: Use of this tool without proper training from Informatica should not be attempted, as improper use can 
adversely affect the reliability and performance of the search application(s).

Edit Rule Wizard User’s Guide
This is a guide to using the SSA-NAME3 Edit Rule Wizard - a Java GUI tool that helps a business user safely 
add certain types of Edit Rules to the Standard or Custom Population without requiring specific knowledge of 
SSA-NAME3 or support from a programmer or data analyst. The types of rules that can be added using this 
tool are:

• Discard a word or phrase when searching and matching (e.g. a new "noise" word)

• Add a new replacement word or phrase when searching and matching (e.g. a new "abbreviation", 
"nickname" or "acronym")

• Add a new compound name marker word

Release Notes
The Release Notes contain information about what’s new in this version of SSA-NAME3. It is also used to 
summarize any documentation updates as they are published.

Preface        5



What Do I Read If. . .

I am. . .
. . . a business manager

The INTRODUCTION TO SSA-NAME3 will address questions such as "Why have we got SSA-NAME3?", "What 
does SSA-NAME3 do"?

I am. . .
. . . a system designer or DBA

The INTRODUCTION TO SSA-NAME3 will address questions such as "What resources are needed to 
implement SSA-NAME3?". The APPLICATION & DATABASE DESIGN manual will lead you through many of the 
design considerations of name search and matching applications.

I am. . .
. . . installing SSA-NAME3

Before attempting to install SSA-NAME3 you should read the Getting Started document. This will describe the 
pre-requisites and help you plan the installation and implementation of SSA-NAME3. The actual installation 
steps for your platform are documented in the Installation Guide.

I am. . .
. . . an Analyst or Application Programmer

A high-level overview is provided specifically for Application Programmers in the INTRODUCTION TO SSA-
NAME3 manual. Before attempting to develop programs that interface with SSA-NAME3, you should also 
read the GETTING STARTED and APPLICATION & DATABASE DESIGN manuals, as well as experimenting with 
calls in the WORKBENCH USER GUIDE.

When developing the application program(s), use the API REFERENCE manual which describes a typical 
application and the Function parameters.

Working example programs that illustrate the calls to SSA-NAME3 in various languages are available by using 
the Sample Program button on the Workbench.

I want to know. . .

. . . what SSA-NAME3 does

The INTRODUCTION TO SSA-NAME3 manual gives an overview of what SSA-NAME3 does and how it does it.

I want to know. . .

. . . how to setup the database

Refer to the APPLICATION & DATABASE DESIGN manual for tips and techniques on configuring the database 
to store SSA-NAME3 Keys and optimizing it for searching and matching.
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I want to know. . .

. . . how to code a search application

The INTRODUCTION TO SSA-NAME3 manual contains a specific section designed to get application 
programmers familiar with the concepts of developing an SSA-NAME3 search and match application.

The API REFERENCE GUIDE details the Function calls required and their parameters. The SSA-NAME3 
WORKBENCH USER GUIDE shows how to generate a sample program in a variety of programming languages.

Informatica Resources
Informatica provides you with a range of product resources through the Informatica Network and other online 
portals. Use the resources to get the most from your Informatica products and solutions and to learn from 
other Informatica users and subject matter experts.

Informatica Network
The Informatica Network is the gateway to many resources, including the Informatica Knowledge Base and 
Informatica Global Customer Support. To enter the Informatica Network, visit 
https://network.informatica.com.

As an Informatica Network member, you have the following options:

• Search the Knowledge Base for product resources.

• View product availability information.

• Create and review your support cases.

• Find your local Informatica User Group Network and collaborate with your peers.

Informatica Knowledge Base
Use the Informatica Knowledge Base to find product resources such as how-to articles, best practices, video 
tutorials, and answers to frequently asked questions.

To search the Knowledge Base, visit https://search.informatica.com. If you have questions, comments, or 
ideas about the Knowledge Base, contact the Informatica Knowledge Base team at 
KB_Feedback@informatica.com.

Informatica Documentation
Use the Informatica Documentation Portal to explore an extensive library of documentation for current and 
recent product releases. To explore the Documentation Portal, visit https://docs.informatica.com.

If you have questions, comments, or ideas about the product documentation, contact the Informatica 
Documentation team at infa_documentation@informatica.com.

Informatica Product Availability Matrices
Product Availability Matrices (PAMs) indicate the versions of the operating systems, databases, and types of 
data sources and targets that a product release supports. You can browse the Informatica PAMs at 
https://network.informatica.com/community/informatica-network/product-availability-matrices.
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Informatica Velocity
Informatica Velocity is a collection of tips and best practices developed by Informatica Professional Services 
and based on real-world experiences from hundreds of data management projects. Informatica Velocity 
represents the collective knowledge of Informatica consultants who work with organizations around the 
world to plan, develop, deploy, and maintain successful data management solutions.

You can find Informatica Velocity resources at http://velocity.informatica.com. If you have questions, 
comments, or ideas about Informatica Velocity, contact Informatica Professional Services at 
ips@informatica.com.

Informatica Marketplace
The Informatica Marketplace is a forum where you can find solutions that extend and enhance your 
Informatica implementations. Leverage any of the hundreds of solutions from Informatica developers and 
partners on the Marketplace to improve your productivity and speed up time to implementation on your 
projects. You can find the Informatica Marketplace at https://marketplace.informatica.com.

Informatica Global Customer Support
You can contact a Global Support Center through the Informatica Network or by telephone.

To find online support resources on the Informatica Network, click Contact Support in the Informatica 
Intelligent Cloud Services Help menu to go to the Cloud Support page. The Cloud Support page includes 
system status information and community discussions. Log in to Informatica Network and click Need Help to 
find additional resources and to contact Informatica Global Customer Support through email.

The telephone numbers for Informatica Global Customer Support are available from the Informatica web site 
at https://www.informatica.com/services-and-training/support-services/contact-us.html.
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C h a p t e r  1

Introduction
The SSA-NAME3 Developer’s Workbench is a Java GUI tool that helps a programmer prototype SSA-NAME3 
calls.

The Workbench is also used for:

• Browser-based Help and Documentation

• Generating Sample Program Code

• Executing SSA-NAME3 Calls

• Testing different SSA-NAME3 parameters

• Producing debugging and support information for Informatica Corporation

In order to use the Developer’s Workbench, the SSA-NAME3 core modules and Standard Populations should 
have been installed, either locally, or on another computer/server.

If SSA-NAME3 was installed on another computer/server, you will first need to start the SSA-NAME3 Server 
process on that computer. To do this, see the SSA-NAME3 Installation Guide.

Note that use of the remote calls (i.e. across a network) to the SSA-NAME3 Server is recommended only for 
development or testing. For production use, your application (or component) should call a local copy of SSA-
NAME3, either directly via the DLL or indirectly via a locally running SSA-NAME3 Server or database stored 
procedure.
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C h a p t e r  2

Launching the Workbench
This chapter includes the following topics:

• Overview, 10

• Launching the Workbench, 10

• Connecting to SSA-NAME3, 12

• Selecting a System and Population, 12

Overview
This chapter takes the reader through a step-by-step guide to using the Developer’s Workbench.

Launching the Workbench
This section provides information on how to launch the Workbench.
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u On a Win32 platform, there will be a Workbench icon in the Start menu, in the Informatica program group. 
Once selected, the Workbench entry screen will be displayed. 

The Introduction to SSA-NAME3 button will launch a document that provides a short introduction to SSA-
NAME3. It can be read by someone who has no prior experience of the product and wants a general 
overview about SSA-NAME3. It explains the problems SSA-NAME3 is designed to overcome and the 
approaches used to do so. There is also a chapter dedicated to providing an overview for Application 
Programmers.

The Documentation button will launch SSA-NAME3’s technical documentation. This documentation 
includes links to INTRODUCTION TO SSA-NAME3, GETTING STARTED, INSTALLATION GUIDE, 
WORKBENCH USER GUIDE, APPLICATION & DATABASE DESIGN, API REFERENCE and RELEASE NOTES.

The All Systems Information button will launch a document that lists the available systems and 
populations that have been installed, along with information about when these were last updated.

The Workbench button launches the Workbench connection screen.

Launching the Workbench       11



Connecting to SSA-NAME3
1. To connect to SSA-NAME3, or load the local DLL, click the Workbench button on the Entry Screen. This 

will launch the connection choice screen: 

2. If SSA-NAME3 was installed on another computer/server, you will need to use the Socket connection to 
connect to the SSA-NAME3 Server. Select Use Socket and enter the Host Name and Port. 

Note: The default port used by SSA-NAME3 is 1665.

3. If SSA-NAME3 was installed locally, select the Use DLL option. 

Selecting a System and Population
On the connection screen, also select the System and Population name you wish to work with. The System 
name is the name of the pr sub-directory where the Standard Populations (files with an extensions of .ysp) 
reside. The System called default is where the installer copies the Standard Population files from the CD. 
You may also have one or more Custom Populations (files with an extension of .ycp).

It is recommended that you copy the Standard Population Files you will be using into a new pr subdirectory. 
The name of that sub-directory could be a name relating to the business system or project name. It is also 
recommended to have different directories/systems for different phases in the project development (e.g. 
dev, test, qa, production).

1. The available Populations will be those you chose to install. Select the most suitable Population for your 
data. 

2. Once you are fine that you are specifying the correct system/population, click the OK button to continue 
into the Workbench and its Function Testing Environment. 
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C h a p t e r  3

The Function Testing 
Environment

The Function Testing Environment of the Workbench is where the actual API functions can be tested. It is 
also where the Documentation is viewed, and sample programs generated.

The screen below shows the first screen displayed when the Function testing Environment is entered. It is the 
ssan3_open function screen.

General Usage Notes
Using the tabs on the left-hand pane you can select from the six available API Functions (Open, Keys, Ranges, 
Match, Close, Info). When a tab is clicked, its available input parameters and parameter values will be listed 
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in the left-hand pane below the tabs. The input parameters are made up of "Controls" to direct what specific 
action the function will take, and "Data" on which the function will perform its actions. Many of these 
parameters are "hotspots", meaning that a mouse click will transfer the selected parameter and value into the 
appropriate text box on the right-hand pane.

If a parameter is a hotspot, the mouse pointer will change to .

Hovering the mouse cursor over a parameter or parameter value will also display a pop-up description of that 
field.

When an API function tab is selected, the right-hand pane will change to show all of the function’s input and 
output parameters as text boxes. Input text boxes have a white background. Output text boxes have a grey 
background. These will be the parameters that are actually used to make the call.

As said in the first paragraph, some of the parameters and values can be easily entered into the text boxes 
via clicks on the values in the left-hand pane, however, others such as the actual name or address data to be 
used in a particular function call must be manually typed or cut and pasted into the input text boxes from 
another location.

Once the text boxes on the right-hand frame are completed, they will closely resemble how you would specify 
the parameters in your own program code. To execute a function, click on the Call button in the lower right-
hand corner of the right-hand pane and view the results. It is useful when debugging program code to put in 
some print or display statements after the call to the SSA-NAME3 function. After running the program to 
produce some debug output, copy the parameters from the program’s function call into the Workbench 
environment to replicate the function call and check if the output is the same.

The Workbench will remember the results of each function as you move around the different functions. Read 
the Functions section in the API Reference Guide for more detail about each function.

File Menu Options

The File menu options are provides as follows:

Options Description

File > Open New Window If more than one Workbench screen is required, use the File > Open > New Window menu 
option. Windows can then be tiled to perform comparison tests between the same 
function type.

File > Close Menu option File > Close will prompt to close the current Function Testing Environment 
session.

File > Exit Menu option File > Exit will prompt to close and exit all Workbench sessions.
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Edit Menu Options

The Edit menu options are provides as follows:

Options Description

Edit > Cut, Edit > Copy, Edit > 
Paste

The menu options Edit > Cut,Edit > Copy and Edit > Paste are useful to allow 
copying of Controls and Data from one textbox to another, or between Function 
screens.

Edit > Clear, Edit > Clear All Menu option Edit > Clear undoes the previous entry. Menu option Edit > Clear All 
clears all entries on the current function screen.

Edit > Contact Details This menu option allows you to enter your contact information. Users are 
advised to complete this information as it helps Informatica Corporation to 
communicate with you regarding product features, diagnostics, and technical 
support. (Informatica Corporation respects your right to privacy. Data collected 
from this form will not be given, sold or shared with organizations external to 
Informatica Corporation).

Tools Menu Options

The Tools menu options are provides as follows:

Options Description

Tools > Export Parameters This menu option allows the parameters and results from the current screen to 
be saved in an external file. You may wish to do this, for example, to email the 
results to another developer.

Help Menu Options

The Help menu options are provides as follows:

Options Description

Help > Overview Selecting Help > Overview will launch the Documentation Overview manual.

Help > Introduction Selecting Help > Introduction will launch the Introduction to SSA-NAME3 manual.

Help > API Reference Selecting Help > API Reference will launch the SSA-NAME3 API REFERENCE manual.

Help > System 
Documentation

Selecting Help > System Documentation will browse the pr sub-folders ("systems") and 
display the available Populations in a new window.

Help|Population > 
Documentation

Selecting Help > Population > Documentation will interrogate the current Population and 
display its internal documentation. This includes information about the Population’s version 
and date, the Code Page(s) used, and the available Field Types, Key Levels, Search Levels, 
Match Purposes, Match Fields and Match Levels.

ssan3_open
Select the Open tab on the left-hand pane and then click the Call button. (No Controls are required). This will 
cause the Workbench to issue an ssan3_open call to SSA-NAME3, and the results will be displayed in the text 
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boxes on the right-hand pane. In the example below, a Session ID of 33554432 has been allocated, and a 
Response Code of "0" indicating a successful call is displayed.

The information displayed in the Messages box contains the version and signature of the core SSA-NAME3 
routine and Population file.

Note: Issuing an Open call is not required to use the other functions; however it is recommended that an 
Open call is done in your application program.
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ssan3_get_keys
This section provides information on ssan3_get_keys.

1. Select the Keys tab. A screen as shown below appears. 

In a run-time environment, the ssan3_get_keys API Function is used to get the SSA-NAME3 Keys into the 
Keys Array, which the application program will store in a database index.

As an example of using this function, the following steps demonstrate how to generate "Standard" Keys 
for the person name "Ann Jackson Smith", using the Tagged method of passing data.

2. Under the Mandatory Controls heading, click Person_Name. This adds the Field=Person_Name 
parameter to the Controls textbox. This will instruct SSA-NAME3 to use the Person_Name Algorithm for 
building keys on the data provided in the Key Field Data textbox. 

3. Under the Optional Controls heading, click Standard. This adds the Key_Level=Standard parameter to the 
Controls textbox. The text in the control box should now look like this:FIELD=Person_Name 
KEY_LEVEL=Standard 

4. Select Person_Name from the Field Type dropdown box. This will add the text *Person_Name* to the Key 
Field Data text box. 

Immediately after the last asterisk in the Key Field Data box, type Ann Jackson Smith.

5. Select End of Data from the Field Type dropdown, or type three asterisks (***) after the name just 
entered. 

6. Click the Call button. The results will appear in the Keys Count and Keys Array boxes below the 
controls, as illustrated below: 
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7. If you select the Hex checkbox, the following screen appears with the hexadecimal equivalent of the 
string: 
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ssan3_get_ranges
This section provides information on ssan3_get_ranges.

1. Select the Ranges tab. A screen as shown below appears. 

In a run-time environment, the ssan3_get_ranges API Function is used to get the SSA-NAME3 Key 
Ranges into the Ranges Array, which the application program would use in a series of Select statements 
to retrieve records from the database.

As an example of using this function, the following steps demonstrate how to generate Typical Search 
key ranges for the person name "Anne Jackson" using the Tagged method of passing data.

2. Under the Mandatory Controls heading, click Person_Name. This adds the Field=Person_Name 
parameter to the Controls textbox. This will instruct SSA-NAME3 to use the Person_Name Algorithm for 
building search key ranges on the data provided in the Key Field Data textbox. 

3. Under the Optional Controls heading, click Typical. This adds the Search_Level=Typical parameter to the 
Controls textbox. The text in the Controls box should now look like this: FIELD=Person_Name 
SEARCH_LEVEL=Typical 

4. Select Person_Name from the Field Type dropdown box. This will add the text *Person_Name* to the Key 
Field Data text box. 

5. Immediately after the last asterisk in the Key Field Data box, type Anne Jackson. 

6. Select End of Data from the Field Type dropdown, or type three asterisks (***) after the name just 
entered. 

7. Click the Call button. The results will appear in the Ranges Count and Ranges Array boxes below the 
controls as shown below: 
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8. If you select the Hex checkbox, the following screen appears with the hexadecimal equivalent of the 
string: 
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Search Check
The Search Check button checks the search key ranges for all available search levels against the keys 
generated in the ssan3_get_keys call. It makes sense to use this button only when trying to prove that a 
search name will or will not find a candidate file name. In other words, this simulates whether the name in the 
ssan3_get_keys call would be found using the name in the ssan3_get_ranges call, and if so, at what search 
level(s).

For this feature to produce results, the Keys and Ranges functions must have been executed in the current 
session.

1. Click the Search Check button after entering the examples above will display the results below. This 
proves that the name "Ann Jackson Smith" when using Standard Keys, would be found by the name 
"Anne Jackson" at all search levels. 

2. Click the Back to Search button to return to the normal Ranges screen. 
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ssan3_match
This section provides information on ssan3_match.

1. Select the Match tab, a screen as shown below is displayed: 

In a run-time environment, once a set of candidate records has been retrieved by the application 
program, the user’s application calls the ssan3_match function to score and further qualify the candidate 
records.

As an example of using this function, the following steps demonstrate how to match the Search Data for 
an "Ann Jackson Smith" living at "555 Harriman Plaza", with the File Data for an "Anne Jackson" living at 
"55 Harrison Plaza", using the "Resident" Match Purpose, a "Typical" Match Level and the "Tagged" 
method of passing data.

2. Under the Mandatory Control heading, click Resident in the list of Purposes. This adds the 
Purpose=Resident parameter to the Controls textbox. This will instruct SSA-NAME3 to use the Resident 
Match Purpose when comparing the search and file records entered below. 

3. Under the Optional Controls heading, click Typical. This adds the Match_Level=Typical parameter to the 
Controls textbox. The text in the Controls will be, PURPOSE=Resident MATCH_LEVEL=Typical. 

4. Select Person_Name from the Field Type dropdown box. This will add the text *Person_Name* to the 
Search Data text box. 

5. Type the name Ann Jackson Smith immediately following the last asterisk. 

6. Select Address_Part1 from the Field Type dropdown box. This adds the text *Address_Part1* directly 
after the name just typed in the Search Data box. 

7. Type the street address 555 Harriman Plaza immediately following the last asterisk. 

8. Select End of Data from the Field Type dropdown, or type three asterisks (***) after the address just 
entered. 

9. Click Tab over to the File Data box. 
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10. Follow steps 3 through 7 above to create a file record with the Name Anne Jackson and the street 
address 55 Harrison Plaza. 

11. Click the Call button. The results will appear in the Decision and Score boxes under the File Data as 
illustrated below: 

The score will be a value between 0 and 100. The Match Decision is based on the pre-set score 
thresholds for this Purpose and Match Level. A Decision of "R" means the records would be Rejected, "U" 
means "Undecided" and "A" means Accepted.
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12. If you select the Hex checkbox, the following screen appears with the hexadecimal equivalent of the 
string: 
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Match Level Comparison
The Match Level Comparison button causes the Match call to be invoked for the same search and file data, 
for each of the available match levels. This shows a comparison of the Decisions and Scores for the different 
Match Levels.

1. Click the Match Level Comparison button after entering the search and file data above will display the 
results below: 

Note: You can refine the Accept and Reject score limits by entering + or - values in the Accept Limit 
and/or the Reject Limit text boxes (in the Optional Controls section of the left handpane). For more 
information, see the Controls section in the API REFERENCE guide.

2. If you select the Hex checkbox, the following screen appears with the hexadecimal equivalent of the 
string: 
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3. Click the Back to Match button to return to the normal Match screen. 

Combining Purposes
Match Purposes can be combined using the operators AND, OR and NOT. Match Filters can also be used in 
combination with Match Purposes. For information on how and why to use filters and combine purposes, 
refer to the Advanced Controls section in the API REFERENCE GUIDE.

The point and click functionality of the Workbench environment currently only supports simple combination 
of purposes (one operator with no match level overrides). To set up more complex multi-purpose controls, 
the details must be manually entered into the Controls text box.

For example, to set up the Controls for the following simple multi-purpose definition using point and click 
items in the left-hand-pane:

PURPOSE=(Individual OR Resident)
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u Click Individual in the left-hand pane, then click the operator OR, then click Resident. The following 
screenshot shows the construction of the Controls: 

Match Explain
The internal logic of the match process can be viewed using the Explain button. This will open a dialog which 
presents the logic of the last match call performed in the form of a tree.
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The score returned by match is the sum of the scores of the individual fields. As can be seen in the example 
above, 2 fields participate in the match process, Address_Part1 and Person_Name. Address_Part1 
contributed 31 and Person_Name contributed 60, giving a total of 91. Note that, in some cases, the total of 
the individual field scores may not equal the returned score due to rounding.
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ssan3_info
This section provides information on ssan3_info.

1. Select the Info tab. A screen as shown below appears: 

The Info screen allows you to interrogate SSA-NAME3 at an individual item level to discover what 
Systems and Populations are available and, for the current Population, what Fields, Purposes, Key Levels, 
Search Levels, Match Levels and Efields are available.

2. To display the Match Purposes available to the USA population, select the purpose item and click Call. 
The following screen is displayed: 
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This information can also be summarized.

3. To summarize the information, select Help > System Documentation or Help > Population 
Documentation menu options. 

Other Menu Options
This section provides information on the other menu options.

Sample Program
The Workbench can generate program source code with example calls to the SSA-NAME3 API in various 
programming languages.

To use this functionality, first make sure that you have called all of the SSA-NAME3 API functions that you 
wish to include, in your current Workbench session.

1. Click the Sample Program icon at the top of the screen. 

The Select Programming Language will be displayed.

2. Select the programming language to be generated. 

The API Functions that have been called in the current session will be automatically selected. The 
ssan3_open and ssan3_close will be auto-selected as they do not require additional control parameters.
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3. Unselect any API functions that is not required and click OK. In this example, a C program was 
requested. 

4. Click OK, a sample program in C will be displayed as shown below. 
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Use the drop-down list to access examples for other languages such as Java, C++, Cobol, Visual Basic, 
PL/SQL etc.

Note: These sample programs are intended to be working examples of the call interface only. They do 
not include any database I/O functionality (or screen dialogue) as will be required in an actual key 
building or search and match program.

5. To copy and paste the code into your application code, use the Edit menu option. 
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6. To save the sample code as a starting point for your actual application, use the File menu option. 

If you require help in designing a searching and matching application using SSA-NAME3 , see the API 
REFERENCE guide (this contains a description of the various API calls, parameters and a high level 
program flow guide). Alternatively, contact your Informatica Corporation support office. Our Tech 
Support team will be happy to help in explaining the details and conceptual use of our products. (Ensure 
to check our Online Support Library for more enhanced code examples as they become available).

Diagnostic Report

At times, individual results from SSA-NAME3 calls via the Workbench or from your application may need to be 
explained or reported to Informatica Corporation Technical Support. In those cases, we recommend that you 
copy the relevant input data to the Workbench, and call SSA-NAME3 to duplicate the problem. Once you have 
done so, you can use the Diagnostic Report button to generate a report that contains the input and the 
results from the SSA-NAME3 call.

When you click the Diagnostic Report button you will be prompted to enter a description of the problem and a 
filename where the report can be stored. The Workbench will then create a file with your contact details and 
the input/output from calls to SSA-NAME3. You can then send this file to Informatica Corporation for further 
investigation.

Note: You can record multiple such cases to the same report file.

Using Batch Input/Output with Workbench
The SSA-NAME3 call parameters from a session can be also be stored in a format that can be later run back 
through the Workbench in batch mode. This batch facility can also be used to run the Workbench in batch 
mode with fresh input derived from an input file.

You need to discuss your reasons for wanting to use the batch input/output features below with Informatica 
Corporation technical support, as using these features will require modifying the Workbench’s program 
shortcut (in Windows) or the startup script (for Unix).

Firstly you will need to create a batch input file that can be used to drive the Workbench in batch mode.

Recording Input from a Workbench Session
This section provides information on how to record from a Workbench session.

1. Modify the Workbench’s shortcut properties (in Windows - use the Start menu to access the Workbench 
shortcut, and right-click to obtain the shortcut Properties. Changing the command line (e.g. 
C:\InformaticaIR\bin\wrkbench.bat) by adding the -cFileName parameter will set the shortcut up to 
start the WB client in record mode. For example, specifying: 

C:\InformaticaIR\bin\wrkbench.bat -cc:\temp\test.txt
This will start the Workbench in record mode and allow you to record all your calls in the file called 
test.txt in the c:\temp directory.

Note: If you are planning to use the Batch mode frequently, it is convenient to create separate shortcuts 
or scripts for each mode.

After entering the Workbench, the following screen will be displayed:
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2. To start recording, click the Create New Record button, then input your call criteria, perform the 
appropriate call to SSA-NAME3. 

3. Click the Record Input Parameters button. 

Repeat as many times as there are input records. Once you have recorded enough, completely closing 
the Workbench which will write and close the batch file.

An example of the saved file containing two input records is shown below:

RECORD NUMBER= 1
*=================
ssan3_get_keys
*=================
SYSTEM= default
POPULATION= usa
CONTROLS= FIELD=Person_Name KEY_LEVEL=Standard
KEY-FIELD-DATA= *Person_Name*Ann Jackson Smith***
*
ssan3_get_ranges
*=================
SYSTEM= default
POPULATION= usa
CONTROLS= FIELD=Person_Name SEARCH_LEVEL=Typical
KEY-FIELD-DATA= *Person_Name*Anne Jackson***
*

Creating Input from Scratch
If you would like to manually write your own batch input file, instead of using the Workbench to create the file, 
follow the syntax above (or create a few sample records using the Workbench) and then clone them to create 
your own input file.
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Running the Workbench in Batch Input Mode
This section provides information on how run the Workbench in batch mode.

1. To start the Workbench so that it can read from batch input files, modify the shortcut or script to add ’-b’ 
parameter. 
C:\WINDOWS\COMMAND.COM /E:3000 /C C:\InformaticaIR\bin\wrkbench.bat -b

2. Start the Workbench and open the file that contains the input records and parameters using the File > 
Open Batch File menu option. 

3. Select the file containing the input records. 

4. To navigate between the records, click the Next and Previous buttons on the Workbench screen. 

5. To close the file, choose File > Close Batch File. 

Screen Capture
The Workbench has the ability to save screen-shots (as JPEG images) on some platforms. This feature may 
be unavailable in the future, since it relies on a deprecated feature of Java.

To enable screen capturing, invoke the Workbench with the -r parameter as follows:

C:\WINDOWS\COMMAND.COM /E:3000 /C C:\InformaticaIR\bin\wrkbench.bat -r<dir>
where

<dir> 

is the name of an existing directory to store the images. Once started with this parameter, the File menu will 
contain options to start and stop screen capturing. The images are stored in the nominated directory using 
generated file names.
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