Table of Contents

Search

  1. Preface
  2. The Transformation Language
  3. Constants
  4. Operators
  5. Dates
  6. Functions
  7. Creating Custom Functions
  8. Custom Function API Reference
  9. POWERCENTERHELP

Transformation Language Reference

Transformation Language Reference

Building the Module on Windows

Building the Module on Windows

On Windows, you can use Microsoft Visual C++ to build the module.
To build the module on Windows:
  1. Start Visual C++.
  2. Click File > New.
  3. In the New dialog box, click the Projects tab and select the Win32 Dynamic-Link Library option.
  4. Enter its location.
    In the Echo example, enter the following directory:
    <Informatica Development Platform installation directory>\CustomFunctionAPI\samples\echo
  5. Enter the name of the project.
    You must use the module name specified for the custom function as the project name. In the Echo example, enter EchoDemo.
  6. Click OK.
    Visual C++ creates a wizard to define the project components.
  7. In the wizard, select an empty DLL project and click Finish. Click OK in the New Project Information dialog box.
    Visual C++ creates the project files in the directory you specified.
  8. Click Project > Add To Project > Files.
  9. Navigate up a directory level. This directory contains the procedure files you created. Select all .c files and click OK.
    In the Echo example, add the Echo.c file.
  10. Click Project > Settings.
  11. Click the C/C++ tab, and select Preprocessor from the Category field.
  12. In the Additional Include Directories field, enter the following path and click OK:
    ..; <Informatica Development Platform installation directory>\CustomFunctionAPI\samples\echo; ...
  13. Click Build > Build <module_name>.dll or press F7 to build the project.
    Visual C++ creates the DLL and places it in the debug or release directory under the project directory.