Table of Contents

Search

  1. Preface
  2. Welcome to Informatica Process Developer
  3. Using Guide Developer for the First Time
  4. Getting Started with Informatica Process Developer
  5. About Interfaces Service References and Local WSDL
  6. Planning Your BPEL Process
  7. Participants
  8. Implementing a BPMN Task or Event in BPEL
  9. Implementing a BPMN Gateway or Control Flow
  10. Using Variables
  11. Attachments
  12. Using Links
  13. Data Manipulation
  14. Compensation
  15. Correlation
  16. What is Correlation
  17. What is a Correlation Set
  18. Creating Message Properties and Property Aliases
  19. Adding a Correlation Set
  20. Deleting a Correlation Set
  21. Adding Correlations to an Activity
  22. Rules for Declaring and Using Correlation Sets
  23. Correlation Sets and Engine-Managed Correlation
  24. Event Handling
  25. Fault Handling
  26. Simulating and Debugging
  27. Deploying Your Processes
  28. BPEL Unit Testing
  29. Creating POJO and XQuery Custom Functions
  30. Custom Service Interactions
  31. Process Exception Management
  32. Creating Reports for Process Server and Central
  33. Business Event Processing
  34. Process Central Forms and Configuration
  35. Building a Process with a System Service
  36. Human Tasks
  37. BPEL Faults and Reports

2. Designer

2. Designer

Configuring a Remote Process Connection

Configuring a Remote Process Connection

Set up a configuration to indicate where processes are running and how you want to attach to them.
As a first step in remote debugging, you must set up a configuration to indicate where processes are running and how you want to attach to them.
  1. From the
    Run
    menu, select
    Debug Configurations
    .
  2. In the Debug Configurations dialog, select Remote Process, and then select
    New
    .
  3. In the Name field, you can change the default configuration name, if desired, to make it more meaningful. This is useful if you set up multiple configurations to various servers or for various authenticated users.
  4. In the Main tab, the default Server URL is displayed for the Process Developer engine embedded with Process Developer. Modify this URL if you want to point to the Process Developer engine in another location or to a different Process Server.
  5. In the Process Selection panel, select what processes you want to debug, and refer to Selecting Processes for Remote Debugging for details.
    Manual process selection or breakpoints
    A list of attached processes appears in the Debug view, and you can right-mouse click on the process to connect to it.
    Prompt for process selection from list
    When you select Debug, a dialog box appears displaying running or completed processes available for debugging
    Stop on next process instance creation
    When you select Debug, a "Waiting" message appears until a process instance is created for any deployed process. Once the process is instantiated, the local copy of the process opens in the Process Editor for debugging. Refer to Options Tab below to hide the waiting message for the current debug configuration and to Remote Debugging Preferences to hide the waiting message for all processes.
  6. In the Process location field, type in a process name, if desired. Only processes of this name are attached to during instance creation and are used as the default filter for process lists.
    If desired, you can type in the qualified name, enclosing the namespace in curly braces, as shown in the example. By using the qualified name, you can pinpoint processes of similar names using different namespaces.
  7. Enable the option Attach to any process on breakpoint, if desired, to indicate that any local copy of a process containing a breakpoint is attached to, if not already attached, when a breakpoint is hit.
    Do not enable this option for processes running on a high volume server. Remote debugging can impact performance.
Authentication Tab
  1. Select one of the following:
    • No credentials required. No username and password are required to access the Process Server.
    • Always prompt for credentials when connecting. Prompt for username and password when beginning a remote debug session for a running process on Process Server.
    • Use supplied credentials when connecting. Use the Username and Password filled in below when connecting to the Process Server.
  2. Enter a Username and Password, if required, for the Server URL.
Options Tab
You can select options for a particular debug configuration that override the default settings listed in Preferences. Preferences are located in
Window > Preferences > Process Developer > Remote Debug
. For details on the default settings, see Remote Debugging Preferences.
Common Tab
  1. Select the Common tab.
  2. Modify the following defaults, if desired:
    • Local or Shared File. You can select Shared and then save the currently named configuration to a workspace folder to share it. The configuration settings are added to an XML file named
      configuration_name
      .launch.
    • Display in Favorites menu. By default the Debug and Run icons are displayed on the Process Developer toolbar.
    • Standard Input and Output. By default, input is displayed on the Console, and you can also send output to a file.
Starting a Debug Session
Select one of the following to start or delay a remote debug session.
  • Select
    Apply
    to save this configuration and continue creating another configuration
  • If the server is running, select
    Debug
    to save and begin remote debugging for the current configuration
  • If the server is not running, select
    Close
    . The configuration is saved, and you can run it from the Debug As list in the main toolbar.


Updated March 30, 2020